57

eero Labs features and feedback thread

Welcome to the eero Labs features and feedback thread!

Here is your place to share your experiences with new eero Labs feature releases, as well as let us know the types of future concepts you'd like to see here. We encourage you to share your feedback and interact with others, as well as have an opportunity to interact directly with our developers.

While this section will be more focused on connectivity related features, you can also submit general feature requests here.

For more on eero Labs, visit the eero help center.

1097 replies

    • Cristian.1
    • 2 yrs ago
    • Reported - view

    Seems WPA3 kicks off devices that don’t support the standard.. despite the text by the option stating “for devices that support the WPA3 standard. Doesn’t indicate it will turn off WPA2. Is there a way it isn’t an all-or-nothing option so that all devices can be supported?

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello Cristian ,

      In my experience it is usually the device that ends up being the decider on whether or not it stays connected to a network. It is also important to remember that the WPA3 feature in the eero app is still a beta feature that is still be optimized. We would like to look into this for you if you have time to reach out to support so we can gather information about the device or devices that are experiencing difficulty accessing the network while WPA3 is enabled and look into this on the backend for you. If you would like you give us a call you can use the link below to locate the best number to call. If you would like to troubleshoot over email, please follow the directions that I will be direct messaging you shortly.

      https://support.eero.com/hc/en-us/articles/207376426-How-do-I-contact-eero-support-

      • Cristian.1
      • 2 yrs ago
      • Reported - view

      James Hi thanks for your reply. Totally aware it’s in beta which is why I pass feedback so it can be looked into before alpha.

      Long story short; turn off WPA3 I am able to connect my AppleTV Gen3 to the network. Turn on WPA3, AppleTV Gen3 says my password is wrong before I’m even given an opportunity to type it in. SSID still seen. This indicates to me on a high-level that issue is down to authentication.

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello Cristian ,

      Good to know that disabling WPA3 allowed your devices to connect to your network. If you have time, I would like to get additional information about the devices you experienced the drops with WPA3 enabled on your network. Can you send me an email so I can verify your account and gather more information about the devices that were experiencing this?

      • Calion
      • 2 yrs ago
      • Reported - view

      James I reported a similar issue upthread and was told, basically, to suck it up.

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello Calion ,

      I would like to get your device information as well. I will send you direct message on how to get that information to me. But keep in mind that everything that cMoo82 said is true. Some older devices are just not going to be able to support WPA3 or connected to a network that has WPA3 enabled on it. Something to keep in mind is that you do not need WPA3 enabled to use Optimize for Conferencing and Gaming to be enabled. I will send you that information on out to get that information to me soon over Direct Message.

      • Calion
      • 2 yrs ago
      • Reported - view

      James I understand that older devices can't connect via WPA3. But I don't understand why they can't connect via WPA2 if the network has WPA3 enabled.

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello Calion ,

      I understand that this can be frustrating. This can be a very difficult topic to understand. I will share some information from our knowledge base article that explains this a little better.

      Issues to watch out for

      Even though transition mode is designed to support WPA2 and WPA3 simultaneously, our testing has revealed interoperability issues with some legacy devices. We would like to highlight a few of the interoperability symptoms we have encountered to help prepare you for some behavior you may experience:

      1. Clients appear to be associated using WPA2 but cannot get an IP address because the DHCP client on the connected device is not responding to incoming packets from the eero APs
      2. The eero network appears as an “Open” network, preventing clients from connecting
      3. When attempting to connect to the eero network from a list of available wifi networks, the client device is unable to connect
      4. Client devices display an 'incorrect password' error when attempting to connect
      5. Client devices switch continuously between WPA2 and WPA3 and ask for the password every time

      If you notice a device isn’t able to connect after turning on WPA3 or if you're seeing other symptoms mentioned above, you may need to update that device to the latest available software or use an updated device if available. We recommend contacting the device manufacturer for any devices that have difficulty connecting when WPA3 is enabled.

      Known Problematic Devices

      Below are some of the devices or software versions may have compatibility issues with WPA3.

      • Devices using Apple iOS 12.2 (newer versions of iOS work correctly)
      • Chamberlain MyQ Garage Door Opener

      This can be found in our article that goes over WPA3. Here is the link if you would like to see the full article: https://support.eero.com/hc/en-us/articles/360042523671-What-is-WPA3-

      I understand that this is not a resolution to the behavior you are experiencing. But iOS 10 devices, from everything I have found on the subject, are not able to join WPA3 networks even if those networks have a transitional mode that supports some WPA2 connections while WPA3 is active like what the eero offers. You can also find more information regarding this in this link: https://support.apple.com/guide/security/protocol-security-sec8a67fa93d/web

      • Travisp
      • 2 yrs ago
      • Reported - view

      Hi James . The KB article seems to contradict the experience of multiple people: I reported about a month ago in this thread problems with iPhones 11 Pro and one iPhone X which were on iOS 14 (whatever the latest was at the time).  I'd bet that Adams  who wrote two weeks ago about problems with IPhones X, 11, and SE2 was also using post-iOS 12.2 on his devices (the SE2 only supports iOS 13+, so we can be positive about that one).  It seems that devices using even recent versions of iOS still have problems with WPA3.

    • Adams.1
    • 2 yrs ago
    • Reported - view

    Ive actually given up with having wpa3 enabled. My iPhones would be continuously booted off and find it very hard to reconnect  ( iPhones X, 11 & se2 ). My laptop download speed would run slow. And a few other things at times. It’s so odd??!!? 
    having it disabled, gives me full speed via wifi again (538mb/s) 

    • mstoeckert
    • 2 yrs ago
    • Reported - view

    It would be great to do QOS by profile. Remote work is hear to stay and with that having a work profile that is prioritized above other profiles for home and smart devices would be great.

    • Greygorn
    • 2 yrs ago
    • Reported - view

    I had to disable WPA3 due to my teckin smart plugs not connecting, tried several times with resets etc different phones and no luck connecting. As soon as I turned WAP3 off I could connect to every one and get them online.

    • SqueezyDonutz
    • 2 yrs ago
    • Reported - view

    Would love to see channel selection added, with a rating of how clear or congested each channel is.

    • rayb30
    • 2 yrs ago
    • Reported - view

    With advanced security enabled in eero secure, local dns caching in eero labs will disappear.  One advanced security is disabled, local dns caching option reappears. I hope this will be fixed with an update. It would be nice if the local dns caching was grayed out and had a disclaiming like in dns settings in the network settings.

    • anotherJmartin
    • 2 yrs ago
    • Reported - view

    With the 6.5 update, I saw this in the release notes:

    • fix for failed connectivity with WPA3 enabled on some Apple devices

    We have 2 very old iPads running iOS 10.3.3. I know previously older devices that don't have WPA3 we unable to connect. I'm wondering if this update is supposed to fix that particular issue? Or will all the older Apple devices never be able to connect to the network if WPA3 is enabled?

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello anotherJmartin ,

      If a device that doesn't support WPA3 connections, can connect to a WPA3 network that uses a transition mode like eero, then it should still connect to the network but it will use WPA2 since it is not able to connect to WPA3. From what I researched, some older versions of iOS do not support connecting WPA3  "transition mode" and so would not be able to connect. That is entirely handled on the iOS firmware and software and it entirely out of the hands of eero. 

      https://support.eero.com/hc/en-us/articles/360042523671-What-is-WPA3-

    • mporkert
    • 2 yrs ago
    • Reported - view

    With the 6.5 update I have a Samsung Fridge and a Honeywell T9 that can’t connect when WPA3 is enabled. They can’t see the WiFi NW neither 2.4 nor 5. 
     

    The Honeywell Thermostat is supported as a Ring Integration. 

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello Mike Porkert ,

      Thank you for reaching out to us and welcome to The Community! Were the devices able to connect to your network with WPA3 enabled prior to the update? When you connect the devices with WPA3 disabled can you check to see if the devices have any firmware updates? Are you able to verify if the devices are able to connect to WPA3 networks?

      • mporkert
      • 2 yrs ago
      • Reported - view

      James 

      • mporkert
      • 2 yrs ago
      • Reported - view

      Mike Porkert 

       

      I just got the Eero’s so they were on 6.4 only a day. So I don’t remember on the Fridge. But the thermostat yes it could connect  

       

      But there is more. In 6.5 the thermostat suddenly could not communicate to the cloud service. It was connected to WiFi. When I briefly turned off 5G in troubleshooting. it worked. Then the moment 5G re-enabled it could not connect to the cloud. All the time it was connected to WiFi per the app. 
       

      Then I enabled legacy. It worked to connect to the cloud. I left it on legacy for 12 hours. All was fine. Then I disabled legacy and the thermostat is still connected to the cloud now on 5G. So now it works but makes no sense to me why. 

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello Mike Porkert ,

      Ahh that makes sense. So Legacy turns your 2.5GHz bandwidth back to WiFi 5 instead of WiFi 6. There is a possibility that the devices are having problems with WiFi 6. If they work correctly with legacy mode enabled I would keep that enabled so your devices work correctly. Check with the manufacturers of the devices and ask them if their devices are able to connect to WiFi 6 networks as well if you have the time.

      • mporkert
      • 2 yrs ago
      • Reported - view

      James 

      yes that makes sense to me too. But I am confused that once I turned off legacy I expected the Thermostat to disconnect but instead it is working correctly now on both 2.4G and 5G

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello Mike Porkert ,

      That is really interesting. Keep an eye on it and if the device continues to have issues mark down the time and date and let me know so we can check the logs on our back end.

      • mporkert
      • 2 yrs ago
      • Reported - view

      James 

      The thermostat disconnected today around 9 pm. Turned legacy on and reconnected. I will disable legacy tomorrow am to see if the thermostat stays connected. 

      • mporkert
      • 2 yrs ago
      • Reported - view

      Mike Porkert 

      And I disabled legacy just now at 6 am EST and the Thermostat is still connected and working. 

Content aside

  • 57 Likes
  • 5 mths agoLast active
  • 1097Replies
  • 51726Views
  • 499 Following