7

WHAT HAVE YOU DONE!? Insane packet loss.

Tried on the same computer, and 2 different (but identical) computers (All Macbook Pro Intel)... same window of time...  

 

Its not my Fiber connection, and its not my ISP., or my any of my other routers...but look'ie what EERO does:

 

(NO, Eero tech people, I'm not your test engineer, I'm your customer, figure your own shit out)

 

After the latest (6.6.0) update--

 

EERO-6 vs. My ISP's (AT&T)'s WIFI provided modem:

 

MacBookH ➜   ping 8.8.4.4   <--- EERO 6 Pro

64 bytes from 1.1.1.1: icmp_seq=158 ttl=54 time=14.992 ms
Request timeout for icmp_seq 159
64 bytes from 1.1.1.1: icmp_seq=160 ttl=54 time=16.959 ms
64 bytes from 1.1.1.1: icmp_seq=161 ttl=54 time=33.592 ms
64 bytes from 1.1.1.1: icmp_seq=162 ttl=54 time=180.074 ms
64 bytes from 1.1.1.1: icmp_seq=163 ttl=54 time=196.682 ms
64 bytes from 1.1.1.1: icmp_seq=164 ttl=54 time=199.880 ms
64 bytes from 1.1.1.1: icmp_seq=165 ttl=54 time=226.821 ms
Request timeout for icmp_seq 166
Request timeout for icmp_seq 167
Request timeout for icmp_seq 168
Request timeout for icmp_seq 169
Request timeout for icmp_seq 170
Request timeout for icmp_seq 171
Request timeout for icmp_seq 172
Request timeout for icmp_seq 173
Request timeout for icmp_seq 174
Request timeout for icmp_seq 175
Request timeout for icmp_seq 176
Request timeout for icmp_seq 177
Request timeout for icmp_seq 178
64 bytes from 1.1.1.1: icmp_seq=179 ttl=54 time=15.916 ms
64 bytes from 1.1.1.1: icmp_seq=180 ttl=54 time=44.537 ms
Request timeout for icmp_seq 181
64 bytes from 1.1.1.1: icmp_seq=182 ttl=54 time=14.510 ms
64 bytes from 1.1.1.1: icmp_seq=183 ttl=54 time=20.719 ms

 

AT&T's provided wifi modem:

MacBookH ➜   ping 8.8.4.4  <-- CHEAP AT&T Wifi 
PING 8.8.4.4 (8.8.4.4): 56 data bytes
64 bytes from 8.8.4.4: icmp_seq=0 ttl=58 time=14.521 ms
64 bytes from 8.8.4.4: icmp_seq=1 ttl=58 time=15.761 ms
64 bytes from 8.8.4.4: icmp_seq=2 ttl=58 time=15.923 ms
64 bytes from 8.8.4.4: icmp_seq=3 ttl=58 time=28.138 ms
64 bytes from 8.8.4.4: icmp_seq=4 ttl=58 time=12.035 ms
64 bytes from 8.8.4.4: icmp_seq=5 ttl=58 time=17.005 ms
64 bytes from 8.8.4.4: icmp_seq=6 ttl=58 time=18.071 ms
64 bytes from 8.8.4.4: icmp_seq=7 ttl=58 time=13.159 ms
64 bytes from 8.8.4.4: icmp_seq=8 ttl=58 time=16.233 ms
64 bytes from 8.8.4.4: icmp_seq=9 ttl=58 time=14.217 ms
64 bytes from 8.8.4.4: icmp_seq=10 ttl=58 time=16.452 ms
64 bytes from 8.8.4.4: icmp_seq=11 ttl=58 time=16.151 ms

73 replies

    • NMS_SALON
    • 1 yr ago
    • Reported - view

    I’m experiencing the EXACT issue as other EERO owners have reported.

     

    My setup:

    - All EEROs (6) are WIRED to one 24 Port TP-LINK TL-SG1024DE Switch

    - Utility Room EERO = Gateway EERO

    - All other EEROs are basically Wired Access Points

    - Modem Plugged into EERO Gateway

     

    Things I have tested:

    - Ping EERO Gateway using wired MacBook connected via 1GB switch (no packet loss)

    - Ping Modem using wired MacBook connected via 1GB switch (no packet loss)

    - Ping Modem using wired MacBook connected directly to EERO Gateway (no packet loss)

    - Ping other EEROs using wired MacBook connected directly to EERO Gateway (no packet loss)

     

    - Ping 1.1.1.1 using wired MacBook connected via 1GB switch (packet loss)

    - Ping 1.1.1.1 using MacBook connected wirelessly (packet loss)

    - Ping 1.1.1.1 using wired MacBook connected directly to EERO Gateway (packet loss)

    - Ping 1.1.1.1 using wired MacBook connected directly to Modem (no packet loss)

    - Ping 1.1.1.1 using iPad connected directly to an iPhone 14 Pro Max Hot Spot (no packet loss)

     

    - Ping 8.8.8.8 using wired MacBook connected via 1GB switch (packet loss)

    - Ping 8.8.8.8 using MacBook connected wirelessly (packet loss)

    - Ping 8.8.8.8 using wired MacBook connected directly to EERO Gateway (packet loss)

    - Ping 8.8.8.8 using wired MacBook connected directly to Modem (no packet loss)

    - Ping 8.8.8.8 using iPad connected directly to an iPhone 14 Pro Max Hot Spot (no packet loss)

     

    Settings things I have tried:

    - Turning UPnP on/off (no improvement)

    - Turning IPv6 on/off (no improvement)

    - Turning Backup Internet on/off (no improvement)

    - Turning Guest Network on/off (no improvement)

     

    Hardware things I have tried:

    - Tried Swapping Modem. CM700 for another CM700. (no improvement)

    - Upgraded Mode from CM700 to CM2000 (no improvement)

    - Removing Access Points Temporarily - Power (some improvement)

    - Removing/Readding Access Points - Network Config/App Wise (some improvement)

    - Forcing the Access Points to be Repeaters - Unplugging Wired Back Bone Connection (no improvement)

     

    So far the only that seems to help is if I remove all the access point EEROs from my network, leaving only a single gateway EERO.

     

    Packet loss STILL occurs when using the one gateway EERO, but the latency is better (closer to 20 MS vs. ~70 MS with all EEROs connected). Problem is I’m trying to cover 6000 square feet…

     

    Personally, it sounds like EERO has a MAJOR hardware or firmware problem on theirhands and these things should be recalled.

     

    I had used Google WiFi previously for years and never had any problems. I only "upgraded" to EERO because I wasn't happy with the Google WiFi app. Little did I know I was going to spend $1,000 just to buy a bigger problem! :(

      • peterconnor66
      • 1 yr ago
      • Reported - view

      NMS_SALON  my ping is 9 to 10 when you buy something I don’t expect to spend hours trying to get it working eero is the worst router you could have

    • NMS_SALON
    • 1 yr ago
    • Reported - view

    EERO support is useless. EERO needs to recall these units. There is definitely a problem.


    In the last 48 hours I have tried:

    1. Swapping two different EEROs and trying to use them as gateways (no improvement)
       
    2. Adding/removing all the EEROs and re-adding them to the network (no improvement)
       
    3. Unplug all the EEROs and rebuild the network using Google WiFi (<12 Hours in, but so far, no reported issues)

    I ran a ping test (1000 total pings) of 1.1.1.1 and 8.8.8.8 on the Google WiFi from 4 iPads on WIFI - and ZERO packet loss. The EERO is absolutely the problem.

     

    Previously, even if hard lined into the EERO gateway, I'd get packet loss between ~ 7 -10%. If I was EERO, I'd be embarrassed right about now.

     

    EERO - RECALL THESES! GIVE US OUR MONEY BACK.

     

    ADMIT YOU HAVE A PROBLEM.

     

    STOP HIDING!

    • david.4
    • 1 yr ago
    • Reported - view

    I have given up with the eero's and returned them. 

    Support were unable to resolve the issue after blaming everything from my cat7 cable, a dumb unmanaged netgear switch, etc etc.  They said the issue was I had a loop in my network.  Which I proved wasn't the case or if there was it was caused by the eero's. 

    I've just installed 3 Linksys Velop's which were given to me.  They are working perfectly with exactly the same setup, placement and devices connected as the eero's.

    • lefty
    • 1 yr ago
    • Reported - view

    Having the same issue as well but on eero 6+. Upgraded from eero released 3 years ago and never experienced this. Wi-Fi calling stopped working after upgrading to 6+ and I'm getting 1000ms ping download doing speedtest.net. eero app shows 460+Mbps running in-app speed test but on connected devices running speedtest.net shows 0.02-3Mbps. So frustrating

    • mkarnick
    • 1 yr ago
    • Reported - view

    So I was having this same issue.  This was very noticeable with Zoom / Teams meetings.   My voice would be all garbled or cut out.   I would test by running a constant ping -t 8.8.8.8.   It would ping fine several times and then time out.   It was only my work laptop though.   No other devices in my house seem to be affected.   TV streams fine (amazon firesticks), security cameras fine, other laptops fine (personal and wife works from home as well).   Even my previous work laptop worked fine.   It is just when I got this new work laptop that has Windows 11 on it.   It is the only PC in the house with Windows 11.   I upgraded and downgraded the drivers for the wi-fi adapter.   Even my work replaced the wi-fi adapter thinking that is was defective.   Still having the same issue.   I was then give 2 loaner laptops from work to test on my network with fresh images of Windows 11.  They were 2 different models of laptops with 2 different types of network adapters in them.   They both had the same issue.   I also took my laptop to my mother-in-laws house to try on their network that does not have the Eero mesh wifi.  It had the same issue there.   They had an old Netgear router (non-mesh).   So now I am really starting to believe that it is a Windows 11 issue.   

    After some additional testing, I think I have found that the issue my laptop running Windows 11 is having is that it is conflicting with some other device attached to the router.  However, I don't know what that device is yet.   Here is what I did to come to that reasoning:

    1) I fired up an old TP-Link router I had.  This was ran separate from the Eero network but used that same ISP connection.   Connected only my laptop to that wifi and now no issue seen.   

    2) I worked with Mark at Eero Support and he had me turn on the Guest network.  I connected only my laptop to that guest network and no issues.   Connect back to the Eero non-guest network and issue seen right away.   Connect back on Guest network again, no issue for several hours now.   

    So whatever is on the main Eero wi-fi network and also on my mother-in-laws wi-fi network, my new work laptop running Windows 11 does not like.   One other note, the issues I was having also seemed to be much worse when connecting to my work's VPN (Global Protect).

    When I get time, I will try and disconnect one device at a time and test to see which device it is conflicting with.   I know the following devices are on my main Eero network and my mother-in-laws network:  Amazon Firesticks, Blink Security Cameras, Laptops running Windows 10, and bunch of Apple products (cell phones, watches, etc.).  Probably have thermostats and garage door openers in common too.   Something that will be time consuming to do.   Hope this posting helps others that are at a loss of what the problem is.   At least you might have a workaround for using the Eero by enabling the Guest Network.

      • dmilr
      • 1 yr ago
      • Reported - view

      mkarnick 

      • dmilr
      • 1 yr ago
      • Reported - view

       mkarnick This is a great find! So I have the exact same situation it seems. My employer swapped out my laptop last Aug. The new system has Win11 installed and has been dropping packets since, mainly while logged onto our VPN. The old system had no issues. I've gone through numerous troubleshooting options from removing/installing drivers and software packages but nothing works. I change to a different network and things seem to work just fine so ruled this to either my ISP or the eero. I've been playing around with various settings and following this thread trying different options and some are better than others but still see the drops here and there. 

      I've now moved over to the guest net and initially I did see a drop here and there but realized I was connected to the farthest most device on my mesh. I move my connection to the closest device and all seems good for now. The tell tale sign will be during the day when I'm on zoom sessions while connected to the VPN. If I don't see drops from that then I think you've cracked it. AND this should be a relatively easy fix for the eero team as this has ARP table issues written all over it. Evan (eero support) If you're still out there, pick this up for a Jira ticket. I'll report back in a day or 2. 

    • mkarnick
    • 1 yr ago
    • Reported - view

    The workaround has remained solid since my last post.   No further issues with Teams / Zoom when leaving it on the Guest network.   
     

    However, I have not taken the time to further troubleshoot what it does not like on the main network.   
     

    I believe this issue is not isolated to Eero though since my in laws have an old Netgear router (non-mesh) router that was having same issue with my laptop.   

    • kagbasiwgsdac
    • 1 yr ago
    • Reported - view

    Hi Folks,

    I run a small network for a church with four eero 5 Pros running in bridge mode and connected in series to each other via cable (with AP1 being directly connected to my core switch).  

    I've also started noticing very high packet loss recently (I'd say about 2 weeks ago).  System has been running fine for well over 2yrs solid.  I've also noticed that I don't have that issue with the Guest Network, just the main one.  I started noticing that when clients attempt to connect, the DHCP broadcast traffic doesn't make it to my DHCP server, so even though the client connects, it reports that there is no Internet traffic.  As a quick workaround, I can change the client settings to use a static IP address and it connects fine to the eero network.  So something is wrong with the Main Network.

    I decided to run an extended ping test using WinMTR over a roughly 4-hour period, and here's what I saw:

     

    From the ping tests above, it is clear that something is up with AP2, AP3, and AP4.  I ran the same test to the core switch (SW1) and you can see virtually no packet loss (1% an issue, but not a major concern).

    I was considering upgrading to eero 6 Pro, but gonna hold off for now.  If someone at eero support is watching this thread, please hit me up so we can troubleshoot.  I'm not one to quickly abandon a tech simply because issues like this arise, so let's troubleshoot please.  

    • fuchsia_baseball
    • 1 yr ago
    • Reported - view

    I had the same issue with my eero pro 6 routers but the issue was only localized to one laptop (Windows) compared to the other (Mac). I ended up setting up the preferred band to 2.4Ghz on the Windows laptop under Wi-Fi network adaptor settings and immediately saw an improvement with no more drops other than the usual one offs. It seems in my case forcing the frequency band seemed to help. I wonder if this is the reason the issue seems to be non existent on guest network setup on eero. Maybe there is no auto switching with guest network ? Who knows.. Hope this helps anyone facing this issue.

    • elFin
    • 1 yr ago
    • Reported - view

    Hi guys, I ran into the same problems described in this post.   My setup: I have 3 EERO Pro 6 routers spread throughout my house. So, while playing online games, I noticed the annoying lag spikes everyone is referencing.  I found out through EERO support that you need to have each EERO router about 25ft min and 50ft max apart from each other.  If they are too close your device will get mixed up and try to switch over to another EERO router resulting in a lag spike.   After I moved my EERO's to be further apart, the lag spikes stopped.   Hope this helps.  

      • david.4
      • 1 yr ago
      • Reported - view

      elFin I binned the eero’s and replaced them with a different brand.  They have none of the issues with exactly the same placement. 
       

      Glad you managed to sort yours out!

    • dani83264
    • 11 mths ago
    • Reported - view

    Having this same issue with my Xfinity gateway in bridge mode. In an Xfinity thread it says "the modem that Xfinity has requires ARP request for the GWs IP at least once every 5 min or starts dropping packets." and that the routers ARP timeout needs to be set to 2 minutes, but I have no idea how to do that on the Eero router. Any help would be greatly appreciated.

    https://forums.xfinity.com/conversations/your-home-network/brand-new-comcast-modem-broken-in-bridge-mode-dropping-packets/63a62f88ebc7551628363662

    • in2win
    • 10 mths ago
    • Reported - view

    I just wanted to add that this is still going on for me on my eero 6 and eero 6 in wired bridge mode. No issues with my Windows 10 machines, but the same machines upgraded to Windows 11 21H2 or 22H2 and I start getting issues when on VPN(Global Protect). eero support help! I have turned off the Optimized for Conference and Gaming, WPA3, and Local DNS in the eero Labs to see if this helps but nothing. Also on the lastest 6.15.2-99

    • dlince
    • 10 mths ago
    • Reported - view

    Just installed my eero 6+'s today, and got the same issue. Only shows on Win11 laptop, and happens on guest network as well. I did see via the eero app that the laptop was switching constantly between eeros, and unfortunately I can't change the roaming aggressiveness of my network card. I tried moving my eero to literally right next to my laptop, and for some reason the laptop won't grab onto that network now... 

     

    So...two steps forward, one step back!

    • DNicholson62
    • 10 mths ago
    • Reported - view

    I am having the same issue where I get drops when on Main network but when I switch to Guest one I don't get drops and it only started happening after Windows 11 update.  I believe it must have to do with something that gets upgraded with Win11 that Eeros does not like for the main network. When I attempt to contact support I feel like I am getting the run around and they are not answering the question I am asking.

      • AFA23
      • 10 mths ago
      • Reported - view

       their entire purpose is to stall until people give up. I spent months going back and forth over endless emails with them - started with basic network questions, went all the way down to blaming my Ethernet cords, and having me run the same ping tests over and over again, and at one point they just straight up ghosted me. Legitimately insulting. 
       

      We recently moved and switched ISPs (new area). Kept the eeros in whatever box the movers stuffed them in and just used the standard router our ISP provides. Have not experienced a single issue since, and our overall speed is significantly faster. Will never use another Eero product again and will advise against anyone using them if they’re considering it. 

      • DwainsEero
      • 10 mths ago
      • Reported - view

      This is what happens when cash strapped companies e.g. eero & twitter get acquired by billionaires.

      The top executives make out like bandits while the stockholders, employees and consumers get the shaft.

    • wurtis
    • 9 mths ago
    • Reported - view

    +1 here.  Just bought a bunch of eero pro's and the intermittent connection drops are insane. I thought these routers were supposed to sense and repair these kinds of problems on the fly? 

      • DwainsEero
      • 9 mths ago
      • Reported - view

      My assumption is if they (eero routers not the extenders) are connected via Ethernet, there shouldn't be an issue.  Ethernet should give you more reliable connectivity.

      It's the WiFi implementation that is the problem even when placed within the recommended 50 feet.  

      Too many access points theoretically can lead to inefficient wireless coverage, where some areas are over-serviced while others are under-serviced YMMV.

      The other thing is that eero WiFi is KNOWN to drop multicast data packets.  This is true for Roon and in some cases Roon Ready devices.  Case in point:  Auralic network streamers preference is WiFi but if you check their website under "WiFi or Ethernet" page, it states:

      "More recently developed mesh WiFi systems like Netgear Orbi and Amazon eero, while steadily improving, still yield mixed performance, so we recommend you proceed with caution when considering a mesh solution. 

       *Do not use Ethernet over Powerline (HomePlug / EoP) adapters. These will not work with our products."

      Lumin Music also has documented cases where customers have reported  issues with dropped data packets sent over WiFi.  In this scenario, customers are using for example one eero as a gateway router and another eero router as a wireless Ethernet access point. Eero doesn't send data exactly the same way a Powerline adapter does.  Because the 2nd eero is only connected wirelessly, the data packets are being sent via WiFi which makes them more susceptible to being dropped.

      • in2win
      • 9 mths ago
      • Reported - view

       I can tell you from my experience, wired OR wireless on my main eero network I experience this issue. Only on my eero Guest WiFi does it go away. 
       

      I have started a support ticket with eero and hopefully they can identify with packet analysis from eero routers the issue.

      • DwainsEero
      • 9 mths ago
      • Reported - view

      Same here but I don't think they (eero support) are listening.  My issue is associated with network streamers.  eero support keeps asking the same questions, over and over again.  It's simple: the information I've provided hasn't changed -- except I have increased my network bandwidth from 30 Mbps to 500 Mbps. 

      More than enough bandwidth for my intended application.  I've tested WiFi signal strength both at the gateway and the access point.  I have two eero pro 6's (1 gateway - 1 access point) in addition to my router to cover 1850 sq. ft.  Less than 10 devices connecting to the network via WiFi - no more than 3 concurrent connected devices.

      We consumers are continually adding more and more devices to our home networks and accessing more and more services. Wireless networks experience more issues with packet loss than wired networks.  I use to work in IT.  Very common for customers to push technology beyond it's limits and intended use. 

      Theoretically, depending on available bandwidth you can connect up to 255 devices on a network. 

      Each connected device is going to reduce available bandwidth. I'm looking at a maximum of 6 devices that potentially could be connected at the same time.

      So, is packet loss occurring because some malfunction on the router(s) end or too many devices on the network?  I don't know. 

      Lumin Music's solution is to tell customers (that have eero) to upgrade their primary router to either a TP-Link or ASUS - and to place their eero gateway router in bridge mode.  Does it always resolve the dropped packets issue?

      Maybe. Maybe not.

      Multicast communication (broadcasts one signal to multiple devices) appears to be a problem area for eero. 

      My understanding is that drops are to be expected. Multicast applications should not expect reliable delivery of data and should be designed accordingly.  Unicast (One sender - One receiver) communication is still the predominant form of transmission on the Internet.  I suspect eero's are based on unicast communications but again - I don't know.

      You say that you don't have the issue with packets dropping on your Guest network.  Bandwidth minimum requirements of 25 to 50 Mbps are recommended for typical guest use.  Ultimately, the bandwidth necessary for a given guest WiFi network depends on several factors, including the intended uses and the number of devices expected to be on the network.  So, if your Guest network bandwidth utilization is lower than your Primary, or you have over allocated bandwidth on your Guest network that might account for what you're seeing.  Just thinking out loud here.  Would be interesting to see what eero support has to say.

Content aside

  • 7 Likes
  • 9 mths agoLast active
  • 73Replies
  • 5706Views
  • 42 Following