WHAT HAVE YOU DONE!? Insane packet loss.

Tried on the same computer, and 2 different (but identical) computers (All Macbook Pro Intel)... same window of time...  


Its not my Fiber connection, and its not my ISP., or my any of my other routers...but look'ie what EERO does:


(NO, Eero tech people, I'm not your test engineer, I'm your customer, figure your own shit out)


After the latest (6.6.0) update--


EERO-6 vs. My ISP's (AT&T)'s WIFI provided modem:


MacBookH ➜   ping   <--- EERO 6 Pro

64 bytes from icmp_seq=158 ttl=54 time=14.992 ms
Request timeout for icmp_seq 159
64 bytes from icmp_seq=160 ttl=54 time=16.959 ms
64 bytes from icmp_seq=161 ttl=54 time=33.592 ms
64 bytes from icmp_seq=162 ttl=54 time=180.074 ms
64 bytes from icmp_seq=163 ttl=54 time=196.682 ms
64 bytes from icmp_seq=164 ttl=54 time=199.880 ms
64 bytes from icmp_seq=165 ttl=54 time=226.821 ms
Request timeout for icmp_seq 166
Request timeout for icmp_seq 167
Request timeout for icmp_seq 168
Request timeout for icmp_seq 169
Request timeout for icmp_seq 170
Request timeout for icmp_seq 171
Request timeout for icmp_seq 172
Request timeout for icmp_seq 173
Request timeout for icmp_seq 174
Request timeout for icmp_seq 175
Request timeout for icmp_seq 176
Request timeout for icmp_seq 177
Request timeout for icmp_seq 178
64 bytes from icmp_seq=179 ttl=54 time=15.916 ms
64 bytes from icmp_seq=180 ttl=54 time=44.537 ms
Request timeout for icmp_seq 181
64 bytes from icmp_seq=182 ttl=54 time=14.510 ms
64 bytes from icmp_seq=183 ttl=54 time=20.719 ms


AT&T's provided wifi modem:

MacBookH ➜   ping  <-- CHEAP AT&T Wifi 
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=58 time=14.521 ms
64 bytes from icmp_seq=1 ttl=58 time=15.761 ms
64 bytes from icmp_seq=2 ttl=58 time=15.923 ms
64 bytes from icmp_seq=3 ttl=58 time=28.138 ms
64 bytes from icmp_seq=4 ttl=58 time=12.035 ms
64 bytes from icmp_seq=5 ttl=58 time=17.005 ms
64 bytes from icmp_seq=6 ttl=58 time=18.071 ms
64 bytes from icmp_seq=7 ttl=58 time=13.159 ms
64 bytes from icmp_seq=8 ttl=58 time=16.233 ms
64 bytes from icmp_seq=9 ttl=58 time=14.217 ms
64 bytes from icmp_seq=10 ttl=58 time=16.452 ms
64 bytes from icmp_seq=11 ttl=58 time=16.151 ms

73 replies

    • scotteero
    • 2 yrs ago
    • Reported - view

    Perhaps the vague "Stability and performance improvements" release last night resolves this. I wish they included more info in the release notes.

    • scotteero
    • 2 yrs ago
    • Reported - view

    Still having the same issue with the latest Eero release. Packet loss at least once every 5 minutes.

      • Lucid88
      • 2 yrs ago
      • Reported - view

      scotteero on a nightly basis I have to disable my wifi and go to cellular data because of the packet loss issue. It’s become a new normal for this router. I will not be buying a eero in the future . It is what it is but they’ve had long enough to fix this issue.

    • diver65
    • 2 yrs ago
    • Reported - view

    Latency issues?  I had it something terrible!  Disabling IPv6 fixed it all.  Eero needs to address this ASAP.  Do not blame ISP, their router, etc.  

    • crack3d
    • 2 yrs ago
    • Reported - view

    Add me to the list of people having random drops on the home Eero network on Mac devices. I'm fine because I'm hard wired to the router, but same issue as reported by others: All lights on all Eeros never report any disruption or change color, but Macbook will randomly disassociate with the network, sometimes multiple times a day.

    • sinkr
    • 2 yrs ago
    • Reported - view

    Same here.  Joined up because of this very issue--dropping packets, I have to sometimes turn wifi off on my device and back on, etc.  It's a mess. 


    I have the 3x Pro 6 setup and am never more than a few feet from a wired/backhauled Eero Pro 6 and can drop packets when pinging my Fios router.


    Also, my Sonos speakers hate this and disconnect quite frequently.


    This exact setup was stable for over a year up until sometime for me in the past 2 weeks.

    • baxx22
    • 1 yr ago
    • Reported - view

    Signed up to comment on this issue specifically. I am experiencing the same issue.

    Purchased a pair of Eero 6's a few months back, they've been a pain in the butt since I got them. 2.4 devices are constantly falling offline and don't even get me started with printer issues.

    I've been able to work around or mitigate most of the issues but this one's got me stumped. About a week ago I started experiencing massive packet loss on the eeros when pinging the modem. If I unplug the eeros and connect directly to the modem I don't experience any issues but as soon as my laptop reconnects to the eeros my speeds cut in half and I loose 40-50% of the packets in a ping test. The problem seems to worsen during bandwidth intensive activities like video chat.

    Called support twice this week. I've currently been on hold for 30minutes while the support agent fumbles around her house and walks her dog in the background.

    Has anyone had any luck returning these pieces of Amazon junk?

      • diver65
      • 1 yr ago
      • Reported - view


      You’re likely to get little to no help from Eero support.  I think, quite frankly, that they’re stumped with this. 

      So, having said that I’ll offer what worked for me.  I’m hypothesizing that something went awry between my home router and Eero gateway during one of the software pushes.  I knew my router wasn’t the issue since my laptop, which I keep connected to my router via Ethernet cable as an in case, was working perfectly on my AT&T internet service when I switched from wireless networking to wired. 

      Ultimately I decided to simply disconnect my Eero gateway from my router, I did not reset my Eero gateway or anything else.  I proceeded to hard reset my AT&T gateway/router then turned off both wireless bands.  I then turned on IP passthrough and set it to DHCPS-Dynamic.  I reconnected the Ethernet cable to my Eero gateway I had previously disconnected going to my router. Waited for my Eero gateway (set to automatic DHCP & NAT) to reestablish connection with my AT&T router and my two satellite Eeros.  Lastly, ran packet loss and speed tests on both my router directly and then through my Eero gateway and I’ve had no packet loss and speeds matched.  Everything has kept working fine so far, keeping my fingers crossed it stays that way.

      I don’t know if this will help in your case but, you can give it a shot.

    • brooklyneero96
    • 1 yr ago
    • Reported - view

    Back again….. after being solid for a while my packet loss is back and constant. I’m done. Selling these pieces of garbage to upgrade with something else. 

      • scotteero
      • 1 yr ago
      • Reported - view

      brooklyneero96 Loving my Amplifi. Zero issues since I moved. Best of luck.

      • brooklyneero96
      • 1 yr ago
      • Reported - view

      scotteero I really appreciate that I haven’t done any research yet! 

    • msplb74
    • 1 yr ago
    • Reported - view

    Signed in to Plus1 this. Have had fibre to house set up with ISP for almost a year, with Eero Plus network setup. Until recently seemed bulletproof.

    First observed issues about two months ago. Did have three eero plus units: gateway direct to the fibre access box. (there's a name for it...) . Then lost connections started constantly. After speaking with the ISP who was sure zero issues I put into the network the ISP provided Plume Superpod so that they could remotely monitor it. Eero gateway connected via Ethernet creating own network and with a reserved IP on the superpod. Worked well until this week when we've had covid going around the house and people having to work from home more. Suddenly yesterday and today crappy remote desktop performance with drop-outs and zoom with unstable connecitons and reporting huge packet loss. Moved location in teh house to be in same room as the gateway eero and zoom worked perfectly (and speeds at the 400 up /down i get when connecting directly at the superpod). Crappy when on the office located eero which is likely at the end of the chain (gateway, eero 2, eero 3 in the home office). Took the office eero (3) out of the network and largely problems seem to have gone on the laptops (pc and mac) but the wifi connection is super weak. iPhone keeps being dropped by the eero network now when connecting to eero2 / or crazy slow. All the time connecting directly to the superpod network yields stable rapid connection. 


    Thoughts welcomed. Feels like eeros doing a poor job of relaying traffic between them along the chain. 

      • Rafa507
      • 1 yr ago
      • Reported - view

      msplb74 I´m having the same issues... continuous signal lost and connection dropouts. Especially with Android 13 device, IOS and a Windows 11 laptop.. I´m tire of this devices.  

    • ebonovic
    • 1 yr ago
    • Reported - view

    I too am another suffering from this, same timeline.     I thought maybe it was my older hardware so mid summer, I purchase a new set of 3 6E units, to replace my gen 1s.   Didn't fix anything.  

    I have been going back and forth on this with eero support, and getting no where.      So I am at a point, where I am going to simply get rid of eero, sell them off to someone that uses it the way they want it to be used...    and replace it all with higher end equipment. 

    eero no longer is completely not for the higher utilization users.   this used to work flawlessly.   

      • scotteero
      • 1 yr ago
      • Reported - view

      ebonovic Sell them and move on - it's not worth working with their support.

      • ebonovic
      • 1 yr ago
      • Reported - view

      scotteero It is probably in my long term plan, I know I won't be buying any more nodes or systems. 

      I did post a new thread "Topology", which they suggested a topology change for my network. 
      I made that change, but it will take a while for me to confirm if it has made a differences. 

    • ncosta7
    • 1 yr ago
    • Reported - view

    Having the exact same issues and it doesn't seem like any solution from eero has been provided. Moved into a new home 3 weeks ago and set up of 3 new eero 6 APs and am experiencing far too frequent of drops that is greatly affecting my work Teams and Zoom calls. When they are working the speeds are exactly what I am paying for, but I cannot afford to let these drops affect my work multiple times a day. 

    Extremely disappointed. Wish I had not thrown the boxes away because I would have returned already given it doesn't look like there is a solution coming any time soon. 

      • ebonovic
      • 1 yr ago
      • Reported - view

      ncosta7 After doing everything Eero asked, except for making the Eero my gateway...   I am done. 
      I actually couldn't trust my own personal network performance, and had to go into the office to do a critical call.  

      Hopefully going to recoup some of the cost by selling them to someone with a smaller setup them me... but going with a full Ubi setup and access points.

    • Oberon
    • 1 yr ago
    • Reported - view

    Experiencing the same, massive packet loss and high latency occurs after some time with my eero 6 pro's. Rebooting the eero alleviates it for a while, but the issue returns.

      • Evan_eero_support
      • 1 yr ago
      • Reported - view

      Oberon Thanks for posting! I am sending you a DM shortly. Respond to me there and we can go from there.

    • AFA23
    • 1 yr ago
    • Reported - view

    Created an account just to find some kind of help here, because multiple months of going back and forth with eero support has given me the impression that they are designed solely to deflect and run people around in circles until they give up out of sheer frustration. 

    The issue is pictured in images I attached: I have been getting huge packet loss/latency spikes that happen at literally the exact same time every single minute in perpetuity. It causes issues with our baby monitor, it disconnects streaming video, it breaks up video calls, it makes online games unplayable, etc. I have literally sat at my desk with a stopwatch and been able to perfectly time the two spikes I know are coming; 50 seconds of acceptable (though wildly jittery) ping, massive spike, 10 seconds, massive spike, repeat. 

    I have sent the below images (and many more of different tests that show the same thing happening under various different conditions) to eero support at various points in what is now a months-long back-and-forth with them. Four different people have given me increasingly pointless checklists to try and get me to give up and go away "troubleshoot the issue" and attempt to isolate what the problem is. Given the nature of the 'troubleshooting' so far - "are you sure the ethernet cord is plugged in to the right port?" "are you sure you're using the right type of cord?" "did you reset your network (at any point in the past two months)?" "can you run another ping test?" - I do not get the impression that they have any idea what is going on or that they care at all. 

    I'm now at the point where they've apparently run of out busywork to give me, so someone has been "trying to schedule a phone call with me"...for 8 days. Hilarious. Really hope I can find some kind of guidance/solution in here, because at this point I'm concerned that there is no fix at all, eero knows this and doesn't care, and my best bet is to throw these things in the trash and buy something else. 

    • 3yM9kQkVUGpj
    • 1 yr ago
    • Reported - view

    Hey folks,


    I'm experiencing high latency to my Eero Pro 6. I think it started after the 6.12 update. I'm still having it with the 6.13 update too.


    % ping eero-basement

    PING eero-basement ( 56 data bytes

    64 bytes from icmp_seq=0 ttl=64 time=2.677 ms

    64 bytes from icmp_seq=1 ttl=64 time=8.979 ms

    64 bytes from icmp_seq=2 ttl=64 time=17.680 ms

    64 bytes from icmp_seq=3 ttl=64 time=25.743 ms

    64 bytes from icmp_seq=4 ttl=64 time=67.556 ms

    64 bytes from icmp_seq=5 ttl=64 time=114.621 ms

    64 bytes from icmp_seq=6 ttl=64 time=2.899 ms

    64 bytes from icmp_seq=7 ttl=64 time=2.903 ms

    64 bytes from icmp_seq=8 ttl=64 time=3.322 ms

    64 bytes from icmp_seq=9 ttl=64 time=3.203 ms

    64 bytes from icmp_seq=15 ttl=64 time=31.071 ms

    64 bytes from icmp_seq=16 ttl=64 time=79.491 ms

    64 bytes from icmp_seq=17 ttl=64 time=124.073 ms

    64 bytes from icmp_seq=18 ttl=64 time=166.852 ms

    64 bytes from icmp_seq=19 ttl=64 time=244.340 ms

    64 bytes from icmp_seq=20 ttl=64 time=19.859 ms

    64 bytes from icmp_seq=21 ttl=64 time=3.065 ms

    64 bytes from icmp_seq=22 ttl=64 time=14.491 ms

    64 bytes from icmp_seq=23 ttl=64 time=62.967 ms

    64 bytes from icmp_seq=24 ttl=64 time=105.650 ms

    64 bytes from icmp_seq=25 ttl=64 time=148.112 ms

    64 bytes from icmp_seq=26 ttl=64 time=191.646 ms

    64 bytes from icmp_seq=27 ttl=64 time=234.922 ms

    64 bytes from icmp_seq=28 ttl=64 time=277.915 ms

    64 bytes from icmp_seq=29 ttl=64 time=321.076 ms

    64 bytes from icmp_seq=30 ttl=64 time=2.964 ms


    --- eero-basement ping statistics ---

    37 packets transmitted, 37 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 2.677/68.928/321.076/87.179 ms



    • david.4
    • 1 yr ago
    • Reported - view

    I also have this issue.  It's insanely annoying.

    I have 3 6+ eero's the gateway connected to my modem, another in the hall which has a cat 7 cable running to the 3rd in my garden office.

    It sometimes works fine for a few hours and then I get loads of packet loss.  A network restart fixes it briefly sometimes.

    The issue I believe is the mesh connection between the gateway and the eero in the hall.  From the garden office I can ping the hall eero with no problems, but pinging the gateway eero results in massive packet loss.

    Devices connected to the gateway eero are fine.  Just anything wifi or hardwired to the hall eero is not working properly.

    The gateway and hall eero are no more that 10m apart with at worst an internal wall between them.

    I have until 31 Jan to return these hopeless devices, but may just sent them back now!

    • Jorgeit
    • 1 yr ago
    • Reported - view

    What's crazier is that I'm connected to the router via wired Ethernet and I still get the lost packages. 

    The router itself is also connected via Ethernet to the main one. 

    This makes no sense at all. 

      • AFA23
      • 1 yr ago
      • Reported - view

      Jorgeit I also experienced this. Hardwired to my modem = zero problem. Hardwired to the gateway eero = massive packet loss occurring at the same intervals every minute. It is 100% an eero problem.

Content aside

  • 9 mths agoLast active
  • 73Replies
  • 5706Views
  • 42 Following