WHAT HAVE YOU DONE!? Insane packet loss.

Tried on the same computer, and 2 different (but identical) computers (All Macbook Pro Intel)... same window of time...  


Its not my Fiber connection, and its not my ISP., or my any of my other routers...but look'ie what EERO does:


(NO, Eero tech people, I'm not your test engineer, I'm your customer, figure your own shit out)


After the latest (6.6.0) update--


EERO-6 vs. My ISP's (AT&T)'s WIFI provided modem:


MacBookH ➜   ping   <--- EERO 6 Pro

64 bytes from icmp_seq=158 ttl=54 time=14.992 ms
Request timeout for icmp_seq 159
64 bytes from icmp_seq=160 ttl=54 time=16.959 ms
64 bytes from icmp_seq=161 ttl=54 time=33.592 ms
64 bytes from icmp_seq=162 ttl=54 time=180.074 ms
64 bytes from icmp_seq=163 ttl=54 time=196.682 ms
64 bytes from icmp_seq=164 ttl=54 time=199.880 ms
64 bytes from icmp_seq=165 ttl=54 time=226.821 ms
Request timeout for icmp_seq 166
Request timeout for icmp_seq 167
Request timeout for icmp_seq 168
Request timeout for icmp_seq 169
Request timeout for icmp_seq 170
Request timeout for icmp_seq 171
Request timeout for icmp_seq 172
Request timeout for icmp_seq 173
Request timeout for icmp_seq 174
Request timeout for icmp_seq 175
Request timeout for icmp_seq 176
Request timeout for icmp_seq 177
Request timeout for icmp_seq 178
64 bytes from icmp_seq=179 ttl=54 time=15.916 ms
64 bytes from icmp_seq=180 ttl=54 time=44.537 ms
Request timeout for icmp_seq 181
64 bytes from icmp_seq=182 ttl=54 time=14.510 ms
64 bytes from icmp_seq=183 ttl=54 time=20.719 ms


AT&T's provided wifi modem:

MacBookH ➜   ping  <-- CHEAP AT&T Wifi 
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=58 time=14.521 ms
64 bytes from icmp_seq=1 ttl=58 time=15.761 ms
64 bytes from icmp_seq=2 ttl=58 time=15.923 ms
64 bytes from icmp_seq=3 ttl=58 time=28.138 ms
64 bytes from icmp_seq=4 ttl=58 time=12.035 ms
64 bytes from icmp_seq=5 ttl=58 time=17.005 ms
64 bytes from icmp_seq=6 ttl=58 time=18.071 ms
64 bytes from icmp_seq=7 ttl=58 time=13.159 ms
64 bytes from icmp_seq=8 ttl=58 time=16.233 ms
64 bytes from icmp_seq=9 ttl=58 time=14.217 ms
64 bytes from icmp_seq=10 ttl=58 time=16.452 ms
64 bytes from icmp_seq=11 ttl=58 time=16.151 ms

63replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hey folks,


    I'm experiencing high latency to my Eero Pro 6. I think it started after the 6.12 update. I'm still having it with the 6.13 update too.


    % ping eero-basement

    PING eero-basement ( 56 data bytes

    64 bytes from icmp_seq=0 ttl=64 time=2.677 ms

    64 bytes from icmp_seq=1 ttl=64 time=8.979 ms

    64 bytes from icmp_seq=2 ttl=64 time=17.680 ms

    64 bytes from icmp_seq=3 ttl=64 time=25.743 ms

    64 bytes from icmp_seq=4 ttl=64 time=67.556 ms

    64 bytes from icmp_seq=5 ttl=64 time=114.621 ms

    64 bytes from icmp_seq=6 ttl=64 time=2.899 ms

    64 bytes from icmp_seq=7 ttl=64 time=2.903 ms

    64 bytes from icmp_seq=8 ttl=64 time=3.322 ms

    64 bytes from icmp_seq=9 ttl=64 time=3.203 ms

    64 bytes from icmp_seq=15 ttl=64 time=31.071 ms

    64 bytes from icmp_seq=16 ttl=64 time=79.491 ms

    64 bytes from icmp_seq=17 ttl=64 time=124.073 ms

    64 bytes from icmp_seq=18 ttl=64 time=166.852 ms

    64 bytes from icmp_seq=19 ttl=64 time=244.340 ms

    64 bytes from icmp_seq=20 ttl=64 time=19.859 ms

    64 bytes from icmp_seq=21 ttl=64 time=3.065 ms

    64 bytes from icmp_seq=22 ttl=64 time=14.491 ms

    64 bytes from icmp_seq=23 ttl=64 time=62.967 ms

    64 bytes from icmp_seq=24 ttl=64 time=105.650 ms

    64 bytes from icmp_seq=25 ttl=64 time=148.112 ms

    64 bytes from icmp_seq=26 ttl=64 time=191.646 ms

    64 bytes from icmp_seq=27 ttl=64 time=234.922 ms

    64 bytes from icmp_seq=28 ttl=64 time=277.915 ms

    64 bytes from icmp_seq=29 ttl=64 time=321.076 ms

    64 bytes from icmp_seq=30 ttl=64 time=2.964 ms


    --- eero-basement ping statistics ---

    37 packets transmitted, 37 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 2.677/68.928/321.076/87.179 ms



  • I also have this issue.  It's insanely annoying.

    I have 3 6+ eero's the gateway connected to my modem, another in the hall which has a cat 7 cable running to the 3rd in my garden office.

    It sometimes works fine for a few hours and then I get loads of packet loss.  A network restart fixes it briefly sometimes.

    The issue I believe is the mesh connection between the gateway and the eero in the hall.  From the garden office I can ping the hall eero with no problems, but pinging the gateway eero results in massive packet loss.

    Devices connected to the gateway eero are fine.  Just anything wifi or hardwired to the hall eero is not working properly.

    The gateway and hall eero are no more that 10m apart with at worst an internal wall between them.

    I have until 31 Jan to return these hopeless devices, but may just sent them back now!

  • What's crazier is that I'm connected to the router via wired Ethernet and I still get the lost packages. 

    The router itself is also connected via Ethernet to the main one. 

    This makes no sense at all. 

      • AFA23
      • AFA23
      • 5 mths ago
      • Reported - view

      Jorgeit I also experienced this. Hardwired to my modem = zero problem. Hardwired to the gateway eero = massive packet loss occurring at the same intervals every minute. It is 100% an eero problem.

  • I’m experiencing the EXACT issue as other EERO owners have reported.


    My setup:

    - All EEROs (6) are WIRED to one 24 Port TP-LINK TL-SG1024DE Switch

    - Utility Room EERO = Gateway EERO

    - All other EEROs are basically Wired Access Points

    - Modem Plugged into EERO Gateway


    Things I have tested:

    - Ping EERO Gateway using wired MacBook connected via 1GB switch (no packet loss)

    - Ping Modem using wired MacBook connected via 1GB switch (no packet loss)

    - Ping Modem using wired MacBook connected directly to EERO Gateway (no packet loss)

    - Ping other EEROs using wired MacBook connected directly to EERO Gateway (no packet loss)


    - Ping using wired MacBook connected via 1GB switch (packet loss)

    - Ping using MacBook connected wirelessly (packet loss)

    - Ping using wired MacBook connected directly to EERO Gateway (packet loss)

    - Ping using wired MacBook connected directly to Modem (no packet loss)

    - Ping using iPad connected directly to an iPhone 14 Pro Max Hot Spot (no packet loss)


    - Ping using wired MacBook connected via 1GB switch (packet loss)

    - Ping using MacBook connected wirelessly (packet loss)

    - Ping using wired MacBook connected directly to EERO Gateway (packet loss)

    - Ping using wired MacBook connected directly to Modem (no packet loss)

    - Ping using iPad connected directly to an iPhone 14 Pro Max Hot Spot (no packet loss)


    Settings things I have tried:

    - Turning UPnP on/off (no improvement)

    - Turning IPv6 on/off (no improvement)

    - Turning Backup Internet on/off (no improvement)

    - Turning Guest Network on/off (no improvement)


    Hardware things I have tried:

    - Tried Swapping Modem. CM700 for another CM700. (no improvement)

    - Upgraded Mode from CM700 to CM2000 (no improvement)

    - Removing Access Points Temporarily - Power (some improvement)

    - Removing/Readding Access Points - Network Config/App Wise (some improvement)

    - Forcing the Access Points to be Repeaters - Unplugging Wired Back Bone Connection (no improvement)


    So far the only that seems to help is if I remove all the access point EEROs from my network, leaving only a single gateway EERO.


    Packet loss STILL occurs when using the one gateway EERO, but the latency is better (closer to 20 MS vs. ~70 MS with all EEROs connected). Problem is I’m trying to cover 6000 square feet…


    Personally, it sounds like EERO has a MAJOR hardware or firmware problem on theirhands and these things should be recalled.


    I had used Google WiFi previously for years and never had any problems. I only "upgraded" to EERO because I wasn't happy with the Google WiFi app. Little did I know I was going to spend $1,000 just to buy a bigger problem! :(

    Like 1
    • NMS_SALON  my ping is 9 to 10 when you buy something I don’t expect to spend hours trying to get it working eero is the worst router you could have

      Like 1
  • EERO support is useless. EERO needs to recall these units. There is definitely a problem.

    In the last 48 hours I have tried:

    1. Swapping two different EEROs and trying to use them as gateways (no improvement)
    2. Adding/removing all the EEROs and re-adding them to the network (no improvement)
    3. Unplug all the EEROs and rebuild the network using Google WiFi (<12 Hours in, but so far, no reported issues)

    I ran a ping test (1000 total pings) of and on the Google WiFi from 4 iPads on WIFI - and ZERO packet loss. The EERO is absolutely the problem.


    Previously, even if hard lined into the EERO gateway, I'd get packet loss between ~ 7 -10%. If I was EERO, I'd be embarrassed right about now.







    Like 2
  • I have given up with the eero's and returned them. 

    Support were unable to resolve the issue after blaming everything from my cat7 cable, a dumb unmanaged netgear switch, etc etc.  They said the issue was I had a loop in my network.  Which I proved wasn't the case or if there was it was caused by the eero's. 

    I've just installed 3 Linksys Velop's which were given to me.  They are working perfectly with exactly the same setup, placement and devices connected as the eero's.

  • Having the same issue as well but on eero 6+. Upgraded from eero released 3 years ago and never experienced this. Wi-Fi calling stopped working after upgrading to 6+ and I'm getting 1000ms ping download doing speedtest.net. eero app shows 460+Mbps running in-app speed test but on connected devices running speedtest.net shows 0.02-3Mbps. So frustrating

    Like 1
  • So I was having this same issue.  This was very noticeable with Zoom / Teams meetings.   My voice would be all garbled or cut out.   I would test by running a constant ping -t   It would ping fine several times and then time out.   It was only my work laptop though.   No other devices in my house seem to be affected.   TV streams fine (amazon firesticks), security cameras fine, other laptops fine (personal and wife works from home as well).   Even my previous work laptop worked fine.   It is just when I got this new work laptop that has Windows 11 on it.   It is the only PC in the house with Windows 11.   I upgraded and downgraded the drivers for the wi-fi adapter.   Even my work replaced the wi-fi adapter thinking that is was defective.   Still having the same issue.   I was then give 2 loaner laptops from work to test on my network with fresh images of Windows 11.  They were 2 different models of laptops with 2 different types of network adapters in them.   They both had the same issue.   I also took my laptop to my mother-in-laws house to try on their network that does not have the Eero mesh wifi.  It had the same issue there.   They had an old Netgear router (non-mesh).   So now I am really starting to believe that it is a Windows 11 issue.   

    After some additional testing, I think I have found that the issue my laptop running Windows 11 is having is that it is conflicting with some other device attached to the router.  However, I don't know what that device is yet.   Here is what I did to come to that reasoning:

    1) I fired up an old TP-Link router I had.  This was ran separate from the Eero network but used that same ISP connection.   Connected only my laptop to that wifi and now no issue seen.   

    2) I worked with Mark at Eero Support and he had me turn on the Guest network.  I connected only my laptop to that guest network and no issues.   Connect back to the Eero non-guest network and issue seen right away.   Connect back on Guest network again, no issue for several hours now.   

    So whatever is on the main Eero wi-fi network and also on my mother-in-laws wi-fi network, my new work laptop running Windows 11 does not like.   One other note, the issues I was having also seemed to be much worse when connecting to my work's VPN (Global Protect).

    When I get time, I will try and disconnect one device at a time and test to see which device it is conflicting with.   I know the following devices are on my main Eero network and my mother-in-laws network:  Amazon Firesticks, Blink Security Cameras, Laptops running Windows 10, and bunch of Apple products (cell phones, watches, etc.).  Probably have thermostats and garage door openers in common too.   Something that will be time consuming to do.   Hope this posting helps others that are at a loss of what the problem is.   At least you might have a workaround for using the Eero by enabling the Guest Network.

      • dmilr
      • dmilr
      • 3 mths ago
      • Reported - view


      • dmilr
      • dmilr
      • 3 mths ago
      • 1
      • Reported - view

       mkarnick This is a great find! So I have the exact same situation it seems. My employer swapped out my laptop last Aug. The new system has Win11 installed and has been dropping packets since, mainly while logged onto our VPN. The old system had no issues. I've gone through numerous troubleshooting options from removing/installing drivers and software packages but nothing works. I change to a different network and things seem to work just fine so ruled this to either my ISP or the eero. I've been playing around with various settings and following this thread trying different options and some are better than others but still see the drops here and there. 

      I've now moved over to the guest net and initially I did see a drop here and there but realized I was connected to the farthest most device on my mesh. I move my connection to the closest device and all seems good for now. The tell tale sign will be during the day when I'm on zoom sessions while connected to the VPN. If I don't see drops from that then I think you've cracked it. AND this should be a relatively easy fix for the eero team as this has ARP table issues written all over it. Evan (eero support) If you're still out there, pick this up for a Jira ticket. I'll report back in a day or 2. 

      Like 1
  • The workaround has remained solid since my last post.   No further issues with Teams / Zoom when leaving it on the Guest network.   

    However, I have not taken the time to further troubleshoot what it does not like on the main network.   

    I believe this issue is not isolated to Eero though since my in laws have an old Netgear router (non-mesh) router that was having same issue with my laptop.   

  • Hi Folks,

    I run a small network for a church with four eero 5 Pros running in bridge mode and connected in series to each other via cable (with AP1 being directly connected to my core switch).  

    I've also started noticing very high packet loss recently (I'd say about 2 weeks ago).  System has been running fine for well over 2yrs solid.  I've also noticed that I don't have that issue with the Guest Network, just the main one.  I started noticing that when clients attempt to connect, the DHCP broadcast traffic doesn't make it to my DHCP server, so even though the client connects, it reports that there is no Internet traffic.  As a quick workaround, I can change the client settings to use a static IP address and it connects fine to the eero network.  So something is wrong with the Main Network.

    I decided to run an extended ping test using WinMTR over a roughly 4-hour period, and here's what I saw:


    From the ping tests above, it is clear that something is up with AP2, AP3, and AP4.  I ran the same test to the core switch (SW1) and you can see virtually no packet loss (1% an issue, but not a major concern).

    I was considering upgrading to eero 6 Pro, but gonna hold off for now.  If someone at eero support is watching this thread, please hit me up so we can troubleshoot.  I'm not one to quickly abandon a tech simply because issues like this arise, so let's troubleshoot please.  

  • I had the same issue with my eero pro 6 routers but the issue was only localized to one laptop (Windows) compared to the other (Mac). I ended up setting up the preferred band to 2.4Ghz on the Windows laptop under Wi-Fi network adaptor settings and immediately saw an improvement with no more drops other than the usual one offs. It seems in my case forcing the frequency band seemed to help. I wonder if this is the reason the issue seems to be non existent on guest network setup on eero. Maybe there is no auto switching with guest network ? Who knows.. Hope this helps anyone facing this issue.

  • Hi guys, I ran into the same problems described in this post.   My setup: I have 3 EERO Pro 6 routers spread throughout my house. So, while playing online games, I noticed the annoying lag spikes everyone is referencing.  I found out through EERO support that you need to have each EERO router about 25ft min and 50ft max apart from each other.  If they are too close your device will get mixed up and try to switch over to another EERO router resulting in a lag spike.   After I moved my EERO's to be further apart, the lag spikes stopped.   Hope this helps.  

      • david
      • david.4
      • 2 wk ago
      • Reported - view

      elFin I binned the eero’s and replaced them with a different brand.  They have none of the issues with exactly the same placement. 

      Glad you managed to sort yours out!

Like5 Follow
  • 2 wk agoLast active
  • 63Replies
  • 1955Views
  • 36 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support