4

Problems with latest Eero 6 Pro update and Wemo Mini smart plugs?

I was gone from the house for about a week and there was at least one, brief power outage.  When I returned home, I see that there was also an Eero update while I was gone.  After returning home all 3 of my Wemo Mini Smart Plugs were offline.  When I factory reset them and try to re-add them to Wemo and HomeKit, the whole process work perfectly until the very end, but then the configured Wemo mini smart plugs will not connect to the WiFi.  Temporarily halting the 5 gHz band has no effect, nor does setting it to Legacy mode. 

Did the power outage fry all 3 of my smart plugs, but nothing else, or did something about the Eero update make the Eero Pro 6 incompatible with Wemo Mini Smart Plugs.

I was able to get some replacement Feit smart plugs (2.4 only)  to connect and work just fine, but they do not work with HomeKit like the Wemo ones do.

111 replies

    • CMore
    • 2 yrs ago
    • Reported - view

    Yep. I had a problem updating Wemo plugs and also had issues with my plugs authenticating to the Eero.  I had HomeKit Security on the Eero for the Wemo plugs. With HomeKit security enabled, the Wemo must go to a URL registered with Apple by Wemo to get updates. I believe that the address registered with Apple is no longer valid. Once I turned off HomeKit Security on the Eero for the Wemo, the plugs were able to function fine.

    I would suggest disabling HomeKit Security on the Eero for the plugs since you have done a Factory reset. Then decide if you want to leave HomeKit Security off and risk someone updating the OS on your Wemo or if you want to enable security after the update is complete. (It sounds unlikely that someone would hack the Wemo OS, but this did happen to Wemo plugs.)

    To enable the Wemo plug to update its software:

    1. go to the HomeKit home app. 
    2. Click "home settings"
    3. Click "Wi-Fi Network & Routers"
    4. Under "Belkin International Inc Outlet" select "No Restriction"

    I first contacted Wemo support and they could not figure out the issue, but said that there were other calls about the same problem. After I found this "solution" I called Wemo and described the above. I asked the technician if they were having this issue mostly with Eeros or other HomeKit enabled routers and his answer was "yes."

    As you consider what I believe the issue to be, you will understand the advantage of Eero providing HomeKit security in the router. If my assumption is correct, the real fix to this problem is for Wemo to update the URL registration with Apple. I mentioned this to the Wemo tech and asked him to pass this on to Wemo development.

      • scw
      • 2 yrs ago
      • Reported - view

      CMore I was now finally able to test your solution. So I indeed set the setting to ‘No restriction’ but unfortunately still no cigar. I try to add the Wemo plug via both the Home app as well via the Eero app. Would you still have some suggestions/checks for me?

      I am so happy with the one Wemo plug working so fine that I really want the other four (!) to work the same way. If only they could be added :-( Thanks again

      • CMore
      • 2 yrs ago
      • Reported - view

      scw Turning off HomeKit security allowed me to do the firmware update to the Wemo plug. Turning off HomeKit device router security is most likely to help If you go to the firmware update option on the Wemo app and it says there is an update for the Wemo devices, but the update is unable to complete. If your Wemos are at the latest firmware update, then changing the HomeKit Accessory Security is unlikely to help.

      Although my Wemo plugs were working fine for the last few years, I now have one that shows no response in the Home app. That plug operates through the Wemo app.  All three of my Eeros show “no response” in HomeKit router section of the Home app, but on the Home app Home Screen only the non-gateway Eeros show as “no response.” All my other HomeKit devices are responsive. Weird. 

      • scw
      • 2 yrs ago
      • Reported - view

      CMore ah I see, there is the difference: since I do not have the Wemo app. My Wemo Smart plugs cannot be added to the Wemo app, only via HomeKit either via the Home app or the Eero app. Customer Support told me they there is no way to update the firmware on this new Homekit only plugs (?). Not sure if that’s true, what I do know is that now I just have four bricks.

      • CMore
      • 2 yrs ago
      • Reported - view

      CMore I just fixed my WeMo plug by unplugging it, putting an Eve Energy plug (with thread, no WIFI) into the wall socket and then plugging my lamp into the Eve plug.

    • Craigge
    • 2 yrs ago
    • Reported - view

    As a follow up...no resolution so I replaced all my Belkin switches with Lutron Caseta.  Cost me about $400, but everything is working perfectly and I am off the Wemo hurt list.

     

    4 months with eero trying to resolve...and Belkin doing absolutely nothing told me everything I needed to know about that company.  If word of mouth is what pushes product...Belkin is on bought time.

     

    Thanks Eero team for troubleshooting.

    • andyj
    • 2 yrs ago
    • Reported - view

    I have eliminated all but one WEMO device. It is a light switch located inside the front hall closet that turns on outside soffit lights on a timer basis (30 min before sunset to midnight) and so does not really need to be accessed either physically or electronically (as the settings are stored on the device). On the odd occasion that I need to access the switch I can put the EERO on 2.4 GHz only mode for 5 minutes. I do have a replacement switch but I may use it elsewhere to add another controlled switch.

    • komocode
    • 2 yrs ago
    • Reported - view

    Have noticed the same issue. I replaced my Google Wifi at home and a few days later,  ALL my wemo switches eventually would stop working and an orange light would appear.

    Have done factory resets, changed wifi passwords, moved routers to a new place, etc... wemo switch would work for a few days then stop.

    I then replaced Google Wifi in my office. Same issue happened. HomeKit is not setup on Eero in my office either so it's not that.

    It's incredibly annoying. I eventually replaced Wemo with Meross switches and they seem to work.

     

    I'd go Lutron if I could as RF is much more reliable but they don't seem to have a smart plug. 

      • CMore
      • 2 yrs ago
      • Reported - view

      komocode The Lutron Caseta wall plug is model PD-3PCL-WH.

      • komocode
      • 2 yrs ago
      • Reported - view

      CMore saw that but it’s only meant for lamps. 100 watts max and only has 2 prongs.

      • scw
      • 2 yrs ago
      • Reported - view

      komocode CMore komocode

      This is off-topic, the post is about eero + Wemo.

      • komocode
      • 2 yrs ago
      • Reported - view

      scw then ignore it. I said what I said about wemo.

      • scw
      • 2 yrs ago
      • Reported - view

      komocode Thanks for your understanding. You can start a new thread for that.

      • komocode
      • 2 yrs ago
      • Reported - view

      scw start a new thread about Wemo? that doesn't make sense.

    • andyj
    • 2 yrs ago
    • Reported - view

    There is the outdoor unit that is a 3-prong plug. Don't know the specs, and it may not be rated for interior use.

    • BGG
    • 2 yrs ago
    • Reported - view

    Same problem. It seems disabling 5GHz “solves” the problem. After using the “temporarily disable 5GHz” option all Wemo devices became visible in the Wemo app again. Unfortunately they start disappearing once 5GHz is enabled again. Hope either Wemo or eero team find a solution to this.

    • scw
    • 2 yrs ago
    • Reported - view

    BGG please see initial post of cwstnsko :

    "Temporarily halting the 5 gHz band has no effect"

    Also, the EU version of the Wemo Smart Plug does not use the Wemo app anymore... it only can be added via Homekit. Both the eero app and the Apple Home app do not find the plug :-((

    • BGG
    • 2 yrs ago
    • Reported - view

    Not sure what happened, but all of a sudden all my WeMos are back online, without disabling 5GHz. Did not see any recent eero updates, so wondering what changed… :-/

      • klbass68
      • 2 yrs ago
      • Reported - view

      BGG I wonder if they can make adjustments on the backend and secretly push out updates? :D Now all of a sudden all the devices that couldn't connect with Wifi 6 enabled are now able. My old work laptop is one. It never saw my network with Wifi 6 enabled. Likewise, my Honeywell T9 Thermostat. Now both have been connected reliably to the network for almost a week.

      • klbass68
      • 2 yrs ago
      • Reported - view

      klbass68 I spoke too soon. A few hours after my prior post, my Honeywell T9 lost connection. It shows connected in the Eero application, but the device itself shows not connected. Thankfully the old laptop has stayed connected.

    • scw
    • 2 yrs ago
    • Reported - view

    @eero_support Could you possibly give follow up on the suggestion of @CMore?

    “for Wemo to update the URL registration with Apple”?

    • dautomator
    • 2 yrs ago
    • Reported - view

    So... finally some success with 6.8. I removed WPA3, made the band 2.4 only and made legacy mode, and was able to configure all my wemo smart plugs that could not before. Long ones, short ones, and an outdoor.

    Not sure what did it, but they worked. Hope this helps... And they keep working after 6.9!

     

    Other experiences?

    • scw
    • 2 yrs ago
    • Reported - view

    Great to hear @dautomator. What’s Legacy mode, where do I find it? Did you add the plugs via Homekit or the Wemo app?

      • dautomator
      • 2 yrs ago
      • Reported - view

      scw 

      legacy mode is one of the troubleshooting options. Disable 2.4 and cannot detect wifi 6. That is legacy mode. And WPA3 is beta. 

      all HK security is in Auto.

       

      i just realized that I still had wpa3 disabled… maybe it needs to be until it is in production….

    • Biggietx
    • 2 yrs ago
    • Reported - view

    I am dealing with the same issues. I have 3 eero 6 pros and 13 Wemo devices. Same troubleshooting as above. No joy. 
    I used to be able to reach them by temporarily disabling 5ghz, but now they are just gone. I am torn given the hundreds of dollars I have in wemo, but being unable to turn of the lights in your home is untenable. 

    • andyj
    • 2 yrs ago
    • Reported - view

    The problem firmly lies with WEMO as other 2.4 GHz only devices that I have (most of my IOT) do not seem to have any problems connecting through the eero network. In fact I switched to the eero devices primarily because of problems I was having with devices constantly disappearing in more remote (from the router) locations in my house with other routers. 
     

    Plugs were switched to Eve and I added more Insteon switches (because 6 out of 11 of my switches are in 3 way circuits which Eve doesn’t support). 
     

    I have one WEMO switch still in service (inside a front hall closet controlling an outside soffit outlet). I don’t really need to control this switch on a day-to-day basis as it is programmed to come on near sunset and turn off at midnight, and getting into the closet to change it out is a pain, so I think that I’ll leave it in place, and use the spare new Insteon switch in another location that could use automation. 

Content aside

  • 4 Likes
  • 11 mths agoLast active
  • 111Replies
  • 3257Views
  • 34 Following