Problems with latest Eero 6 Pro update and Wemo Mini smart plugs?

I was gone from the house for about a week and there was at least one, brief power outage.  When I returned home, I see that there was also an Eero update while I was gone.  After returning home all 3 of my Wemo Mini Smart Plugs were offline.  When I factory reset them and try to re-add them to Wemo and HomeKit, the whole process work perfectly until the very end, but then the configured Wemo mini smart plugs will not connect to the WiFi.  Temporarily halting the 5 gHz band has no effect, nor does setting it to Legacy mode. 

Did the power outage fry all 3 of my smart plugs, but nothing else, or did something about the Eero update make the Eero Pro 6 incompatible with Wemo Mini Smart Plugs.

I was able to get some replacement Feit smart plugs (2.4 only)  to connect and work just fine, but they do not work with HomeKit like the Wemo ones do.

110replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Same problems here. Have tried just about everything to get my wemo plugs and light switches/dimmers to work. We have at least 7-8 plugs and maybe 10 switches/dimmers in the house, and it is so annoying having half of them disappear/not respond until doing a reset and only having them work for maybe a day or two before they kick back offline and just flash orange and white continuously. Seriously sick of the headache and WeMo appears to have 0 support on the issues. I have seen a couple people mention that setting a dedicated IP might help so I will try that to see if it magically helps but I somehow doubt it. Really hoping for a reliable solution other than replacing everything with the hefty investment already made into the WeMo products. Will likely never buy another belkin product again.

      • Jdr
      • Jdr
      • 1 yr ago
      • Reported - view

      Nicodemus like others have noted on this thread, I have decommissioned my legacy Wemo devices. Price point on smart plugs that support HomeKit out of the box makes the decision a no brainer for me.  Kasa/TPLink smart plugs are dirt cheap as well and work across ecosystems - another reason I dumped Wemo.

  • I still have one WEMO switch, and of late it seems to be working OK with WEMO app. I don’t really use the app, as it is programmed to turn on 1/2 hour before dark and to go off at midnight, for my outside Christmas lights. They are unplugged after the Christmas season, so not really an issue going on/off all year round. The only reason that I checked lately was curiosity. 

    I switched my plugs to Eve units. They work well, if a little laggy on Bluetooth. I upgraded my Apple TV 4K to latest version and was able to use Thread, which made the Eves respond immediately. But now the Apple TV refuses to act as the border router for the thread network, and I’m back to the slower BT connection. So now I have another compatibility chase, but at least Eve and Apple seem to be helpful trying to sort out the problem. Just no luck so far. 

    For switches, I replaced my WEMOs with more Insteon switches, which now seems like a bad plan in light of the recent vaporization of Insteon and parent company, but fortunately as I am using HomeBridge, the devices are still working in HomeKit. Just can’t use the Insteon app. Not sure if I’ll be able to install my one last Insteon switch that is still in the box (it was intended for that last WEMO location, but I might try it in another location). 

    When Eve comes out with their Thread capable wall switches I may upgrade from Insteon (assuming that I can get the Apple TV Thread working). 

    IOT, still not ready for prime time yet. 

  • After weeks of frustration, I found a post on a Best Buy thread and it worked.  The key is disabling 5GHz BUT ALSO following the instructions to do a RESTORE on the plug before you add the accessory.  

    Instructions to restore: https://www.belkin.com/us/support-article?articleNum=317782

  • Also leave IPv6 toggled OFF

  • I went to Eero Settings and Troubleshooting and disabled 5G temporarily (15 minutes) and all my Wemo devices showed up in the Wemo app within 1 minute.  

      • Willibu
      • Willibu
      • 3 mths ago
      • Reported - view

      Willibu As follow up I did restart the Wemo app after I temporarily disabled the 5g on my network.  After I reenabled the 5G the devices continued to show for about an hour and then went back to showing as it connected in the Wemo app.  

      I do have one Smart Outdoor Plug (WSP090) and it always shows as connected in the app.  I have two very old larger size plugs and three of the smaller size Smart Plug and both styles show offline when 5G is active in my eero.  I have three Eero Pros running my network. 

Like4 Follow
  • 3 mths agoLast active
  • 110Replies
  • 2103Views
  • 33 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support