4

Samsung QLED Smart TV drops WIFI connection, with Eero PRO 6

I recently moved to Eero PRO 6, and since then my Samsung QLED QN82Q6FN Smart TV continuously drops WIFI connection, every time I switch on the TV. I have to go into Settings->Network, and set the wifi connection again, after which it starts working. 

 

Any tips on how to fix this problem? 

76 replies

    • Erika10299
    • 2 yrs ago
    • Reported - view

    Same issue here with my Samsung QLED - if you turn off the tv for any length of time — eero Wi-Fi’s show’s it’s “not connected.” Turn the tv back on and you have to go to setting and reconnect the tv every single time. It’s very frustrating! There is no setting that I can find on my tv to change this — never had an issue before eero pro 6. It’s definitely an issue on eero’s end with compatibility. Anyone have any tips. Looks like eero hasn’t solved it.

    • Runica
    • 2 yrs ago
    • Reported - view

    I am having the same issue, curious if any solution presents itself.  Same scenario, Newer Samsung TV, takes a few minutes to connect unless I manually do it then it still takes a minute.  Running an Ethernet cord is possible but not optimal

      • Runica
      • 2 yrs ago
      • Reported - view

      the issue seems to stem from time away from the tv.  Takes 2-3 minutes to reconnect

    • markzerler
    • 2 yrs ago
    • Reported - view

    I did move the Eero closer to the TV, but my issue turned out to be an issue with DirectTV Streaming.  I got rid of it and am back to using YouTubeTV and have no current issues.  Seems to have been an issue with the app.

    • ryen_khoury
    • 2 yrs ago
    • Reported - view

    This happens on my Samsung Q9FN as well. No issues on previous wifi, and other devices right next to my one connect box are fine.

    • steve.5
    • 2 yrs ago
    • Reported - view

    I am having the same exact problem.  Samsung drops from Eero.  I believe if I leave it on for a few minutes it eventually connects, but why should I have to wait??   I usually reset, takes half the time.  

    • Runica
    • 2 yrs ago
    • Reported - view

    I had to run a wired connection, very frustrating running a 75’ cable through my attic :/

    • Pretzel11
    • 2 yrs ago
    • Reported - view

    I am experiencing the same issue with my eero 6 pro and Samsung tv. It was a gift to my parents, who are too old to diagnose and fix. I’m afraid the pro is going to be returned if there is no fix soon. 

      • klbass68
      • 2 yrs ago
      • Reported - view

      Pretzel11 I seem to have resolved my Samsung TV issues by disabling WP3 and enabling legacy mode. 

    • Stites_jx
    • 2 yrs ago
    • Reported - view

    Joining the list of disgruntled Samsung, eero, direct tv stream customers.  2 Samsung TVs and ongoing drops for months now.  I will call again (called 6+ times) tomorrow but at this point I’m beyond my Amazon return date and stuck.  My wife and kids think I bought a cheap device and they complain non-stop.    A little piece of me does every time I get this message and it happened about every 20-30 minutes continuously.  Please help.  

    • ryen_khoury
    • 2 yrs ago
    • Reported - view

    I returned eero. It’s atrocious compatibility with Samsung and even worse with Apple products.

     

    Went back to older Orbi setup where everything works flawlessly

      • paokada
      • 2 yrs ago
      • Reported - view

      @eero_support  I'm sorry but I completely disagree with you that the issue is with the Samsung TV.  It is almost certainly with the eero pro 6.  I say this because neither I, nor it seems the bulk of the folks responding here, ever had a problem with the TV disconnecting before "upgrading" to the eero pro 6.  This is an eero pro 6 issue and it is disappointing that eero won't recognize it.

      • klbass68
      • 2 yrs ago
      • Reported - view

      ryen. khoury Is your Orbi and WiFi 6 system?

      • ryen_khoury
      • 2 yrs ago
      • Reported - view

      klbass68 no it’s the original Orbi mesh. It’s actually great, only tried eero because it’s forced eero with Ring Alarm Pro and I wanted that local storage.

       

      everything went back, got the last gen ring alarm and put my Orbi mesh back up and it’s all perfect.

       

      very disappointing as I was excited to get wifi 6 and I did like the eero app. 
       

      it’s just terrible at the one thing it should be GREAT at. Wifi. 
       

      It’s unbelievable that it has such problem with the most popular brands, Apple & Samsung. 
       

      if you can’t work well with Apple products, I’m sorry, you won’t be in my home.

      • klbass68
      • 2 yrs ago
      • Reported - view

      ryen. khoury I think all Mesh systems that are Wifi 6 are having issues. I went and took a look at Orbi's community boards and people are reporting disconnects with the Orbi Wifi 6 Mesh system. Likewise, on Linksys' and AmpliFi's community boards with their Wifi 6 Mesh systems.

      Like you, if I revert back to my Linksys Velop Mesh system, which isn't Wifi 6, all is well. 

      • mitch777
      • 2 yrs ago
      • Reported - view

      klbass68 I don’t think you are correct.  I am running just a single EERO pro 6 router without any satellite routers.  So it’s not a meshed network.  I also turned off WiFi 6 functionality in the router.  This made no difference.  The problem remains.  Additionally, I turned off IPv6 in the router.  No help.   I turned off client steering.  No help.

      • skelley5000
      • 2 yrs ago
      • Reported - view

      mitch777 I ended up turning off WPA-2 and it fixed my connection problem, but I wanted to use WP2 so I just hardwired my TV to a switch

    • Pretzel11
    • 2 yrs ago
    • Reported - view

    James @eero_support  Let me know if there are any device logs or diagnostic information I can get you...

    My brownouts seem to only happen overnight. This morning, my Samsung TV was offline, along with my chromecast! 

    We have been at this property for 3 years with the same device configuration, and had no issues with the previous router, so this is definitely due to the Eero 6 pro. 

    As the original author states, as soon as I go into network settings on the TV and attempt to reconnect manually, it works again for the entire day, then cannot reconnect to the router the next morning. One thing I did try lastnight with the TV was to disable IPv6, but it still couldn't connect this morning. I also verified that there were no firmware updates for the TV. 

    The chromecast is also now having issues. It displays an error on the TV "Please check your internet connection, or restart your router", which means that it has an IP address from the router, but cannot access the internet. As you can see in my screenshot, the router knows about it, and it is considered "active", as the timestamp for "last seen" updates every minute, so the devices are communicating... The chromecast simply cannot get online. It's also interesting that the wifi signal shows 1 bar... whereas EVERY other device on my network has full wifi connectivity...

    The last thing I am going to try, is to disable IPv6 entirely in the Eero settings, as I've read that your ISP can interfere with IPv6 devices. 
    https://www.reddit.com/r/eero/comments/e5nyjv/comment/f9lbw4l/?utm_source=reddit&utm_medium=web2x&context=3

    • kerberos
    • 2 yrs ago
    • Reported - view

    I couldn't even connect my Samsung TV at first.  Once I turned off WPA3 and client steering, I was able to connect now.  Not sure how long it will stay connected but my guess is that the Samsung TVs don't work nicely with these newer features and your older routers probably didn't have them, hence no issues.  Try disabling WPA3 (although that's much better for security) and client steering to see if it make a difference.  I'll switch to Ethernet so I can have those features enabled though.

    • Lynf
    • 2 yrs ago
    • Reported - view

    Same exact problem. Just bought new Eero 6 router. Works fine except I have to reset WiFi every time I turn on Samsung QN series TV. Extremely annoying. No issue with prior router. Why isn’t Eero addressing this?

    • Tretinker
    • 2 yrs ago
    • Reported - view

    Installed Eero 6 a few days ago and every night since our Samsung TV has had to be reconnected to the WiFi until tonight where it can't find the network at all now! 

    I searched the Web to see if there is a solution but it seems despite this being a year old issue that nothing has changed!

    If anyone has any tips on what I can do I would be very grateful 

    • mickycat
    • 2 yrs ago
    • Reported - view

    I have exactly the same issue with my Samsung QN75 TV. I often find the Wifi is connected but shows an alert sign. I have to turn off wifi and reconnect to fix it. It only happens to the Samsung TV. This is really annoying. I have multiple eero pro 6 to form a mesh.

    • Lynf
    • 2 yrs ago
    • Reported - view

    Why can't eero fix this problem? I switched from an Apple Time Capsule Router to eero. I, too, have a Samsung QN65Q8FNBFXZA. I recently bought an eero 6 mesh system with one extender. I live in a small NYC apt. Before, with just one Apple router in my bedroom,  my living room TV connected seamlessly. Now, like others, I have to reconnect thru the tv almost every time I put it on. Sure, it doesn't take long and then works fine. But I shouldn't have to do this. WHY CAN'T EERO FIGURE THIS OUT AND FIX IT????? Such a pain! And clearly, this is an issue with eero as so many before me have noted.

      • Mblue999
      • 2 yrs ago
      • Reported - view

      Lynf QN65Q6FNA worked fine. "Upgraded" to eero pro6 and daily disconnect issues since. Have tried all the settings...ip6, beam steering, etc. The entire history of everyone makes it clear that this is an eero problem. Unfortunately, cannot run an ethernet cable to the TV, so trying to decide if I should spend money on another network or replace the tv....thanks to eero.

    • Gemfeeney87
    • 2 yrs ago
    • Reported - view

    I'm having the same problem with my LG TV, its three years old but the people in currys said that's not old for a smart tv and spoke to talktalk and they told me I need to get a new tv! I asked for a booster they said they don't do one. I've never had problems connecting to the Internet before the eero box.

Content aside

  • 4 Likes
  • 5 mths agoLast active
  • 76Replies
  • 5841Views
  • 49 Following