1

Samsung QLED Smart TV drops WIFI connection, with Eero PRO 6

I recently moved to Eero PRO 6, and since then my Samsung QLED QN82Q6FN Smart TV continuously drops WIFI connection, every time I switch on the TV. I have to go into Settings->Network, and set the wifi connection again, after which it starts working. 

 

Any tips on how to fix this problem? 

20replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello,

    Devices decide whether or not to try and establish a connection with networks. I would first check to see if there are any updates you need to do on your TV. You can also reach out to Samsung as they might need to update the wifi adapter drivers as well. I do know that come computers with older wifi network cards needed to do this as well. I also have a few more questions to help us narrow down possible causes.

    Are any other devices experiencing this connection behavior?

    Does this happen only when the TV is powered off for an extended period of time or can you power it off and then back on and it will stay connected?

    Another option you can verify with Samsung is if the TV stores network information in a battery powered part of the TV and if so, look into replacing that battery.

    Looking forward to hearing back from you,

    James

    eero Support

    Like
  • Before Eero Pro 6, I was using a Linksys non-mesh dual band router and my TV was connected to wifi all the time. 

    Regarding your questions:

    Are any other devices experiencing this connection behavior?

    - Not at this moment. 

    Does this happen only when the TV is powered off for an extended period of time or can you power it off and then back on and it will stay connected?

    -  Yes, it happens when the TV is powered off for an extended period of time (few hours). If I turn off and on within few mins, it still stays connected to wifi.   

    Another option you can verify with Samsung is if the TV stores network information in a battery powered part of the TV and if so, look into replacing that battery.

    - I don't believe it is specific to the TV, as it used to work fine with my old Linksys router. Suspect it is about Eero and how it is managing connections. 

    Like
    • ram 

      Hello,

      eero would not do anything that would prevent the TV from connecting to it if it had the password and network information saved into the TV. You stated that no other devices are exhibiting this behavior and that you need to go into the TV and setup the connection again. Something in the TV seems to be forgetting the network information. 

      We can do some testing on your network if you would like. However, this seems to be behavior isolated with your Samsung TV. Have you contacted Samsung support to find out if there were any firmware upgrades they can push to your TV and explained that your Samsung TV seems to be unable to connect to wifi after a period of time being offline?

      One trouble-shooting step we can also take is to place your eero network into legacy mode and see if your Samsung TV was just having issues connecting to WiFi 6. The option is in the eero app: Settings -> Troubleshooting -> My Device Won't connect. Legacy mode turns off WiFi 6 on just the 2.4Ghz bandwidth which has more than enough speed to stream 4k HD shows.

      Thank you,

      James

      eero Support

      Like
  • Sorry James, I dont agree that this is not related to Eero PRO and how it is handling connections. As I mentioned earlier, my previous Linksys dual band router, never game me this problem. 

    Like
  • I also am a new Eero Pro 6 user with a Samsung QLED TV, and I have this same exact experience. The connection is dropped after a few hours and I have to restart the TV (to trigger a reconnect) or manually reconnect in the TV’s network settings.

     

    I’ve been through 2 different routers with this TV prior to getting an eero. I think somethings not playing nicely between these two devices - hard to say which device’s fault it is with certainty, but considering it’s not had this problem before, I’m inclined to believe it’s on the eero side of things.

    Like
  • Same.  We got two eero Pro 6 devices.  Immediately our Samsung 8 series 55" TV started having no network connection every time when turning it on after being off for a while.

    One of the eero devices is located directly behind the TV, since that's the only place where the cable/network is connected in our apartment.

    This is a pretty bad problem, and it is definitely related to the eero.  Former routers were Linksys and ASUS, and there were no problems with them and the TV.

    We got the eero devices because we're moving to a 4 story townhouse and will need a mesh network.  They'll have to be returned soon if a fix is not available.

    Like
  • All,

    We are also having the same issue at our house since we switched to the eero. We never had an issue with our old router. The eero is sitting next to our Samsung TV and seems to lose connection every night, once we turn off the tv for the evening. Once connected again in the morning, the tv does not lose connection. Just bought a switch so that I could wire the tv directly to the router so that this problem would go away, however, I am sure there is something with the way the eero is handling the connection that needs to be addressed. Other than, that we love our new router. 

     

    Thanks,

    Dan

    Like
  • I’m having the same issue with my new eero 6 and Samsung TV.  No problems at all with my prior eero router but now the TV keeps getting disconnected.

    Like
  • I am having the same issue with the 6 Pro and our Samsung. It’s is a little annoyance  for me, but my kids don’t understand how to hard rest the TV.

    Like
  • I’m having the same issue with my new eero pro 6 and my Samsung tv. I do think this is related to eero because I’ve never experienced this issue with my old router. Tried a bunch of settings and no luck. It’s really annoying as I can no longer turn on my TV via the Samsung app or smart assistants and I had to set the network connections every time I turn on my tv.

    Like
  • Update, still no fix however, I have noticed when I turn my TV on in the morning, if there is no connection, I can turn off the TV and wait two minutes. Then when I turn the TV back on it is reconnected to the network. I am going to try hardwiring soon. 

    Like
  • I’m working at a rental condo that is having this issue on FIVE separate Samsung TVs.  One TV is a 43NU6900 another is a 50NU710D, since I’m not on site right now I don’t have the other model numbers but they are similar in age.  If the TVs are off for maybe 15 mins or more they will lose an automatic connection.  If I go into network settings and simply click “Network Status” it will successfully connect.  I did speak with Samsung support several times, we tried static IPs (with reservations), different DNS servers, and factory resets (through the service menu),  Nothing worked.  The signal strength is great everywhere in the condo.  All TVs have the latest firmware.  This is clearly an issue with how Eero and Samsung are communicating (or not communicating).  Does anyone have any successful resolution?

     

    (I’m having to install Roku’s on all five TVs to get away from the problem for the client - not an ideal solution).

    Like
  • I’m having the same issue with my TCL Roku TV. The interesting part is that I had an eero original as my gateway router before and never had this problem. I upgraded to an eero Pro 6 last week and every morning now have to manually reconnect to the network as the TV loses connection overnight. 

    Like
  • Yes! That's why I'm convinced that it's my eero and not the TV. I had an older eero and never had a problem with the same TV.  Ever since I "upgraded" to the eero 6,  I have to reconnect all the time.  It's ridiculous.  Eero needs to tell us what is going on and come up with a fix.

    Like
  • I have a Samsung QLED 4K TV hardwired to an Eero router (the TV only has a 100 mb/s ethernet card, but I guess that's fast enough).  I just upgraded a few days ago from an Eero Pro to an Eero Pro 6 as my router.  Even though I have Ethernet, I had the same issue when I turned the TV on once, so it is not limited to WiFi.  The issue has not recurred but I've only had the Eero 6 pro for a few days, so I'll have to wait and see.  Don't be surprised, though, if your problem persists even if you replace WiFi with ethernet.

    Like 1
  • I am experiencing the same issue. I have 2 Samsung TVs (connected via LAN cable), NVidia Shield TV (LAN cable) and Fire TVs device (Wifi). I also have an LG 48" CX TV in my office connected via Wifi only. I was expericning the same issue with both Samsung TVs and no other device was affected. Here are the tests that I have performed:

    - Replaced my eero with my old Asus rt-AC88U modem/router and everything started working again.

    - Used a Different Router (TP-Link AX5400) connecting to a different Internet provider (4G modem) and all devices including the Samsung TVs are connected using Wifi instantly.

    - Configured eero devices back in to the environment. Samsung TVs stopped connecting via Wifi and LAN cable.

    - Performed a direct connection from eero to the TV, still the same issue.

    - Devices information:

    1. 75" QLED Q70T (2020)

    2. 65" 4K UHD Series 6 (2014-2015)

    3. LG 48" CX (2021)

    None of the other devices seem to show the problem.

    It almost looks like the issue is related to how eero Pro 6 connects to Samsung hardware.

    Like 1
    • Hello stnadeem ,

      Thank you for reaching out to us and welcome to The Community! So the two Samsung TVs are unable to connect to the eero 6 network over ethernet or WiFi? That is very odd. I'll send you a direct message with instructions on how to get an email to me so we can look into this further.

      Like
  • Same for me with LG CX and Samsung Q7. Constant losing Wi-Fi connection with Eero Pro 6. Turning tvs off and on helps a bit. Restarting Eero nearest hub usually fixes the issue. 

    Like
  • I know it is not optimal, but if you have ethernet it makes a rock solid connection with the Samsung.  I've been using it as my exclusive input to to my Samsung 850D for a year without a hiccough.  The network card in the TV is only 100 MB/sec but it is plenty fast even for 4K streaming.  I'm fortunate in that my gateway EERO is connected to a network switch with 16 ethernet ports and is close to my TV.  

    Like
  • Yep. Came to see if this problem with anyone else. The tech clearly doesn't understand the problem as the tech did not give a fix for the device. Like is there a hibernation setting we need to tweak in eero or some firmware update?

    I switched back over to my Google WiFi which is close to a  200mbps DL drop compared to EERO 6 Pro (Not a wifi  speedtest). 

     

    Hopefully this is fixed otherwise, I'll stay with less speed. Reliability over speed - always -

    Like
Like1 Follow
  • 1 Likes
  • 9 days agoLast active
  • 20Replies
  • 428Views
  • 14 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com