Eero automatically blocking access to needed web sites and services

I have a repeating problem with my Eero network. There are, at times, websites or outside web services that I need to access, but Eero blocks them.

This is WITHOUT me running Eero secure or any other blocks on my end. Eero simply chooses not to allow access.  I'm sorry, but this is total B.S.

Eero should not have a say in any outside sites I access. None. Not unless I ask for the block.

And no, this is not to access porn or some other crud; today, the current problem is my new Chamberlain/LiftMaster MyQ account server (my garage door opener and garage smart camera). I can connect just fine with LTE data. I can also connect using my back up wifi router when I plug it in to the same cable modem.  But when I try to connect through my Eero wifi, I cannot reach the server.  It's blocked.  This is unacceptable.

60replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • The best feature of the eero is its design -- unobstrusive, small footprint, blends into the wall.  It looks pretty.

    The worst feature of the eero is that it is not a router! It is a router that routes only when it feels like it! I tried all of the solutions mentioned here. Yesterday, I finally just unplugged the satellite eero and that seemed to finally let me access all the websites I needed to. Tonight, suddenly it decides that it no longer wants me to access google.com -- yup, it was blocking me from google.com. After an hour, of switching back and forth between regular and guest mode and rechecking everything on the cumbersome eero app, it suddenly decided it was okay to let me access google again!

    I just purchased this 16 days ago. For the first week, it seemed fine.  Then, the nightmare began!  While it is now past the return date of Best Buy, I refuse to waste anymore time dealing with eero!  Tomorrow,  I will be going to back to Best Buy to purchase a standard, who-cares-if-it-looks-like-an-alien, router!!! 

    Eero Saarinen was a genius of form and function.  This amazon eero is sadly a poor example of it.

  • If you think it's bad as a user, try running a service that gets randomly blocked by Eero. We have paying customers who call us saying our app doesn't work, and there's no indication of why it's not working since the requests just time out. We spent two months trying to debug the issues until we finally noticed a pattern that people were reporting having an Eero. Our only recourse is to sound sketchy by telling our customers to turn off their security settings while requesting that Eero stop blocking us with no feedback or timeline for when that might be fixed. It's terrible.

  • Has anyone found a fix to this?  I do NOT have an eero pro, so it's not white or blacklisting.  I can get to the sites when I connect directly to my cable modem, but not through the eero.  Doesn't matter what browser or what device I use.  And it's intermittent, sometimes they work and sometimes they don't.  I can get to the sites if I use a VPN.  I've tried changing DNS servers, that didn't help.  Anyone?

      • sharpe15
      • sharpe15
      • 6 mths ago
      • Reported - view

      sharpe15 Correction, I do have eero pro but not secure. 

  • Having same problem but only affecting my Fire Cube running any Amazon Apps/Services.

    guest network solves issue but just can’t get primary network to work.


    I’ve disabled eero secure’

  • I am having the same problem trying to surf the web. When I use my windows PC laptop and connect to the Eero network, websites are blocked, even on the guest network. Using a VPN seems to fix the problem and I can surf easily. I can also surf using the Eero network on my iPhone with no VPN and have no problem. The blocking happens only with the Windows laptop and no VPN. 

  • I was also having issues with some websites timing out. I tried changing all options within Eero and the Firewall settings on my modem. The only thing that worked for me was deactivating IPv6. I guess I'll leave this off until no one uses IPv4.

  • Does anyone else have issues with the eero blocking BBC iPlayer, ITV Hub etc? if I plug into the router direct, it works. If I run it through the eero they all disappear. Means I can’t run my upstairs TV properly. My internet provider are baffled. I thought it was just the new TV I got at Christmas but it’s definitely the eero blocking it. Thanks.  

  • I’m experiencing the same issue with the Commerce Bank app (not the website) on my iPhone. As is my daughter on hers. I launch the app and it just hangs on the splash screen if I’m on Wi-Fi. But if I disconnect the Wi-Fi and get on the cellular network the app works as expected. 

    I do not now nor have I ever run eero Secure or eero Plus. So nothing eero related should be doing any sort of site blocking. It hasn’t always been like this as the problem only started a few months ago. 

    Originally I had Local DNS Caching enabled and was using my local ISP DNS. Couldn’t launch the app. So thinking it may be a corrupted DNS cache I tried …


    Disabling Local DNS Caching and keeping my local ISP DNS. Couldn’t launch the app. 

    Disabling Local DNS Caching and switching to OpenDNS. Couldn’t launch the app.

    Enabling Local DNS Caching and switching to OpenDNS. Couldn’t launch the app.


    After testing all combinations I think it’s safe to say that it doesn’t matter if Local DNS Caching is enabled or disabled. It doesn’t matter if I’m using my local ISP DNS or OpenDNS. But there is something about EERO that is blocking this app. 

    • OAW Make sure to call this into support so it can be investigated and fixed.

    • OAW I have exact same problem, I believe. I haven't tested anything because I'm not as savvy. :-) I cannot access PayPal. No one in my house can. We're in Oregon. I set my mother up with an eero and she's in Tennessee and she also has access problems. What I notice is that I can access the PayPal site ONCE. After I get to the website, I cannot do anything else. My computer screen spins as if loading. Same for my phone. But the second I turn off WiFi on my phone, it works. I can create a Personal Hotspot for my home laptop to connect to my phone using cellular and everything works. 

    • jamesreb360 I should add, I have no Secure subscription. I'm using only the basic eero 6+ router. 

      • OAW
      • OAW
      • 2 wk ago
      • Reported - view

      jamesreb360 Be sure to contact eero Support. They were able to help me get my issue resolved.

    • OAW thank you. I just did that. For now, I'm using my phone's cellular and connecting my laptop using a hotspot. 

  • For those of us with NO erro PLUS or Secure subscriptions, just operating with the eero base router, they provided these steps to clear up these issues accessing/loading various websites from computers and mobile device apps. This worked for me. Not sure whether this also helps those with eero subscriptions to Plus or Secure. 

    Please follow the steps exactly:

    1. Power off both the GWE eero and the modem
    2. Wait 3 minutes *
    3. Swap the Ethernet port on the eero
    4. Power on ONLY the modem
    5. Wait until it's online
    6. Power on the eero 
    7. Reboot the device with which you were trying to access PayPal (or whatever site has the problem) and try again.

    * Make sure you wait the 3 minutes.

  • I just purchased eero plus and am having the same problem, which is very frustrating. I'm trying to cancel but customer service is unresponsive.

    • bcassid Please send us an email to support@eero.com and use the subject line "Community Followup - eero Plus cancellation" and we'll see what we can do. Please send this email from the email address on the eero account (to check/change/verify the email go to eero app->Settings->Account).

      Please note that if you signed up using ApplePay you will have to cancel via Apple's store, we can't do those remotely.

  • I am having a similar yet somewhat different problem.  I replaced outdated router equipment with Eero 6 recently and my outdoor Wi-Fi security cameras began to function intermittently.  The 1.5 year old cameras were supported by an extender, but the eero provides robust signal strength in the area of the the Edimax Technology cameras (marketed by Honeywell).  To correct the camera connection issue, the extender was removed and the cameras reset.   The cameras successfully join the eero network.  After successful connection the camera initiates a registration process with the Edimax servers. The registration process repeatedly (always) times out.  Working with Edimax Technology tech support several work arounds were attempted including temporarily suspending 5G service and registration through a guest network.  The work arounds failed.  Eero tech was then contacted and after sometime between the security company tech and eero tech about sub-mask and other issues, the eero tech acknowledged (after consultation with other Eero tech team members) a known Eero communication problem with Edimax Technolgy cameras.  The ultimate recommendation was and camera replacement with Netgear products.  Not a good suggestion from the perspective of the security company that supports many Edimax Technology cameras or the customers perspective who now must choose to replace the home network router system or the security camera system to secure the full array of desired service.  Buyer beware, Eero does not communicate with Edimax Technology Wi-Fi cameras.

  • I just created an account only to say that I canceled my eeroPlus subscription this morning due to this issue. I have been fighting with issues on a couple of major websites the last couple of weeks and in an act of desperation this morning, I tethered with my phone instead of using wifi, and behold, all of the issues went away! To further test that it was my eeroPlus subscription causing the issues, I disabled the "advanced security" feature and everything worked fine after that.

    As a final data point that I made the correct decision of canceling my subscription, I received a 502 bad gateway error when going through the workflow on account.eero.com to cancel my subscription. I forgot that I had reenabled the advanced security feature during my testing, so after disabling it again, I was able to successfully cancel the subscription. It's absolutely pathetic that the flagship feature of your subscription service is breaking functionality ON YOUR OWN DOMAIN.

Like9 Follow
  • yesterdayLast active
  • 60Replies
  • 5302Views
  • 42 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support