Eero automatically blocking access to needed web sites and services

I have a repeating problem with my Eero network. There are, at times, websites or outside web services that I need to access, but Eero blocks them.

This is WITHOUT me running Eero secure or any other blocks on my end. Eero simply chooses not to allow access.  I'm sorry, but this is total B.S.

Eero should not have a say in any outside sites I access. None. Not unless I ask for the block.

And no, this is not to access porn or some other crud; today, the current problem is my new Chamberlain/LiftMaster MyQ account server (my garage door opener and garage smart camera). I can connect just fine with LTE data. I can also connect using my back up wifi router when I plug it in to the same cable modem.  But when I try to connect through my Eero wifi, I cannot reach the server.  It's blocked.  This is unacceptable.

12replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I too have a site www.schedulesdirect.org that I need access to. When I try normally my browsers will time out and I get a message about the site not being able to be reached. I worked with support but did not get any solution. I too connected direct to the modem bypassing the eero router and all works perfectly, so it is not with my antivirus or anything else. I did find that a work around was to turn on my Norton 360 VPN which I normally leave off. Once that is turned on and I am using the VPN then I can access the site every time. I will try working with support some more and see if we can figure out what setting is keeping me from accessing my cable TV guide listing site.

  • Anybody find a resolution to this? I’ve worked with support too but they all act like they’re befuddled. I find that all cannabis sites are blocked, even when I have all secure turned off. Anybody got a list of manufacturers that aren’t trying to enforce their so-called morality? I need to know before I switch vendors.

  • Enable the guest network, connect to it and see if you can access the website in question. The guest network bypasses all the eero security features or so I have read.

  • Wow, that worked. Curious, wouldn’t you want more security on your guest network than your home network? Regardless, what do I need to turn off on my main network to get it to work like this? I have all content filters turned off now.

  • Can't Connect to socialclub.rockstargames.com [] .A bit off topic, not real fond of the Eero Android app. at least v6.2.1-23, don't know what /when it changed, I didn't use it (other than initial set up w/ MetroNet) I don't have a discovery screen with Allow / block options just an Amazon link button [added reluctantly] and Eero Labs [Beta] with 4 buttons greyed out - I did try 'optimize for conferencing and gaming' -no effect for my problem. I can't seem to access router through, PC \ Chrome. -to see (change?) settings etc. I've been on the phone with MetroNet (twice 40min+ per) My networking knowledge is limited, But did the obvious reset/unplug etc changed the DNS to google ( etc etc Was working fine until MetroNet (Eero??) did a 2am-5am Maintenance window -doing unspecified. When using T-Mobile hotspot (RedDead/ GTA) works fine.(Slower and capped at about 15G /mth) ...Prime, YouTube, SamsungTV etc.not affected negatively by maintenance window.

  • i to have problems opening important sites on my PC. I put the domains in the allowed section of the app, and i turned on guest network, but nothing worked.

  • I am routinely having to turn on my Guest network to follow links in email.  Like, for instance, the Wall St. Journal's various daily emails with links to stories on their site.  But today I had a unique experience when a website I was using (my ADT security system website), upon my clicking on an update entry I had made in my settings, blocked the entire website.  Although the blocking message had "X" and "back" buttons, neither  worked and my browser's back button didn't work either.  This large message box essentially blocked the web page I was viewing and froze the browser.  After restarting my browser, the same thing happened 5 seconds after I successfully logged back in to that site and before I'd taken any action.

    I agree that this is TOTAL BS!!  I think it's great if a router can protect me from inadvertently going to fringy websites that might be dangerous.  But ADT, the alarm company????  Come on!!  SOMETHING is SERIOUSLY WRONG with Eero's algorithm that it used to identify danger spots if one can't connect to legitimate business websites.  And total blocking with no "STOP" button is ridiculous.  Block my click and warn me, and if I choose to go ahead and visit the site, which I will have no problem doing with the Wall St. Journal or ADT, THEN LET ME GO AHEAD by giving me "back-off Rover!" button.

    If someone doesn't have a solution to this pretty fast, my new Eero system of routers is going bye-bye!!

  • PS to above:  For what it's worth, I tried Guest network to work around the ADT block but no help, same issue.  And, I have domain "allow" set for the WSJ, but doesn't stop the link blocking in their emails or a lot of other emails as well.  Guest so far does seem to solve that problem.

    • Hello Willyjp ,

      Thank you for reaching out to us and welcome to the Community! I apologize that you are experiencing some difficulties accessing websites on devices connected to your eero network. There could be a few settings that might be causing this. Can you check your app and see if you have eero Secure enabled? If you do, please try disabling eero Secure and see if you can access the websites. If you can please let me know. Also, if you are still unable to access the sites, please give me an update.

  • In the App: selecting "Discover" at the bottom: In "eero Secure": I DID have "Advanced Security" and "Ad Blocking" both turned on. I turned both off, but the "eero Secure" box still says "Active" under the heading. I do not see any choice to select turning that off. I do not have any profiles under Content Filters and no blocked sites entered under advanced. A quick check of emails in my inbox fails to find any with links blocked at this moment. I'll have to watch to see if the problem recurs or not. The entire website (myadt.com) for accessing my security alarm company seems to be working find at this moment. The strange blocking experienced yesterday only occurred after browsing in the site and clicking external links for awhile. So provisionally, things seem to be operating fine at this moment. So maybe it was "Advanced Security" being turned on that created the problem? If there's a way to remove that "Active" which stilll shows under "eero Secure" in Discover, I don't see it!

    Thank you for the suggestions.

    • Hello Willyjp ,

      Okay, so it does sound like it was the Advanced Security feature. These blocks happen up at the DNS level which also explains some of the behavior you were experiencing. We will need to get a ticket created and escalate it up to have those sites no longer be blocked. You can give our support a call to set this up, or you can send us and email to support@eero.com and we can get that escalated up. The link below will have numbers that you can call us just in case you are located outside of the US & Canada region.


Like3 Follow
  • 10 days agoLast active
  • 12Replies
  • 357Views
  • 8 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support