Eero automatically blocking access to needed web sites and services

I have a repeating problem with my Eero network. There are, at times, websites or outside web services that I need to access, but Eero blocks them.

This is WITHOUT me running Eero secure or any other blocks on my end. Eero simply chooses not to allow access.  I'm sorry, but this is total B.S.

Eero should not have a say in any outside sites I access. None. Not unless I ask for the block.

And no, this is not to access porn or some other crud; today, the current problem is my new Chamberlain/LiftMaster MyQ account server (my garage door opener and garage smart camera). I can connect just fine with LTE data. I can also connect using my back up wifi router when I plug it in to the same cable modem.  But when I try to connect through my Eero wifi, I cannot reach the server.  It's blocked.  This is unacceptable.

51replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • The best feature of the eero is its design -- unobstrusive, small footprint, blends into the wall.  It looks pretty.

    The worst feature of the eero is that it is not a router! It is a router that routes only when it feels like it! I tried all of the solutions mentioned here. Yesterday, I finally just unplugged the satellite eero and that seemed to finally let me access all the websites I needed to. Tonight, suddenly it decides that it no longer wants me to access google.com -- yup, it was blocking me from google.com. After an hour, of switching back and forth between regular and guest mode and rechecking everything on the cumbersome eero app, it suddenly decided it was okay to let me access google again!

    I just purchased this 16 days ago. For the first week, it seemed fine.  Then, the nightmare began!  While it is now past the return date of Best Buy, I refuse to waste anymore time dealing with eero!  Tomorrow,  I will be going to back to Best Buy to purchase a standard, who-cares-if-it-looks-like-an-alien, router!!! 

    Eero Saarinen was a genius of form and function.  This amazon eero is sadly a poor example of it.

  • If you think it's bad as a user, try running a service that gets randomly blocked by Eero. We have paying customers who call us saying our app doesn't work, and there's no indication of why it's not working since the requests just time out. We spent two months trying to debug the issues until we finally noticed a pattern that people were reporting having an Eero. Our only recourse is to sound sketchy by telling our customers to turn off their security settings while requesting that Eero stop blocking us with no feedback or timeline for when that might be fixed. It's terrible.

  • Has anyone found a fix to this?  I do NOT have an eero pro, so it's not white or blacklisting.  I can get to the sites when I connect directly to my cable modem, but not through the eero.  Doesn't matter what browser or what device I use.  And it's intermittent, sometimes they work and sometimes they don't.  I can get to the sites if I use a VPN.  I've tried changing DNS servers, that didn't help.  Anyone?

      • sharpe15
      • sharpe15
      • 4 mths ago
      • Reported - view

      sharpe15 Correction, I do have eero pro but not secure. 

  • Having same problem but only affecting my Fire Cube running any Amazon Apps/Services.

    guest network solves issue but just can’t get primary network to work.


    I’ve disabled eero secure’

  • I am having the same problem trying to surf the web. When I use my windows PC laptop and connect to the Eero network, websites are blocked, even on the guest network. Using a VPN seems to fix the problem and I can surf easily. I can also surf using the Eero network on my iPhone with no VPN and have no problem. The blocking happens only with the Windows laptop and no VPN. 

  • I was also having issues with some websites timing out. I tried changing all options within Eero and the Firewall settings on my modem. The only thing that worked for me was deactivating IPv6. I guess I'll leave this off until no one uses IPv4.

  • Does anyone else have issues with the eero blocking BBC iPlayer, ITV Hub etc? if I plug into the router direct, it works. If I run it through the eero they all disappear. Means I can’t run my upstairs TV properly. My internet provider are baffled. I thought it was just the new TV I got at Christmas but it’s definitely the eero blocking it. Thanks.  

  • I’m experiencing the same issue with the Commerce Bank app (not the website) on my iPhone. As is my daughter on hers. I launch the app and it just hangs on the splash screen if I’m on Wi-Fi. But if I disconnect the Wi-Fi and get on the cellular network the app works as expected. 

    I do not now nor have I ever run eero Secure or eero Plus. So nothing eero related should be doing any sort of site blocking. It hasn’t always been like this as the problem only started a few months ago. 

    Originally I had Local DNS Caching enabled and was using my local ISP DNS. Couldn’t launch the app. So thinking it may be a corrupted DNS cache I tried …


    Disabling Local DNS Caching and keeping my local ISP DNS. Couldn’t launch the app. 

    Disabling Local DNS Caching and switching to OpenDNS. Couldn’t launch the app.

    Enabling Local DNS Caching and switching to OpenDNS. Couldn’t launch the app.


    After testing all combinations I think it’s safe to say that it doesn’t matter if Local DNS Caching is enabled or disabled. It doesn’t matter if I’m using my local ISP DNS or OpenDNS. But there is something about EERO that is blocking this app. 

    • OAW Make sure to call this into support so it can be investigated and fixed.

Like8 Follow
  • 7 days agoLast active
  • 51Replies
  • 4566Views
  • 39 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support