2

iOS 16 + Private Wi-Fi Address OFF = STILL Disconnecting

This is a continuation of the LONG thread found at:

https://community.eero.com/t/x2hfjm0/ios-ipados-14-5-1-private-address-off-frequent-disconnects

The short version: New iPhone 14 Pro with iOS 16. The Private Wi-Fi Address option has been turned OFF so that the iPhone can use a reserved IP address set in the Eero Pro 6 (latest firmware). Go to bed, all is working correctly; wake up, the iPhone is now DISCONNECTED from the Wi-Fi and has to be reconnected. This also still happens to a variety of similarly-configured, stationary iPads running iPadOS 15.7. The issue occurs randomly with devices that are all in a 1500 square foot condo.

WHY HAVEN'T YOU FIXED THIS, EERO? It's been happening for over a year now, almost two years. I'm sick of your laziness. TALK TO APPLE AND GET IT FIXED.

11 replies

null
    • Printerscape
    • 1 yr ago
    • Reported - view

    I am also having this issue with iPhone 14 Pro and iPhone 11, both running iOS 16, with an Eero Pro 6E. I’m at a point where I have ordered a different mesh system (Asus), and will be selling the Pro 6E.

    • clayj
    • 1 yr ago
    • Reported - view

    Happened again this morning. Went to bed, all was well; woke up and iPhone 14 Pro on iOS 16.0.2 was disconnected from WiFi.

    WHY AREN'T YOU FIXING THIS, EERO?

    • clayj
    • 1 yr ago
    • Reported - view

    Exact same issue this morning -- looks like it is a daily occurrence now. Would really like to hear back from Eero on this forum as to what is being done to resolve this issue -- surely I can't be the only person seeing this?

    • ebonovic
    • 1 yr ago
    • Reported - view

    Do you happen to have Wi-Fi Calling on?     I had a similar issue you are listing. 
    And I narrowed it down to that.   I have turned that off, and haven't had it happen since.  
     

      • clayj
      • 1 yr ago
      • Reported - view

      ebonovic No, Wi-Fi Calling is turned off here. Thanks for the suggestion.

      • ebonovic
      • 1 yr ago
      • Reported - view

      clayj Bummer... I was hopping it was that simple tweak.   Best of luck

    • clayj
    • 11 mths ago
    • Reported - view

    I think -- after all this time -- that I may have figured out how to stop this problem. I think it has something to do with the iCloud Keychain. Since most of my Apple devices stay at home all of the time -- iPads set up to be used as TVs -- they don't get used on different WiFi networks or for non-TV stuff, so I turned OFF the iCloud Keychain (Settings > iCloud account > iCloud > Keychain = OFF). The only device where this is still turned on is my iPhone 14 Pro.

    Since I made this change last week, I have not woken up to find my iPhone disconnected from WiFi, and there have been no other disconnections of other devices.

    It's too early to say that this has definitely solved the issue, but anyone else seeing similar problems should give this a try and see if it helps.

    As for the folks at Eero: You need to set up a test for this and see if you can reproduce the problem. Here are the particulars:

    • Set up WiFi network with long password (26 characters or more) and SSID with long name (14 characters or more) -- two Eero Pro 6 routers
    • Multiple Apple devices (iPhone, iPad -- I have 6 devices) with Keychain = ON
    • WiFi on each device with Private Wi-Fi Address = OFF
    • All devices have reserved IP address in Eero

    I should not have to turn Keychain OFF -- your work in troubleshooting this issue is NOT done even if this does eliminate the issue.

      • clayj
      • 11 mths ago
      • Reported - view

      clayj PS: At some point later on, I am going to turn the iCloud Keychain back ON on all of my devices. If the issue returns, that will pretty much confirm that it has something to do with the issue occurring in the first place.

    • jduffy
    • 11 mths ago
    • Reported - view

    This is not happening to any of my iPhones or iPads. I have eero Pro6E with 6+ and an extender. All are connected all the time.

    • Tadamson03
    • 8 mths ago
    • Reported - view

    I have tried every step listed above for my iPhone 14. None of them have worked. The only thing that works for me is to connect my phone to the Guest Network. However, that causes other issues with devices that are on the main network. Such as my Shark robot vac. I have to use my work iPhone 11 to set up the vacuum. It has to be done on the same network as the phone and the Shark won’t connect to the guest network. This is truly ridiculous. I’ve been in IT for 25+ years and if we’d done something like this, we wouldn’t have jobs if we’d gone this long without fixing it. 

    • computersteve
    • 2 mths ago
    • Reported - view

    I am also noticing this. Have an iPad and an iPhone 13 Pro Max and I notice if I come back to the device I have to toggle Wi-Fi to have connection. 

Content aside

  • 2 Likes
  • 1 mth agoLast active
  • 11Replies
  • 841Views
  • 7 Following