16

Eero iPhone Connectivity Issues

Hello, 

I have not yet purchased an Eero system yet; I am in the research stages deciding between Google Wifi, Orbi, Luma, Unify mesh, Amplifi, and Velop. 

I have seen many reviews and threads in forums in regards to Apple IOS devices failing to 'roam' between APs, or randomly dropping connections, or staying connected to the furthest AP rather than switching to the closest one. 

A couple years back I set up a $1000 Cisco Meraki AP for my home network. After countless issue with our iPhones and iPads not being able to connect, not seeing the SSIDs, and randomly dropping connections I switched back to my $100 Asus router, which has superior performance (for Apple devices) to the enterprise grade AP. I am looking for a modern WiFi solution to power all of our devices, including many Apple devices.

In any case, it seams Apple devices always have issues with WiFi, I am looking for a solid solution to this, I thought Eero was the winner until I started reading it also has the same issues with Apple. I have read that people have open cases with Eero regarding this, but it's still a known issue. 

At my office we have a ton of Enterprise Cisco APs, in which iPhones can seamlessly roam between without loosing a video call. Obviously at the price point of Eero we cannot expect enterprise grade features, but I am looking for some input if others are having this issue with their iPhones on Eero, and what support / development teams are doing to solve this issue? 

One other item of interest is outdoor WiFi coverage. With other mesh WiFi options on the market; outdoor weather resistant APs are offered. Does Eero have any intentions or future plans to offer the addition of outdoor APs to the mesh network? 

Thanks in advance. 

252 replies

    • LightEero
    • 6 yrs ago
    • Reported - view

    Since iOS 10.3.3 and Eero Gen 1 Firmware 3.2.1-2, I am experiencing numerous WiFi dropouts and general WiFi stalls. According to Eero support, this is a known issue.  I have had the Eero Gen 1 woth 3 access points for almost a year and it has provided much better coverage and speed throughout my home than my previous Apple AirPort Extreme 5th Gen but it has also had some quirks with iOS devices that is causing me to think about trying another solution. Such quirks have included Apple Continuity and Handoff features (including Apple Watch unlock of Mac) between iOS devices and my Macs not working (has to do with devices being connected to different eero Access Points, which a user generally has no easy control over) and now this issue, which is likely due to the Broadcom update included in iOS 10.3.3 and how it interacts with the Eeros. It's been enough of a hassle to make me consider something else. 

      • travisbell
      • 6 yrs ago
      • Reported - view

      LightEero I would just like to point out that I have iOS 10.3.2 devices doing this so I don't think it's anything unique to 10.3.3.

      • LightEero
      • 6 yrs ago
      • Reported - view

      travisbell interesting. Be sure to report this via email to support@eero.com as they are reporting that the wifi hangs are due to the Broadcom WiFi firmware update included in 10.3.3. The issues with Continuity and Handoff have always been present for me (and I know why because it is related to time of flight calculations that iOS and Mac devices do that are impacted by devices being on two different access points) but the WiFi hangs are recent.

    • mattv123
    • 6 yrs ago
    • Reported - view

    To be fair, I bet this problem is happening for any mesh Wi-Fi network provider that is trying to take advantage of iOS's 802.11r FT capabilities.  Everything I am seeing points to a bad code update in iOS 10.3.3 that is breaking the broadcom firmware.

    I have filed a ticket with Apple: rdar://34074507 and I'll report back if anything helpful comes through.

      • lwdupont
      • 6 yrs ago
      • Reported - view

      mattv123 Do you mind putting the details in openradar.me so I can dupe it? No worries if not. Thanks.

    • Gravity Brings Me Down...
    • stevebaker
    • 6 yrs ago
    • Reported - view

    Hi again - earlier this week I updated my iPhone and iPad to the latest iOS 11 public beta, and thus far have not encountered any noticeable issues with network connectivity or performance. I'll continue to try a variety of things to see if I can replicate the issues (for example, setting the devices aside for a while, then seeing what state they're in, and engaging in a bit of casual roaming around the house and yard, etc.).

      • mattv123
      • 6 yrs ago
      • Reported - view

      stevebaker So I’ve noticed the opposite. With iOS 11 beta 7 the situation is much worse. I will try a network reset and see if that helps with the situation. 

    • Gravity Brings Me Down...
    • stevebaker
    • 6 yrs ago
    • Reported - view

    Hi again! Well the Hawthorn Effect has kicked in for sure — this morning I had my first issue with the eeros Gen2 using my iPhone on the latest iOS 11 public beta. Not getting any network traffic so I popped it into airplane mode for about 30 seconds, then back into action and it connected again fine. I had left the phone idle for a few minutes (happens a lot) but this time it wasn’t able to see anything. While I don’t have any good diagnostic tools, I’ll definitely keep an eye on things and keep you posted.

      • mattv123
      • 6 yrs ago
      • Reported - view

      stevebaker I've found just an instant toggle of WiFi is your fastest way to fix the problem (no need to wait 30 seconds or disable cellular/bluetooth). The app I use to run pings from my phone to eero router is called Net Analyzer ( https://techet.net/netanalyzer ) and I've found it to be really useful in many occasions.

      • Gravity Brings Me Down...
      • stevebaker
      • 6 yrs ago
      • Reported - view

      mattv123 Awesome, thanks! I use the iOS apps Fing, IP Scanner, iNet, and SubnetInsight to peek around and fun stuff like that, but ever since I signed up for the eeros plus network security thing, all of those apps have effectively been killed (I’ve been meaning to ask about that, it’s a real bummer). I didn’t have any problems before addinthe plus, and didn’t have problems after either, until the one time this morning. I’ll keep poking around and I’ll also check out the Net Analyzer app too! Thanks

    • jamiemcd
    • 6 yrs ago
    • Reported - view

    Been seeing a problem with the iOS devices on my network. Enough complaining from family members that I finally found this thread  

    It has happened on devices running iOS 11 Beta, iOS 10.3.3, and iOS 9.3.5

     

    I have the 1st generation 3 Eero pack. Running v3.2.1-2. 

    Either the yellow “No Internet Connection” or the iOS device drops WiFi completely 

    Most of the time a quick tap of turning WiFi off and back on will resolve the issue  

    Other times I have to power cycle the Eero.

    I hope this is not an acceptable solution to the Eero team. I also “upgraded” from an AirPort Extreme  

    • thegameguru
    • 6 yrs ago
    • Reported - view

    Want to add to the pile.. I have this exact same issue with both my iPhone 7 Plus and my wifes iPhone 7.  Makes using the eero's very frustrating as it also affects wifi calling.

    • mattv123
    • 6 yrs ago
    • Reported - view

    It’s too early to say for sure, but I have not had a single drop out since upgrading to iOS 11 beta 8... I’m sure that by writing this it will trigger the problem again, but that is the way it goes. I will be out for a few days so I won’t be able to test, but will when I get back.

    Fingers crossed Apple worked some magic!

    • Gravity Brings Me Down...
    • stevebaker
    • 6 yrs ago
    • Reported - view

    Hi everyone - I'm now also on the latest iOS 11 public beta, and just updated my eeros firmware to the newly released version. Fingers crossed for smooth operations (I only had a few iPhone outages, which were easily resolved by turning off and back on the wifi on the device - but still that shouldn't be necessary). The release notes didn't specify this issue in particular; here's hoping this resolves things!

      • travisbell
      • 6 yrs ago
      • Reported - view

      stevebaker Ya, hard to say if the new firmware addresses any of this. The release notes don't necessarily indicate anything for iOS users but who knows. I just updated too, time will tell!

      • Armydoc214
      • 6 yrs ago
      • Reported - view

      stevebaker 

      I have all the same issues. The problem seems to be with the FS between the AP’s. I’m running iOS 11 beta 8 but is a problem on multiple roaming devices.  As I sit here typing this I am sitting in my living room between the main AP and a beacon in the kitchen.  The first thing I do in the morning is get my coffee and usually the phone is connected to the kitchen AP. When I go to the living room and sit the signal seems to try and make the transition but the Internet connection is just not there. The WiFi calling indicator drops off and I’ll need to turn WiFi off and on to get it to connect again. I first started noticing this when I tried to make a call over WiFi. It does not transition between AP’s well. 

    • rjjds
    • 6 yrs ago
    • Reported - view

    Same issue here, running iOS 10.3, multiple drop outs all day long.

    Very disappointed with Eero's non response, never acknowledging the severity of the problem by stating that they have numerous iOS devices running with no problems.

    • bdplatt
    • 6 yrs ago
    • Reported - view

    interesting note from support this morning on this topic. Seems pretty impractical, since most of the devices on my network roam around. I'm also very curious why setting an address reservation would help an issue which appears to be caused by the device staying connected to an Eero that is now a long distance away, rather than a device that is much closer.......

    >>>>>>>>>>>>>>

    Aug 31, 8:22 AM PDT 

    Hi Bryan, 

    Thank you so much for the update!

    I understand that this is occurring throughout the network and that typically the affected device remains connected to the network through the original eero. 

    I'd recommend setting an IP reservation for each of the affected devices in your eero app. You can do so using the steps below: 

    - Open your eero app

    - Click on the menu icon (three lines) in the top left

    - Click 'Network Settings'

    - Click 'Advanced Settings' 

    - Click 'Reservations & Port Forwarding' 

    - Click 'Add a reservation'

    - Tap on the device in question

    - Click 'Save' in the top right corner 

    - Repeat for any other devices that are having similar issues 

    >>>>>>>>>>>

      • Dinnid
      • 6 yrs ago
      • Reported - view

      bdplatt I tried that and it didn’t work for me. 

    • travisbell
    • 6 yrs ago
    • Reported - view

    A developer at eero left some comments on this Reddit post about the new firmware: https://www.reddit.com/r/eero/comments/6x49u1/eeroosv330350_out/

    • Dinnid
    • 6 yrs ago
    • Reported - view

    I get the WiFi dropping all the time with iOS and feel like all the reviews must be lies.  If this “mesh network” is the “future” I don’t want it.  This has been my only experience with eero and it’s been junk from day one.  I have a feeling it’s going back to Best Buy tomorrow.  I tried static IPs, moving the beacons, and iOS 10.3.3 and 11.

      • Armydoc214
      • 6 yrs ago
      • Reported - view

      Dinnid 

      my google WiFi worked fine but I got sold on the Tri-band router and faster network. Not the case. EERO has a lot of issues still

    • FlipABit
    • 6 yrs ago
    • Reported - view

    Any updates on this? It seems like the engineers have been working on a solution for almost a month now. The new firmware and iOS beta haven't seemed to have any effect. I bought my eero's before reading about these iOS issues but decided to try my luck and set them up. I'm about ready to return them at this point if they can't do something as basic as stay connected to Wifi on one of the most popular platforms around today.

    • cleverdevil
    • 6 yrs ago
    • Reported - view

    I’ve also been experiencing frequent dropouts and problems in my iOS devices for the last month, and it’s made my WiFi network pretty much unusable.

    I have been a huge fan of eero and have recommended and installed eero for family members and friends.

    I am pretty disappointed in the response I’ve seen so far from eero on this issue. Apple’s iOS is a dominant platform, and eero advertises on many Apple-oriented podcasts and websites, and has a very Apple-like experience. Having a major issue with iOS that has gone unresolved for 6+ weeks is not a good look for eero.

    I am losing confidence.

    • Pusdad
    • 6 yrs ago
    • Reported - view

    I to am having same issues as noticed in this thread. Have 4 eeros hardwired to a high end dell switch. Been strugling with loss of connectivity on iOS and MacOS devices for months.  Have around 60 devices on network. Yesterday I put eeros in bridge mode and used Xfinity router for DCHP.  Seemed like everything was running much better all day with blazing speeds above 200MB, but alas today the family called me at work to tell me "internet isn't working" again. Did reboots of router and eeros and its still hit or miss.  Every few minutes need to turn wifi off on iPhones and on again to get connectivity back.

    Help. I convinced many family members to buy eeros and I hate to have to move to another platform.

Content aside

  • 16 Likes
  • 5 yrs agoLast active
  • 252Replies
  • 8724Views
  • 59 Following