Eero iPhone Connectivity Issues

Hello, 

I have not yet purchased an Eero system yet; I am in the research stages deciding between Google Wifi, Orbi, Luma, Unify mesh, Amplifi, and Velop. 

I have seen many reviews and threads in forums in regards to Apple IOS devices failing to 'roam' between APs, or randomly dropping connections, or staying connected to the furthest AP rather than switching to the closest one. 

A couple years back I set up a $1000 Cisco Meraki AP for my home network. After countless issue with our iPhones and iPads not being able to connect, not seeing the SSIDs, and randomly dropping connections I switched back to my $100 Asus router, which has superior performance (for Apple devices) to the enterprise grade AP. I am looking for a modern WiFi solution to power all of our devices, including many Apple devices.

In any case, it seams Apple devices always have issues with WiFi, I am looking for a solid solution to this, I thought Eero was the winner until I started reading it also has the same issues with Apple. I have read that people have open cases with Eero regarding this, but it's still a known issue. 

At my office we have a ton of Enterprise Cisco APs, in which iPhones can seamlessly roam between without loosing a video call. Obviously at the price point of Eero we cannot expect enterprise grade features, but I am looking for some input if others are having this issue with their iPhones on Eero, and what support / development teams are doing to solve this issue? 

One other item of interest is outdoor WiFi coverage. With other mesh WiFi options on the market; outdoor weather resistant APs are offered. Does Eero have any intentions or future plans to offer the addition of outdoor APs to the mesh network? 

Thanks in advance. 

234replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi everyone —

    Thanks for your patience and support as our team has continued work on this matter throughout the weekend.

    Starting tonight, we will be releasing an update to all networks that will provide improvements to roaming. This will come in the form of a cloud-based change to the backend of eero networks (no new firmware), and there is no action needed on your end. This will be a rolling update to networks. We appreciate your patience and understanding.

    Your feedback is invaluable. We ask that you continue to use your devices as normal. If you continue to see the same issues, please email support@eero.com. This will allow our team to efficiently track and report any feedback back to engineering.

    Thanks again.

    Reply Like 1
      • Sjustis
      • 3 wk ago
      • 1
      • Reported - view

      Jeff C.  I will test it out tomorrow thanks!

      Reply Like 1
      • rtlee
      • 3 wk ago
      • Reported - view

      Jeff C. Thanks Jeff. Does it matter if we have FT enabled or not? Mine is currently disabled. Should it be reenabled for that testing? Also is here a way to verify when the network hanger has gone into effect for our accounts?

      Reply Like
      • arfung
      • 3 wk ago
      • Reported - view

      Jeff C. Thanks, Jeff. You guys kindly pushed the test firmware to me and I don't want to miss out on the fix. Will it push to those of us with the test (3.4.0 firmware?) Thanks!

      Reply Like
    • arfung it will go to all eero networks. Thanks!

      Reply Like
    • rtlee nothing to check/change — just give it a go tomorrow once the update goes out later this evening. Thanks!

      Reply Like
    • Jeff C. Thanks for the update and to the eero engineering team for your work on this issue. Judging from the eero Reddit, I'm not the only one confused about how a cloud-based fix can solve the roaming issue. Could you please elaborate on the fix, and even what the exact issue was determined to be?

      Reply Like
      • rtlee
      • 3 wk ago
      • Reported - view

      Jeff C. Should I call in to have them turn FT back on tomorrow or leave it disabled for this re cloud testing?

      Reply Like
    • Jeff C. Does the back end update tonight mean you've fixed FT (based on the talk here it seems like that was the issue) or are you disabling it for everyone? I'm just wondering a bit more about this update.

      Thanks. 

      Reply Like
    • Jeff C. It is still a problem!

      Reply Like 1
    • jweiss2005 Unfortunately, I do as well.

      Reply Like
    • Sjustis Jeff C.  ~ things are better for me, have not had to toggle the WiFi button yet on the iPhone since the changes

      Reply Like
  • I manage around 75 Meraki APs and have been doing so for the last few years so I'm very familiar with them. Most likely the problems you had stemmed from band-steering being enabled. Not likely the fault of the Meraki hardware; your settings probably just weren't properly configured to work best with Apple hardware.

    I've been running 3 eeros at home since the day they came out. Apple devices did have some problems with connecting to the eeros for the first few firmware versions (it wasn't a super big deal), but the last few months have been rock solid for me (I'm basically Apple only at home; iPhones, iPads, macOS computers). 

    Reply Like 1
  • Thanks Cmoo. I did work for an MSP prior to switching over to enterprise IT, and also managed hundreds of Meraki APs. They are great for the most part; but we always had issues with IOS, even with band steering disabled. 

    Thanks for the info on the Eeros. I have it narrowed down to Eero, Orbi, and Velop. I like the two others due to their dedicated backhaul. How many devices are you running on your 3 Eero setup? 

    Reply Like
  • Hi  Commdude

    Thanks for your questions and for your interest in eero! Also, just wanted to say thanks to  cMoo92 for stepping in with some great feedback!

    Just to clarify, there are no known issues with Apple devices on eero networks. For what it's worth, most of us here use Macbooks and all run eeros at home with no issues.

    While eero doesn't have a dedicated backhaul, what eero does have is our own proprietary mesh called TrueMesh. Our mesh is built to quickly optimize your traffic, ensuring you always are seeing the highest speeds at each of your eeros throughout your home. Also, if your house is built for it, eero supports mixed topologies of wired and wireless so you have the option to hardwire some of your eeros while others can continue to mesh with your network wirelessly.

    As for the number of devices, each eero can support up to 128 devices.

    I hope this helps! If you have any other questions, please don't hesitate to reach out!

    Reply Like
  • Commdude I average 15-20 devices connected at any given time. I never have issues with streaming and I stream a lot from my Plex media server to a couple Apple TVs, and iOS devices. I have a 200Mb internet connection at home and never have a problem maxing it out.

    I know the other competing products have dedicated backhaul radios, but that doesn't seem to be an issue with eeros (and eero was intentional about that decision based on their design/testing).

    Depending on how much you (or your wife 😉) care about aesthetics, the eero is awesome. They are small (unlike the competition) and look very nice wherever they are placed. I also like how the status LED can be turned off on a per eero basis. I don't know if the competitors can do that, but it's perfect for the eero that's in our master bedroom. Before they released that software option, I had to cover the light on the eero at night.

    Reply Like
  • Jeff C. I'm surprised to hear you say there are no known issues with Apple devices connecting with Eero. I was just on the phone with your support people (who are very nice by the way) yesterday for the 3rd or 4th time since I purchased my Eero 3 pack last March due to connectivity issues with my Apple devices. Today, I've gone through all the trouble shooting steps and still can't connect my parents iPhone 6's to my network. So frustrating and embarrassing that I can't get my parents on my expensive wifi system. The support person did say that this was a known issue with Apple products and said there was no timeline for a fix. Unfortunately, I cannot return my Eeros because the 30 day return window is up. Do you think this is a hardware issue then if no one else is experiencing Apple connectivity issues with the firmware? I have to manually enter the IP address, etc to connect most of my iOS devices, as they don't connect automatically. 

    By the way, I have experienced this issue since day one, where only 5 or 7 Apple devices would connnect without having to manually enter IP info.  

    I want to keep the Eero because it does provide a nice signal (to the devices that will connect) and I love the app but I'm really frustrated at this point. Would love your thoughts. 

    Reply Like
  • Koolmanchu --

    Thanks for reaching out. I'm sorry to hear the issues you are encountering, and appreciate your patience as you work with our support team.

    As mentioned, there are not any known issues with an iPhone connecting to an eero network. There is no technically limiting reason they shouldn't, so we should take all the necessary steps to ensure what may be causing the issue. Our support team is happy to continue working with you, however, we will need to go through troubleshooting so that if the issue is determined to be on our side, we can get you an exchange as your eeros have a one-year warranty.

    In the meantime, I'd also like to suggest that you try some of these tips from Apple, specifically having you reset the network settings on the iPhone. Hopefully your parents don't switch between too many networks, so ideally, they'll only have to sign into your's and their network again. You can find these tips here:

    https://support.apple.com/en-us/HT204051

    I hope this helps. Thanks again for your patience, and we look forward to getting this resolved.

    Reply Like
  • Jeff C. thanks for the quick response.  Typically, I'll go through all these steps and the issue is not resolved. From there, the Eero support person has me enter the IP address, etc manually as the Eero can't do it automatically on some Apple devices. Is this  something Eero can address with a firmware fix in the future? 

    Reply Like
      • DavidCC
      • 2 mths ago
      • Reported - view

      Koolmanchu 

      Hi, did you ever get your iOS devices working properly on your network? I want to eventually replace my two Airport Extremes with the eero mesh system.

      Reply Like
      • Jason
      • 2 mths ago
      • Reported - view

      DavidCC Speaking for myself my iPhone works pretty well on the network.  However, I had inconsistency with the 5 GHz range.  Sometimes it won't connect to the nearest AP.  Sometimes when it is on the 5 GHz band it will get really poor speeds.  There definitely still seems to be an issue with it.  I have an extensive case open with support.  Last I heard they've escalated to engineering.  It's not a deal breaker, but an annoyance that I can't get the speeds sometimes that I should.

      Reply Like
      • DavidCC
      • 2 mths ago
      • Reported - view

      Jason Thanks for replying. I hope that it is fixed as there are four iPhone users in my home.

      Reply Like
  • Koolmanchu --

    I'm glad to hear you've gone through those, however, I'm sorry to hear they weren't able to resolve this matter.

    I'm going to touch base with our support team once they get in to get a better understanding on what they're seeing on their end.

    The solution they provided was to ensure your devices connected in the meantime. However, at the end of the day, I can assure you iPhones and other Apple devices are compatible with eero. Thanks again for your patience. I hope we can find a timely resolution.

    Reply Like
  • Jeff C. well in my experience, most Apple devices are compatible (automatically connect) with Eero, while others (regardless of model type) have to be manually configured (IP address, etc). I hope you guys can prepare a fix soon. I really want this to work. 

    Reply Like
  • Koolmanchu I know I'm late to the discussion, but if their devices are connecting but not getting internet try reserving the IP. Eero support did it for me a while back for a stubborn connection, and I've since had to do it for all devices that connect regularly (not just iPhones). It's actually why I was on the forums, trying to figure out a real fix. 

    Reply Like
  • I've had the same problem with all of my Apple devices since I got the Eero system. It delivered exactly the opposite of what it promised and has made my WiFi an incredibly frustrating experience. My iPhone and MacBook connect to WiFi, but then cut out a random amount of time later (10 mins - 2 hours). I've tried everything and even brought in Network Consultants but I think my only option might be to ditch these things. My internet is great for 30 minutes but I'm getting sick of toggling my WiFi on/off on my computer all the time. It really kills my workflow.

    Reply Like
    • frustratedinseattle 

      1. Have you talked to support? 
      2. Have you tried adding an IP reservation for your devices that are experiencing issues? This worked for me several months ago when I was having issues.
      Reply Like
  • Hello again - really late to this thread (just purchased and installed eeros two days ago). So far, our two iPhones and our various iGadgets are all connecting and performing very well.

    I gather there was a recent firmware update (released a few weeks ago?) so I can't comment on how the system performed when the thread was started; maybe that helped fix things?

    Reply Like
  • I am also experiencing iOS issues with multiple devices with my brand new Eero Gen 2 (Pro-Wifi system: 2 eero's wired, 1 wireless).  Things seemed fine with firmware 3.1, but since upgrading to 3.2, all of my devices lose connectivity when wandering around my house, and the only way to get it back is to disable then re-enable wifi on the device.  I bet it has something to do with this in the 3.2 firmware:

    • Improvements to 802.11r FT (fast transition) for Apple iOS devices

    There are quite a few people reporting similar issues at https://www.reddit.com/r/eero/

    I really want to love Eero, but this issue has been an embarrassment having to explain to my family why this fancy new $500 WiFi system is worse than our old one.

    Reply Like 1
    • afx114 +1 same exact issue. Only appears to be impacting iOS devices. 

      Reply Like 2
  • I'm having issues where I'm not consistently getting correct speeds on the 5 Ghz band.  The issue is currently with support/engineering.

    Reply Like
  • Hi - what can I do to help replicate and test this? New install of two eeros and four beacons (last Saturday, running the latest firmware) -- using four iOS devices (two phones, two iPads). It's only been a few days but we haven't encountered any drops or issues yet as we wander around the house, basement, and back yard. Thanks!

    Reply Like
      • afx114
      • 2 mths ago
      • 1
      • Reported - view

      stevebaker I'm not sure.  All I can do is provide my setup and say that it happens when moving around the house.

      I have the Gen 2 Pro WiFi system (3 Eeros), connected like so:

      Arris SB6183 => (Wired) Eero => (Wired) TP-Link TL-SG108E Gigabit Switch => (Wired) Eero => (Wireless) Eero

      • All wired connections are CAT6.
      • The Modem/Eero/Switch are in the basement.
      • The 2nd Eero is upstairs in the bedroom, wired to the switch in the basement.  
      • The 3rd Eero is in the detached garage in the back yard (wireless). It shows full bars but I'm not sure if it's connected to the basement or bedroom Eero.  I'm going to guess basement since it is closer. (Would be nice if the app showed which Eeros were connected to which!)

      Software versions:

      • All Eeros are on the latest firmware (v3.2.1-2)
      • All iOS devices are on the latest iOS (10.3.3)

      I'm not sure what other info I can provide.  Please let me know if there's anything else that would be helpful.

      Note that I have started an experiment.  I had originally used the same SSID as my old router (ASUS AC1900), but new password.  I read that using the same SSID could be problematic, so I've just changed it today.  I'll run on this a few days and let you know how it goes.

      Reply Like 1
    • stevebaker I have the 2nd gen 3-tpack (one pro, 2 beacons).  I think the issue may be related to the APs being close enough together, but not quite far enough to warrant a hand off.  I've moved them around physically to see if that would make a difference. 

      Otherwise, replication steps is to put your device on Wi-Fi and after some period of time (likely between the device sleeping and becoming active again a few times) observe that stuff is just broken.

      Next time it happens, I'll try more diagnostic debugging like pings, DNS queries, etc. and will report.

      Reply Like 2
      • afx114
      • 2 mths ago
      • 2
      • Reported - view

      An update on my little experiment of changing the SSID.  I thought it had worked, because I had no issues with WiFi last night.  But this morning when I picked up my phone -- no WiFi!  Safari sat there spinning, then all of a sudden WiFi disconnected completely, leaving me on 4G.  I had never seen that before.  In the past I would stay on WiFi, but it just had no connectivity.  This time was different, it was as if my Eero's were completely gone.  Toggling my WiFi on/off fixed it as usual.

      Reply Like 2
  • Hello again! Cool, thanks to you all for the additional details. I have a similar setup, from my Netgear CM1000 cable modem (owned, not leased) to the first gen2 eero in the basement, to a Linksys 8-port gigabit switch, through CAT5 cable to a second gen2 eero on the main floor. The other side of the basement has an eero beacon, plus one in the main floor Florida room, and two more beacons on the far sides of the upstairs (total of two gen2 eeros and four gen2 beacons, a bit overkill perhaps...).

    It's just been since midday Saturday so we will definitely keep tabs on things, for sure. But our iPhones and iPads thus far have not dropped any connections at all, and from what I can tell with the eeros app, they're making good decisions on where to connect (we're on the latest iOS 10, I'm holding off on the iOS 11 public beta although it's so tempting!). I'll continue to check regularly over the next few days, and my wife is particularly sensitive to outages as she streams a lot of podcasts and things (partly why I left the Velop platform for this).

    Reply Like
    • stevebaker I'll be interested in your experience.  I just got the eero yesterday after 8 months with Google WiFi and a couple weeks with Velop.  I have bridge mode on, 3 floors, lots of devices. Several iOS devices. Fiber internet, so it has to be bridge mode, PPPoE connection. 

      Wi-Fi calls from T-Mobile drop when switching APs, that is all I have seen so far.  Otherwise, this seems to be faster than the Velop and a lot less latency.  

      These have provided the best wireless speeds I've seen yet.  I got a 1st Gen system cheap due to clearing them out, I assume.

      Liking it so far.

      Reply Like
  • OK, just replicated this. Here are some stats:

    • Device: iPhone 7 iOS 11 beta 5
    • Ping from device:  Cannot ping gateway (eero) nor outside service (8.8.8.8)
    • Websites not loading in Safari (simple test HTTP (not HTTPS) website)
    • Cannot access Sonos via app on local network (this is how I detected something was up)
    • Physical: Had been using the device in the same room for several hours.  Was streaming a video to Apple TV via AirPlay then put device down.  After picking it up again to turn on music, issue was experienced.
    • Coverage is really good in this area.  Using WiFi Explorer on my mac, I have 5GHz SNR of ~45DB from two APs.  Those same APs have a SNR of ~60+DB for 2.4 GHz. 

    Having put down my phone after collecting the above info, I picked up the phone again and everything was fine again...  Same room, same position, no manual tweaking of network settings.  Downtime was about 2 - 3 minutes.  I think I would have run out of patience in this time had I not been testing and would have tried to fix it manually (as I have in the past).

    During the outage, everything was perfectly fine on my macOS device. I didn't have a second iOS device handy to check it. 

    I would have normally chalked this up to iOS 11 beta shenanigans, but given others are seeing this in iOS 10 (including other iOS 10 devices in my house) I think it is not correlative.

    Will post more as I learn more details.  Keen to hear if others have the same experience with it starting to work again after 120-300 seconds of waiting.

    Reply Like 3
    • mattv123 OK, happened again.  This time something very interesting happened:

      I was running a ping to the local Eero gateway address (192.168.150.1) on my iPhone and all of the pings were not responding.  I popped open my laptop and in that moment all of the pings responded omniscience's my iPhone!  The response times were 55000ms+ (that is how long I was running pings), but they all came back.  This means that none of the ICMP pings were lost, but they were stuck.

      Now, the question is: did opening my laptop and connecting to the network unblock whatever was going on with the access point?  Note that in my message yesterday, the same thing happened when I opened up my laptop to take notes... Could be coincidence, but I am going to test this case more directly the next time it happens.

      I'll also try using rvi0 on my iPhone to my Mac (with WiFi off) to see if I can track the behavior on the interface.

      Reply Like 4
    • mattv123 damn you autocorrect! *Pings came in all at once

      Reply Like
  • Just wanted to add my similar experience to the thread.  

     

    Currently have one 2nd gen eero and 2 Beacons in a 3800sq ft home.   eero gateway is on the 1st floor in the corner of the house, then one Beacon in the basement (central), the other in the master bedroom on the 2nd floor (other side of house).  House is rectangle in shape and the gateway has to be placed in one of the corners, with the 2 beacons creating a "V" to the basement and the second floor. 

    I have experienced the stuck issue as well, as least on my iPhone 7 and iPad Pro (10.5).   Running iOS 11 beta 6.


    One thing I did try to do was move the master bedroom Beacon further away from the gateway.  That did seem to help a little with the issue, but it still happens every once in a while. 

    Issue can be quickly fixed with a toggle of the WiFi, but I'd rather not keep doing that.   Just hoping a fix is coming soon.   Appreciate people's explanations here.   

    Reply Like 2
      • stevebaker
      • Gravity Brings Me Down...
      • 2 mths ago
      • Reported - view

      Sorry you're having issues too! My network is not in bridged mode, and we're not running the iOS 11 beta, and we have six eero or beacon units in a ~1600 sq.ft. house. I wonder which of those factors is driving the issue? We are still doing fine, with no noticeable issues or problems on our iDevices.

      Reply Like
    • stevebaker I think spacing out the Beacons has helped.   eero app still indicates a good signal between the Beacons and the gateway.

      Despite the specific issue with iOS devcies, eero is the most responsive and reliable network that we've had in the house.  30+ devices connected at any time.

      Reply Like 1
  • Same issues here. 2nd gen Eero, one base and two beacons. iPhone 7 on IOS 11 beta 5 and iPhone 6 on latest IOS 10. Loosing WiFi connections or getting very low speeds when moving through our home.

    Reply Like 1
  • Ok, new update and very relevant: the issue has been happening on my iPhone at least once or twice every day, but never on my macOS machine(s).  It doesn't seem to be related to roaming, but my APs are close enough that my phone may be opportunistically transitioning.

    Today I managed to capture the issue and connect my iPhone to my Mac and start a packet capture on the rvi0 interface (the virtual interface of the iPhone) via WireShark while the problem was ongoing.

    I have been doing this type of analysis for years, and I have never before seen this behavior: there was no activity on the interface!  Even though new requests were seemingly being made on the device (DNS, Pings, HTTP requests, etc.) nothing* was appearing on the wire! (* There were some unidentifiable payloads that were being egressed, possibly for 802.11r protocol communications, but they were not readable by WireShark. Will probably look into this more later.) 

    This seems to indicate that something about the Eero's handling of the WiFi connection is bricking the network interface.  Of course, this could very well be (and probably is) an iOS bug triggered by hero's implementation (a 3rd party AP should not be able to brick an OS's network stack) since it only appears to impact iOS devices.

    If I had to venture a guess, I would bet this has to do with the Eero's 3.2 firmware 802.11r FT improvements which were specifically targeting iOS devices.

    I snapped a sysdiagnose on my phone while this was happening and I'll spend some time analyzing some of the networking stack debug log output.  I'll likely file a bug with Apple as well and will pass along to rdar for Eero engineers to follow up on.

    As expected, disabling and re-enabling WiFi resulted in an immediate flood of expected traffic in the Wireshark capture and everything was working fine again.

    Jeff C.  FYI!! ^^^

    Reply Like 4
    • mattv123 Analyzing sysdiagnose logs:

      Around the time of failure, there are a bunch of console errors indicating:

      165661.719785 wlan0.A[28576] startEventScan@444:Error sending event scan request: BCOM Busy

      Clearly the "wlan0" is referring to the wireless LAN.  Assuming BCOM = Broadcom WiFi chipset

      At times preceding these errors, it looks like there is a trap triggered in the Broadcom chip and then a watchdog comes around and reloads the firmware for it.

      default    2017-08-19 12:16:30.161222 -0700    kernel    163642.801070 wlan0.A[28436] parseEventLogRecords@11349:Failed to parse Event Log Record tag 60 at i 152, payloadLen 20    0
      default    2017-08-19 12:16:31.261224 -0700    kernel    163643.901083 wlan0.A[28437] interruptPCIeMSI_v6@9454:FAILED HEALTH CHECK (0x3000000b)    0
      default    2017-08-19 12:16:31.261505 -0700    kernel    163643.901471 wlan0.A[28438] handleFWTrap@9327:FW TRAP 132 (1c3b78): epc 1862d5, pc 1862d5, lr 1a162d, sp 1c3bd0, cpsr 60000193, spsr 60000033    0
      default    2017-08-19 12:16:31.261682 -0700    kernel    163643.901652 wlan0.A[28439] handleFWTrap@9329:r0 1, r1 1a162d, r2 1c18a4, r3 0, r4 1862d5, r5 1, r6 1862d5    0
      default    2017-08-19 12:16:31.261847 -0700    kernel    163643.901819 wlan0.A[28440] handleFWTrap@9331:r7 1, r8 18001000, r9 1c3c34, r10 0, r11 0, r12 0    0
      default    2017-08-19 12:16:31.269815 -0700    kernel    163643.909778 wlan0.A[28441] watchdog@23578: <1ad85a> state 0x30005 watchdog@BCMWLAN Chip Trap~Type=132,PC=0x1862D5,LR=0x1A162D    0
      default    2017-08-19 12:16:31.274987 -0700    kernel    163643.914894 wlan0.E[28442] reportCompletedTxCommands@1122: Command for completion 0x26a47c386bd12cb7 (status success) not in Outbound queue, dropping.    0
      default    2017-08-19 12:16:31.276528 -0700    kernel    163643.916490 wlan0.E[28443] enqueueRxCommands@1207: Command response unexpected:  37649) 0x26a47c3890685b37 [ cmd 0x00000106 len 0x000007D4 flags 0x0893110000 status 0x00000000 "success"]    0
      default    2017-08-19 12:16:31.277797 -0700    kernel    163643.917765 wlan0.A[28444] enqueueRxCommands@1213: Failed to trigger WD, "device is busy"    0
      default    2017-08-19 12:16:31.376696 -0700    kernel    163644.016659 wlan0.A[28445] getTCPAliveOffloadWakeReason@555:Getting TCP Keep Alive Status failed    0
      default    2017-08-19 12:16:31.376877 -0700    kernel    163644.016847 wlan0.A[28446] unConfigureKeepAlives@763:Failed to get TKO Wake Reason with err: BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.377051 -0700    kernel    163644.017021 wlan0.A[28447] setTCPAliveOffloadEnable@526:Configuring TCP Keep Alive Enable/ failed    0
      default    2017-08-19 12:16:31.377215 -0700    kernel    163644.017187 wlan0.A[28448] unConfigureKeepAlives@768:Failed to disable TKO with err: BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.377378 -0700    kernel    163644.017352 wlan0.A[28449] unConfigureKeepAlives@793:Failed to UnConfigure mkeep-alive for ID 1    0
      default    2017-08-19 12:16:31.377537 -0700    kernel    163644.017512 wlan0.A[28450] unConfigureKeepAlives@793:Failed to UnConfigure mkeep-alive for ID 2    0
      default    2017-08-19 12:16:31.377722 -0700    kernel    163644.017692 wlan0.A[28451] configureActivePortsInToChip@26041:Failed to configure Packet Port List : BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.377888 -0700    kernel    163644.017864 wlan0.A[28452] resetPorts@27639:Failed to configure Active Ports    0
      default    2017-08-19 12:16:31.378047 -0700    kernel    163644.018021 wlan0.A[28453] configureARPOffload@26575: Unable to Disable ARP filtering: BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.378216 -0700    kernel    163644.018186 wlan0.A[28454] clearHostIPv6TableForNeighbourDiscovery@26830: Failed to Clear IPV6 addresses from to IPV6 Table BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.378431 -0700    kernel    163644.018401 wlan0.A[28455] configureNeighbourDiscovery@26764: Failure to Disable Neighbour Discovery: BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.378605 -0700    kernel    163644.018575 wlan0.A[28456] configureMulticastBroadcastWaitPeriod@27729: Failed configuring pm_bcmc_moredata_wait: BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.378775 -0700    kernel    163644.018746 wlan0.A[28457] configureMulticastBroadcastWaitPeriod@27736:LPAS: Ignore Multicast/Broadcast failed    0
      default    2017-08-19 12:16:31.378943 -0700    kernel    163644.018913 wlan0.A[28458] configureLPASMode@27684: Failure to configure LPAS in FW: BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.379107 -0700    kernel    163644.019081 wlan0.A[28459] resetLinkParams@21567: Unable to turn off Link Up filtering BCMWLAN Cmdr Disabled    0
      default    2017-08-19 12:16:31.634807 -0700    kernel    163644.274645 wlan0.A[28460] loadImage@3757:Image: 0 [ 0< FIRMWARE{640520} >640520 |  pad  | 640640< NVRAM_PROVISIONED{26} >640666 | 640666< NVRAM{5174} >645840 | pad ] 655134    0
      default    2017-08-19 12:16:31.635025 -0700    kernel    163644.274988 wlan0.A[28461] loadImage@3780:Chip RAM: 0 [ 0< firmware{640520} >640520 | 640520 ~ 640520< free{271776} >912296 | 912296< nvram{5200} >917496 | 917504 ~ pad | 917500 @0xfaea0515 ] 917504    0
      

      I believe all of this happened while the phone was in my pocket. I didn't notice problems until about 30 minutes later.  It is a bit unclear if the phone was dead during this whole time, or only when I started using it. 

      Some of the other errors I am seeing that is indicative of something really messed up is stuff like this:

      default    2017-08-19 12:52:40.228997 -0700    symptomsd    L2 Metrics on ifname en0: rssi: -75 (txFrames/txReTx/txFail) 0/0/0 -> (was/is) 0/0    4626
      mDNSPlatformSendUDP: sendto(49) failed to send packet on InterfaceID 0000000000000008   en0/4 to 75.7.75.75:53 skt 49 error -1 errno 0 (Undefined error: 0) 1516951940 MessageCount is 5

      Next time it happens, I'll take another snapshot and compare behaviors (specifically if the trap is experienced before the outage or if that is a red herring)

      Reply Like 2
  • For those experiencing issues with iOS 11 beta:

    Thank you for reporting this matter. This is something we are looking into. 

    If you are experiencing this issue with either iOS 11 beta or the current production version of iOS (10.3.3) and haven't yet contacted eero support, please email us at support@eero.com so we can continue to look into the matter.

    Thank you, and we will update this thread as soon as we have more details to pass along.

    Reply Like 6
      • bdplatt
      • 1 mth ago
      • Reported - view

      Jeff C. eMail sent. Noting wifi dropout issues with 2 IOS 11 devices whenever I walk through the house. Eero loses connection (or throughput), Eero app says the device in question is still connected to an Eero where I was a couple of minutes ago, instead of the one in the room I'm in now.

      Reply Like
  • Count another one in.

    I just replaced my Netgear Nighthawk X6 with a pack of 2nd gen Eero's and have had multiple problems that I never experienced in 2 years with the Netgear.

    All iOS devices and all the same behaviours described in this thread. Random disconnects, lots of times I have "full bars" but Safari kicks back the "You're not connected" error and yet my wife's sitting right next to mine working fine. Usually after that happens about 5 seconds later boop, I lose wifi all together. It takes iOS another 30 seconds to reconnect to wifi at which point it's fine. All until it randomly happens again. I setup the Eero's last night (18 hours ago) and it's already happened 3 times.

    This is in a 2500sqft home that I mean honestly, the Nighthawk had no problems with I just wanted to "get something better" and the Eero's are centrally located on each floor.

    Reply Like 4
  • I managed to replicate this problem yesterday (it continues to be daily) and the device stayed in the locked out state for over an hour left undisturbed.  This is running the latest iOS 11 beta 7. Switching the network to the guest network fixed the problem, but other things like DHCP renews and any amount of network activity made no difference until that point.

    Some more analysis of the detailed captures definitely point to the broadcom chip hanging and crashing multiple times within that hour, but not coming back up as I would have expected.

    At this point, I am well beyond my depth but it definitely appears to be some sort of interoperability issue between iOS, eero, and/or broadcom. Since this same phone works great all day on my office WiFi network as well as my past Netgear, I think it is safe to assume that something eero is doing is triggering the faults. 

    Reply Like 5
  • Since iOS 10.3.3 and Eero Gen 1 Firmware 3.2.1-2, I am experiencing numerous WiFi dropouts and general WiFi stalls. According to Eero support, this is a known issue.  I have had the Eero Gen 1 woth 3 access points for almost a year and it has provided much better coverage and speed throughout my home than my previous Apple AirPort Extreme 5th Gen but it has also had some quirks with iOS devices that is causing me to think about trying another solution. Such quirks have included Apple Continuity and Handoff features (including Apple Watch unlock of Mac) between iOS devices and my Macs not working (has to do with devices being connected to different eero Access Points, which a user generally has no easy control over) and now this issue, which is likely due to the Broadcom update included in iOS 10.3.3 and how it interacts with the Eeros. It's been enough of a hassle to make me consider something else. 

    Reply Like 2
    • LightEero I would just like to point out that I have iOS 10.3.2 devices doing this so I don't think it's anything unique to 10.3.3.

      Reply Like 1
    • travisbell interesting. Be sure to report this via email to support@eero.com as they are reporting that the wifi hangs are due to the Broadcom WiFi firmware update included in 10.3.3. The issues with Continuity and Handoff have always been present for me (and I know why because it is related to time of flight calculations that iOS and Mac devices do that are impacted by devices being on two different access points) but the WiFi hangs are recent.

      Reply Like
  • To be fair, I bet this problem is happening for any mesh Wi-Fi network provider that is trying to take advantage of iOS's 802.11r FT capabilities.  Everything I am seeing points to a bad code update in iOS 10.3.3 that is breaking the broadcom firmware.

    I have filed a ticket with Apple: rdar://34074507 and I'll report back if anything helpful comes through.

    Reply Like
      • lwdupont
      • IOS Software Engineer
      • 1 mth ago
      • Reported - view

      mattv123 Do you mind putting the details in openradar.me so I can dupe it? No worries if not. Thanks.

      Reply Like
login to reply
Like14 Follow
  • 14 Liked by
  • 2 wk agoLast active
  • 234Replies
  • 4596Views
  • 55 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com


Latest from the eero blog

eero, plus peace of mind

Learn more about eero Plus and how our security suite helps to keep both your devices and everyone in your home safe while online.


Meet a few members of our team