Eero customer support, eero devices and FreeNAS jails

I reported an issue to Eero customer support in early December regarding my  eero devices and my new FreeNAS system which I'm using jails where systems connected to the wireless network provided by my eero devices lose communications to the media server which I'm running on my FreeNAS system.  I have fairly extensively debugged the issue including using a secondary non-Eero wireless network (which shows no issues) and all empirical evidence points to an issue with the Eero network.

In the roughly five weeks I have had little communication from Eero customer support.  I received a message acknowledging my problem report and asking for details of my network on December 11th, to which I replied within a day.  A week after my reply, on December 19th, I received second message suggesting I continue to use my workaround of my secondary wireless network.  I've not heard from customer support since.  A week ago (January 12th) I sent a message to eero support expressing my disappointment in the lack of communication and asking for an update on Eero's position on the issue, to date I've received no reply.

The issue appears to be very specific to the combination of systems/technologies that I am using, however I am not the only person to experience something similar (see: https://forums.freenas.org/index.php?threads/jails-eero.59477/).  I utilize "jails" (containers running on my NAS which have their own IP on the network) for running my Plex media server and after a short time clients on the Eero wireless network will lose communication to the media server.  Clients on my secondary wireless test network (which is an older Apple Airport based network) and on the wired network do not suffer this communication loss. 

I have observed that ARP requests reach the container and the system reply however the reply but does not make it back through the Eero device to the client.  The ARP request will begin making it through again if I log in to the jail and ping the IP of the eero.  Again, this issue only occurs on clients connected via the eero provided network.  "arp -a" for instance on a Macbook Air client on the eero network will show "incomplete" instead of the MAC address of the jail while the issue is occurring; it will see the ARP reply as expected after I issue the ping from the jail and will work again until the ARP table clears. 

At this point I do not know what I should do, but continuing to run my secondary network is unacceptable as there are technology and coverage issues for which I invested in Eero to solve.  I'm struggling with the decision of whether to investigate other wireless mesh providers/solutions to replace the Eero.  

Does anyone in the community have any suggestions or ideas?

21replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I’m mentioning Jeff C. in this reply so he doesn’t miss it. He’s probably the best person on here to try and get you a response.

    You could also try posting on reddit.com/r/eero as there’s some customers on there with higher level of technical expertise that might have some ideas, plus one of the eero engineers is very active on there as well.

  • hi, has there been any updates or progress on this? This is really a problem for me and will probably have to explore other options as it makes my FreeNAS completely unusable. I didn't imagine this would be an issue when I ventured down this route so it is a little disappointing :( Thanks

    Like 1
  • I have a very similar setup, xFinity fiber and router, eero in bridge mode and a Freenas server with several jails.  None of the wireless clients can access the jails but can access the server directly.  I was able to get Window clients to access the jail by setting up a static route on the box using netsh similar to the following: netsh interface ipv4 add neighbors "Wi-Fi" 10.0.0.xx 00-24-01-d2-3a-bd

  • I have the same issue here, and cannot find a resolution anywhere.

    Connection lost between vnet jails and wireless devices on the eero network, it seems not to matter which eerothe wireless devices connect to.

    It worsened after a recent update, and there is no connection at all no matter what. Rebooting the jails, the freebsd host, or the eero network in any order does not help. No ping between a jail and a wireless device, but the FreeBSD host works fine and is seen by all devices.

  • Same problem here. I have a 10GBit subnetwork with a couple of switches and an Eero wireless network. Hardwired machine can ping FreeNAS and all Jails. Wi-Fi connected machines can ping FreeNAS but not jails. I am not sure what the issue is yet, but Im wondering if it has to do with use of VNETs which use promiscuous mode?

    from FREENAS shell, ifconfig showsvnets in this mode:
    vnet0.10: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

  • FWIW I was able to fix this by removing one of my Eero satellites and re-adding them. Jail ips are routing properly again.

  • Nope, not fixed. On a reboot of the Jail I can ping it again over wireless for about 30 minutes or so, then it cannot be pinged but it can ping anything on the network. I think this is an eero bug.

  • I've been having this issue since September of 2019.  I purchased the eero 3 pack.  I could/can connect to everything on the network that's not in a vm; freeNAS or proxmox.  Even if I'm connected wired/wireless to the same error unit as the vm I'm trying to reach.  _Sometimes_ it works.  Most of the time it doesn't.  The times it does, only last until something is rebooted.

    I had an email thread w/their support (Cory) from September until November.  At he tried to tell me it was because I had a managed switch.  I even played their game and removed everything except some old 24 port HP 1Gbit switch; no delta.  W/a Google Wifi setup in the equation everything just works.  Eero is the most epic fail ever.  And they won't accept any responsibility for the trash. I'm surprised they haven't had a class action lawsuit against them for incompetence, false advertisement, or stupid claims of blaming everything but themselves for their own failures.

    _extremely_ irksome.

  • FWIW I also spent quite a lot of time with Eero support, swapping switches around, trying various settings... nothing helped. Finally I loaded up Wireshark and tracked ARP traffic flowing to and from the FreeNAS. I was failing to respond to ARP requests from all the machines I couldnt hit it from, and successfuly responding to the ones I was able to talk to it from. Certain this was an ARP issue I looked around and found this: 


    Looks like a FreeBSD bug and the fix will be available soon. 

  • Is there any solution here.  I have the same issue.  I run FreeNas jails and they become unreachable.  I can access them through Ethernet and other wireless products but not when I access them through eero.  I love eero and it has been rock solid but the arp issue is causing me a ton of issues.

  • Also typing “arp -da” within the shell of a freenas jail that seems to allow access for a period of time.

  • We are having the same issue . Adrianna Fisher was quik to respond but for only two emails. 6 have since gone unanswered. one of our EERO's gets extremly hot and shuts off. We want to know where to ship it for a replacement. It is less than 6 weeks old. The other two are fine.


    Customer service is non existent. 


    Sending emails daily asking for a reply or update. No response from Eero. 

    Like 1
  • Did call, and recieved an email from Mike. That was a few days ago. We sent photos in showing the area is clear and the airflow is execlent. We have 5 other EERO;s in two different locations.I beleive we know the difference in temperature between all of them .The other 5 run warm not hot. Hot is hard to touch warm is like a laptop. We have heard nothing back since we sent the photos in. Round two of no responses.

    Customer support is intermittent and then missing or condesending. 



    Like 1
    • Hello rickh ,

      I will be sending you a direct message shortly. Please reach out to me over direct message so I can look into this for your asap.

      • rickh
      • rickh
      • 3 wk ago
      • Reported - view

      James Thank you

    • Hello rickh ,

      I sent you the direct message through the chat on the Community. When you have time please reach out to me through that chat as I am requesting personal information to locate your account.

  • Yes ... asking for phone number and address. You will find it on the original ticket. If you still need it please send me your email ... as I don't want to post personal information.

    • Hello rickh ,

      I don't have a direct email but I will give you an alternate way for me to locate your account in the direct message. Give me just a moment to type it out.

  • Still waiting for help. James Seems to have passed the ticket to Philip who is asking the same questions. How many times do we have to answer the same questions. The item used to get hot and stop working temporiraly. Now it just doesn't work. They had us try so many times , so that they could gather logs , it finally gave up. We keep asking about where to send the device for a repair or replacement. That question never gets answered. 

    Like 1
    • Hello rickh ,

      I can look into the ticket for you if you would like. It sounds like the ticket was escalated to our tier 2. I will send you a direct message so I can get some information to locate your ticket and look into this for you.

Like2 Follow
  • 2 wk agoLast active
  • 21Replies
  • 849Views
  • 11 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support