8

Enable WPA3 for Compatible devices blocks incompatible devices

When WPA3 is enabled it blocks the devices that cannot use WPA3, however even though WPA3 is enabled the devices that can use it are not using WPA3 according the eero app.

Anyone else noticed this? devices that cannot connect are Apple TV 1st gen and IPad gen2/3. my Motherboard which is a Asrock 570 extreme4 wifi can use WPA3 is not using WPA3 according to the app.

27 replies

    • jcdub17
    • 3 yrs ago
    • Reported - view

    I have this same problem with Apple TV gen 1.

    • Swests
    • 3 yrs ago
    • Reported - view

    I see this behaviour with HP 8615 printer, Apple TV v2, Google Nest (v3)

    • Prouty
    • 3 yrs ago
    • Reported - view

    enabling WPA3 blocks my ability to use my HP OfficeJet 8610 printer over a wireless connection :-(

    I'll leave it off until things improve

    • AIRNetwork
    • 3 yrs ago
    • Reported - view

    I have the same problem with my Epsom wireless printer.

    • Grtday_ne
    • 2 yrs ago
    • Reported - view

    Same with Samsung Galaxy tablet s6 lite

    • djcampbell
    • 2 yrs ago
    • Reported - view

    Same with earlier iPad generations.   Do you think an update is on the horizon?

      • VASK61
      • 7 mths ago
      • Reported - view

       not as of yet. I think someone said that it fixed on theirs but I tried and had to turn it back off, today. The WPA3 will not allow my older generation iPad to connect, when on.

    • brianmilby
    • 2 yrs ago
    • Reported - view

    Same issue with HP Photosmart 7525 printer

    • Cyberianreacher
    • 2 yrs ago
    • Reported - view

    I tried using WPA3, and my Shark robot Vacuum would t connect to the network. Although everything else I had would. I think this feature needs a bit of work before I’m willing to try it again. Caused some headaches.

      • Eibtiysamah
      • 1 yr ago
      • Reported - view

      Cyberianreacher I have two Shark robots and the same problem. It will not connect even after isolating the network to the 2.4ghz and disabling WPA3. Nothing I have tried is working. 

    • Timmmmyyyyyy
    • 2 yrs ago
    • Reported - view

    Same issue with 2 Meross Smart plugs and a govee led light strip. WPA3 goes off and there are no further issues. All are 2.4ghz devices. 

      • Timmmmyyyyyy
      • 2 yrs ago
      • Reported - view

      seems to have been fixed with the latest 6.8.0

    • BearHenle
    • 1 yr ago
    • Reported - view

    WPA3 prevents iPhone 8+ from connecting. Restarted phone, still wouldn’t connect. Turned off WPA3 and it connects fine. 

    • Gadget Enthusiast
    • imjoey
    • 1 yr ago
    • Reported - view

    Yes, same here... Eero! Some of my devices wont connect after enabling this. If I turn it off they connect back just fine. Mostly all of my 2.4 devices. Meross IOT devices do not like this turned on.

    • marcbeau
    • 1 yr ago
    • Reported - view

    I’ve experienced the same issue with RiNG doorbells and cameras, though I did not have that issue with other devices.

    • Timmmmyyyyyy
    • 1 yr ago
    • Reported - view

    I recently rebuilt the network. Just reset to whole damn thing. Used the same ID and password and it resolved all of the issues I’ve been having. Why? Who knows but may be worth a shot. 

    • VASK61
    • 1 yr ago
    • Reported - view

    I have had this problem with my IPad gen 4. Is there a fix?

      • VASK61
      • 7 mths ago
      • Reported - view

      Vask61 I finally fixed it about nine months ago but forgot to put it on here. It was/is finally online, how to fix it. Mediacom Techs did not know how to fix it. They told me to call, Apple Support.  I appreciate everyone’s replies. I just got an email stating that someone had replied. I mean like, today. I should have posted that I fixed it but yes, I had to turn off the WPA3. Thanks everyone😊

    • Yink
    • 1 yr ago
    • Reported - view

    Had same issue recently but with a Samsung TV every other device worked fine but it just blocked the TV off. It just couldn’t get an IP. 
    Worst thing is switching off WPA3 made no difference only after lots of debugging figured I had to restart the eero device for WPA3 to switch off. 

    • gkuyat
    • 1 yr ago
    • Reported - view

    WPA3 Breaks several of my devices, especially WiFi enabled lights.

    • Magicman76
    • 10 mths ago
    • Reported - view

    Same thing with my Zengge smart bulbs. They go offline when I run on WPA3.

    • VASK61
    • 7 mths ago
    • Reported - view

    Finally found the fix about nine months ago and yes, turning of Wpa3 fixed it! I tried to see if they had fixed it last week but no, I had to turn it off today.

    • sgmah
    • 6 mths ago
    • Reported - view

    Any update on the WPA3 compatibility? Amazon eero's website still says, "eero’s WPA3 feature operates in “transition mode,” meaning WPA3 capable devices will connect using this new standard, and unsupported devices will continue to use WPA2." Just tested it and a bunch of my Wi-Fi devices started dropping off the network. It'll nice if it worked since I have a few devices that support Wi-Fi 6E.

    • JonathanM
    • 6 mths ago
    • Reported - view

    Apparently this is still an issue - for me it was a Chamberlain smart garage door controller. The discussion on correcting this problem is years old and extensive.  Turns out it was WPA3.  Seems this option should go away until/unless eero exerts some effort into making it work correctly!

Content aside

  • 8 Likes
  • 4 mths agoLast active
  • 27Replies
  • 1065Views
  • 23 Following