Enable WPA3 for Compatible devices blocks incompatible devices

When WPA3 is enabled it blocks the devices that cannot use WPA3, however even though WPA3 is enabled the devices that can use it are not using WPA3 according the eero app.

Anyone else noticed this? devices that cannot connect are Apple TV 1st gen and IPad gen2/3. my Motherboard which is a Asrock 570 extreme4 wifi can use WPA3 is not using WPA3 according to the app.

18replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have this same problem with Apple TV gen 1.

  • I see this behaviour with HP 8615 printer, Apple TV v2, Google Nest (v3)

  • enabling WPA3 blocks my ability to use my HP OfficeJet 8610 printer over a wireless connection :-(

    I'll leave it off until things improve

  • I have the same problem with my Epsom wireless printer.

  • Same with Samsung Galaxy tablet s6 lite

  • Same with earlier iPad generations.   Do you think an update is on the horizon?

  • Same issue with HP Photosmart 7525 printer

  • I tried using WPA3, and my Shark robot Vacuum would t connect to the network. Although everything else I had would. I think this feature needs a bit of work before I’m willing to try it again. Caused some headaches.

    • Cyberianreacher I have two Shark robots and the same problem. It will not connect even after isolating the network to the 2.4ghz and disabling WPA3. Nothing I have tried is working. 

  • Same issue with 2 Meross Smart plugs and a govee led light strip. WPA3 goes off and there are no further issues. All are 2.4ghz devices. 

    • seems to have been fixed with the latest 6.8.0

  • WPA3 prevents iPhone 8+ from connecting. Restarted phone, still wouldn’t connect. Turned off WPA3 and it connects fine. 

  • Yes, same here... Eero! Some of my devices wont connect after enabling this. If I turn it off they connect back just fine. Mostly all of my 2.4 devices. Meross IOT devices do not like this turned on.

  • I’ve experienced the same issue with RiNG doorbells and cameras, though I did not have that issue with other devices.

  • I recently rebuilt the network. Just reset to whole damn thing. Used the same ID and password and it resolved all of the issues I’ve been having. Why? Who knows but may be worth a shot. 

  • I have had this problem with my IPad gen 4. Is there a fix?

  • Had same issue recently but with a Samsung TV every other device worked fine but it just blocked the TV off. It just couldn’t get an IP. 
    Worst thing is switching off WPA3 made no difference only after lots of debugging figured I had to restart the eero device for WPA3 to switch off. 

Like8 Follow
  • 3 mths agoLast active
  • 18Replies
  • 413Views
  • 17 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support