1

Eero, Siri/HomeKit, and Smart Plugs

Hello,

I just bought an Eero Pro 5 router with two beacons. Prior to buying I had your usual 2G/5G setup and utilized six Wemo Smart Plug Minis, HomePods, etc. since installing my Eero, my smart plugs no longer work. I can’t seem to get them to install. They’re 2.4ghz only. I’ve tried my iPad (at the same ghz), stopped the 5ghz band for 15 minutes, installed a different router for them off the main Eero, and just about everything I could think of and have read. They just won’t connect.

I was able to at one point connect it to the Eero, but it failed to connect to the HomeKit or Wemo apps and had an error when installing. 

So, I’ve given up on them. Does anyone have any recommendations on Smart Plugs that do work with Eero Pro 5 and HomeKit? I would really like suggestions. I really enjoyed my connectivity with my plugs and HomePods, and it really do love the internet quality with my Eero Mesh system. I’m hopeful that products are out there to help Me get the best of two! 

5 replies

    • mrsaxy
    • 3 yrs ago
    • Reported - view

    The Amazon plugs always work, but I recently got these Kasa brand made by TP-Link and they work great plus mush cheaper than the Amazon plugs.

    https://www.amazon.com/dp/B07TXM4MT3/ref=cm_sw_em_r_mt_dp_JWX8VA0EY7Q38KYFBT8Y?_encoding=UTF8&psc=1

      • SamKoester21
      • 3 yrs ago
      • Reported - view

      I have a Siri/HomeKit setup and would prefer not to change over to Alexa or Google. 

      • eero_support
      • 3 yrs ago
      • Reported - view

      Hello SamKoester21 ,

      As long as you do not have an eero 6 setup as the gateway for your eero network you should be able to use HomeKit through the eero app. I have included a link below that will provide you with instructions and troubleshooting for your HomeKit devices. Let me know if you have any questions.

      https://support.eero.com/hc/en-us/articles/360036319531-How-to-use-HomeKit-with-your-eero-Network

    • scw
    • 2 yrs ago
    • Reported - view

    Hi SamKoester21

    I have the exact same problem as yours. See also this thread:

    https://community.eero.com/t/83h1rfv/problems-with-latest-eero-6-pro-update-and-wemo-mini-smart-plugs

    Did you already figure something out yet?

    The solution offered by James did not help anything for me unfortunately

    • scw
    • 2 yrs ago
    • Reported - view

    SamKoester21

    There's also the difference in firmware from the Wemo. The 4.0.2009 version worked about seamlessly for me installing and is working perfectly in combination with my Eero Pro. The 4.0.2011 versions (I tried four of them!) don't seem to get working... :-((

Content aside

  • 1 Likes
  • 2 yrs agoLast active
  • 5Replies
  • 849Views
  • 4 Following