4

iOS / iPadOS 14.5.1 + Private Address OFF = Frequent Disconnects

Hi all -- seeing this issue with several iOS / iPadOS devices (iPhone 12 Pro, iPhone 8, a few iPad Pros, iPad Air, iPod Touch): If the device is configured with the Private Address option turned OFF (so that I can use DHCP IP reservations), the device will frequently either disconnect from the WiFi completely, or it will flip over into the Private Address option (in which case my IP addresses get all out of whack). The only thing I can do when this happens is to completely forget the WiFi network on the device and then join again with the Private Address option turned off.

Anyone else seeing this? I have called Apple and of course they wanted to blame the Eero. I have restarted the Eero a few times and nothing solves the issue. Eero is on the latest version (6.3.0).

53 replies

    • dtrimm
    • 2 yrs ago
    • Reported - view

    Hi there,

    Just in case anyone at Eero is thinking this issue is fixed... it isn't. I'm on the latest software, have over 30 devices connected without problem to 4 Eero Pro 6s in the house, but the Apple devices ALL have problems - two iPads and two iPhone XRs. The Apple devices are all on the latest software, WPA3 is turned off (and always has been), address randomization is off on all 4 devices. The guest network is on - and that works just fine with Apple devices btw), there are two reserved IP addresses among the 30 devices which are working without issue. 

    Here's the symptom: generally I can get a 5GHz connection, but when I move between Eeros (by moving about the house), I get a message on the Apple Device which says something like "It looks like this 5GHz network is not connected to the internet. Would you like to switch to cellular data?".

    Sometimes if I toggle wifi off on the device, then when it turns back on I get a connection. However when I look at which Eero it has connected to, it never seems to be the nearest (most logical) one. If the toggle doesn't work then forgetting the network does, or (sometimes) a reboot of the Eeros is required.

    Staying on the guest network isn't an option as our Amazon Echo sound system is all on the 5GHz network - just like someone commented earlier re Sonos.

    It has occurred to me that the Apple devices are really the only ones which roam about the house, so MAYBE there's a problem with other devices, but because they don't move, they don't have to hand off between Eeros? I do have a Windows 11 laptop which I use rarely, though I'm not conscious of problems with that.

    The plain fact is that (for me) this expensive network, owned by one of the biggest names in tech, just doesn't work with the (second) most popular mobile devices in the world, and that ought to be a HUGE red flag for people at Eero and for anyone thinking of buying it or (like me) moving to an ISP where this is basically the only option. C'mon - let's have it fixed please!!!!

    • clayj
    • 2 yrs ago
    • Reported - view

    Yep -- just happened to me again this morning. I was checking mail on my iPhone 12 Pro (iOS 15.5) and WiFi was definitely connected -- put it down for a few minutes -- picked it up and found that the WiFi was "Not Connected". Eero Pro 6 on latest firmware, iPhone configured NOT to use Private Address (I have an IP reservation set up in the Eero and I want all of my devices using specific IP addresses).

    Eero: Get with Apple and GET THIS FIXED. I can tell you right now that if it comes down to using Eero OR Apple, you will not win -- and I will stop recommending Eero to anyone.

    • superpixels99
    • 2 yrs ago
    • Reported - view

    It's July 18, 2022 and I'm still seeing this issue. Even with reserved IP addresses, it looks like the iPhone (12 Pro) "isn't on the network" even though it is. The HomePods work otherwise, every other device works fine, and the Apple Home app sees the HomePods, but they act like the iPhone isn't on the network. This really feels like Eero is punishing Apple users, which, if true, is illegal. Perhaps worth investigating, because this is ridiculous. 

Content aside

  • 4 Likes
  • 10 mths agoLast active
  • 53Replies
  • 2889Views
  • 23 Following