4

iOS / iPadOS 14.5.1 + Private Address OFF = Frequent Disconnects

Hi all -- seeing this issue with several iOS / iPadOS devices (iPhone 12 Pro, iPhone 8, a few iPad Pros, iPad Air, iPod Touch): If the device is configured with the Private Address option turned OFF (so that I can use DHCP IP reservations), the device will frequently either disconnect from the WiFi completely, or it will flip over into the Private Address option (in which case my IP addresses get all out of whack). The only thing I can do when this happens is to completely forget the WiFi network on the device and then join again with the Private Address option turned off.

Anyone else seeing this? I have called Apple and of course they wanted to blame the Eero. I have restarted the Eero a few times and nothing solves the issue. Eero is on the latest version (6.3.0).

53 replies

    • Goinloco
    • 2 yrs ago
    • Reported - view

    Having the same issues on my current apple devices. Posting for updates

    • inertjade
    • 2 yrs ago
    • Reported - view

    Having the same issues on my current apple devices. Posting for updates

    • Corby_Mason
    • 2 yrs ago
    • Reported - view

    Don't know if this helps, but for me ONLY my APPLE devices have this problem. I have turned off, in my Apple devices,"Private Addressing" and the problem goes away.......for a while. I can't seem to make my Apple device persistantly keep this setting off. If I restart it or there is an update, it comes back on, and in a short while after that, it disconnects my Ipad or phone from the EERO network connection. EERO needs to open a discussion with Apple to understand what's happening here. That is the words you need to tell us all- "We have contacted Apple and are trying to understand if there are any open issues we can enhance or resolve" that would be nice to hear, so far you have been really no help on this issue.

      • chevyv
      • 2 yrs ago
      • Reported - view

      Corby Mason My Sony PS4 and PS5 take a while to have a fully functioning access to the “internet” and the lag is a nuisance.

      This could be a problem with their Secure+ functionality but with zero tools and no descriptive diagnostics of the internals it’s impossible to determine.

    • chevyv
    • 2 yrs ago
    • Reported - view

    Here’s a new twist.

    I added my guest network and credentials. Guess what?

    No problems with Apple devices. If get on the regular network and it drops out, my devices jump on the guest network.

    This is an Eero problem.

      • clayj
      • 2 yrs ago
      • Reported - view

      chevyv Interesting. Are you doing this with the Private Address option DISABLED on your Apple devices?

      • chevyv
      • 2 yrs ago
      • Reported - view

      clayj My iphone and iPads are all have private address disabled, however I know when my kids connect with private addresses. Since this is the default, my actual guests connect their iphones to the guest network with no problems.

      All summer we've been streaming audio to a Sonos via Airplay (I personally use the Sonos app to fire and forget) and now we can tell when we get booted off the regular network and jump on the guest network because the audio cuts off but we still have internet access over WiFi. It's a nuisance for us because the Sonos is on the "wrong" network.

      • chevyv
      • 2 yrs ago
      • Reported - view

      clayj It's been two months since you originally posted. Do you still have this issue?

      • clayj
      • 2 yrs ago
      • Reported - view

      chevyv It hasn't been gone long enough for me to declare it gone. I just updated to eeroOS 6.4.0 last week, and iOS / iPadOS 14.7.1 as soon as it came out. I'll call it solved when it hasn't happened for at least a month or two.

    • susanmooremaddox
    • 2 yrs ago
    • Reported - view

    Yes, my iPhone 11 Pro Max does this constantly. Whenever I see that AT&T Internet symbol up there, I know that they’re is a privacy issue with my network. This image is, of course, following my changing the privacy setting.

    • tardifa
    • 2 yrs ago
    • Reported - view

    A little late but I've been having this problem since last Spring. Eero didn't resolve it and in speaking to Apple many times, it doesn't look like this is an Apple problem.

    My iPhone sporadically disconnects multiple times A DAY and the only thing I can do is either toggle Private Address off OR toggle it back on. It's the only way I can reconnect to the damn network. I've done extensive troubleshooting on my end and nothing has helped.

    I'm on 6.4.0 and today, my work iPhone started disconnecting as well. I sent an email to Support. As someone who works remotely, I need a reliable connection and thus far, this does not seem to be it.

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello tardifa ,

      Thank you for reaching out to us here and welcome to the Community! Some customers have had success disabling WPA3. Can you check that setting in your app? It is located in the discover tab -> eero LABs section where customers can test our features that are in beta for testing while we optimize the feature. 

      • Peterj0
      • 2 yrs ago
      • Reported - view

      tardifa disabling WPA3 fixed it for me

    • NeedHelpWithMyEero
    • 2 yrs ago
    • Reported - view

    Hey there clayj, did your issue resolve now that we're at version 6.5.0? I'm asking because I'm also experiencing the same issue. Guest network is the only light at the tunnel of my daily reboot regimen

      • clayj
      • 2 yrs ago
      • Reported - view

      NeedHelpWithMyEero I just updated to 6.5.0 yesterday, so we will need to wait a while (a week or two) to see if there are any more disconnects here.

      • nicolas_cindric
      • 2 yrs ago
      • Reported - view

      clayj My name is Nicolas. I do have eero pro 6. the iphone, ipads disconnects from the eero network and then lose the password of the network systematically. All ios devices run latest firmware and the eero pro 6 have 6.5.0. I tried the WPA3 off , the private address on and off. And still the same issues since recent upgrade of the eero pro 6 to a previous firmware upgrade.

      Tried to remove the network, remove all eeros, re add them one by one....All was woirking perfectly in the past. and now it is a nightmare with ios devices

      • nicolas_cindric
      • 2 yrs ago
      • Reported - view

      nicolas. cindric just very frustrating when we paid top dollars as they are the most expensive systems... Did eero recognize there is a problem with their firmwares? I am about to dump them and the brand and try to buy something else. I cannot waste my time reconnecting the appleTVs, iphones, ipads...

      • nicolas_cindric
      • 2 yrs ago
      • Reported - view

      clayj are you still experiencing the same issues as I do? I guess all people with ios who upgraded to the latest firmwares must face similar issues

      • nicolas_cindric
      • 2 yrs ago
      • Reported - view

      clayj so upsetting that I am going to buy some google wifi mesh today. If it works well, I will inform everyone here to switch as it seems that eero is ignoring the reality of what we are facing.

      • txgunlover
      • 2 yrs ago
      • Reported - view

      nicolas. cindric Try to stop using Crapple devices.

      • nicolas_cindric
      • 2 yrs ago
      • Reported - view

      txgunlover nice joke. But do you have any idea to solve this? that would be more useful thank you

      • Peterj0
      • 2 yrs ago
      • Reported - view

      nicolas. cindric have you turned off WPA3 ? This resolved the issue for me.

      • nicolas_cindric
      • 2 yrs ago
      • Reported - view

      Peterj0 Thanks Peter, I had it off and it is only apple ios devices. However, you have a different GUI, I dont see in my app the option about Optimize for conference and gaming

      • nicolas_cindric
      • 2 yrs ago
      • Reported - view

      Peterj0 it did not change anything about having the WPA3 turned off. unfortunately.

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello nicolas. cindric ,

      Thank you for reaching out to us! I apologize that you are having difficulties with connectivity of your Apple products with your eero network. I would like to help you troubleshoot this behavior. I will send you a direct message shortly with directions on how to get an email to me so we can start working on this shortly.

Content aside

  • 4 Likes
  • 5 mths agoLast active
  • 53Replies
  • 2656Views
  • 23 Following