3

UPNP not functioning properly in the latest eero software update.

In the latest eero update,  the UPNP function doesn’t work correctly, and doesn’t function normally. Basically, it acts like it isn’t enabled. 

I fixed my issue by manually port forwarding, I just wanted to report the issue so the developers could fix it.

 

Thanks,

Luke

18replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Ah.  That explains the Xbox issues.  How could they push an update out with UPNP broken?  That's nuts.

    Like
  • First day with an Eero Pro. I need to +1 this issue. I cannot get UnPnP to work as well on a wired connection in a pretty basic setup (Eero to network switch, Xbox to switch)

    Like
  • I knew something was up! My Xbox’s both went to moderate NAT type ever since the most recent update. I don’t understand how a firmware update released with intention to “improve UPnP” can actually break it instead. I’m hoping the Eero team is well aware and pushes out an update on it very soon. 

    Like
  • I’ve been exchanging messages with support on Twitter and they’ve been giving me troubleshooting steps, though I’m not optimistic their solutions will work. I’ll report back if I find any satisfaction. I’m trying to avoid port forwarding and any of that nonsense.

    Like
      • Esalmani24
      • Esalmani24
      • 5 mths ago
      • 1
      • Reported - view

      Bronstrmontstr  Yes, please do. I’m hopeful there will be a fix soon. 

      Like 1
  • I've also noticed that my speed on the speed test has plummeted down to 72 mbps from the 800+ mbps I was getting. My devices are seeing this too and if I bypass and connect directly to the Uverse modem they get back the high speed.

    Like
  • My journey with Eero support ended in Reservation/Port Forwarding land, which did solve my problem, as I now have an Open NAT on my Xbox. I'd have preferred to use UPnP, but I guess I'll have to wait till the next Eero software update. 

    Like
      • Esalmani24
      • Esalmani24
      • 5 mths ago
      • Reported - view

      So they are actually aware that this update did something to the UPnP functionality it wasn’t intended to do? UPnP always worked perfectly fine. There was no need for port forwarding at all. Bronstrmontstr 

      Like
      • LordRazon
      • LordRazon
      • 5 mths ago
      • Reported - view

      Bronstrmontstr would you be able to post what you did in port forwarding?

      Like
    • Esalmani24 I am doubtful that the frontline support folks have much visibility into what the engineering team has planned. The rep I was dealing with did not acknowledge when I asked if they were seeing an uptick in support requests for UPnP. 

      Like
      • Esalmani24
      • Esalmani24
      • 5 mths ago
      • Reported - view

      Bronstrmontstr  Yeah, there has to be more people definitely voicing their frustration on this. Something is up 100%, and there are issues with the whole UPnP in this update. The overall stability seems to have been negatively impacted as well. First update I can truly say on Eero that has been a disaster. Eero has been extremely stable and more than amazing for more than over the year that I’ve had it. This update is flawed and has issues without a doubt. 

      Like
    • LordRazon I will do my best. First, you’ll need this to get the port numbers and configuration details you need: https://support.eero.com/hc/en-us/articles/208229046-My-Xbox-says-my-NAT-is-Strict-or-Moderate-and-won-t-let-me-join-online-games-How-do-I-fix-this-

      I am including two photos with some text instructions to try and explain how to do it - let me know how you fare with this.

      Like 1
    • Esalmani24 Good to know - I’m only into my first week with Eero having switched away from Orbi’s. Eero’ s reputation is pretty stellar, so hopefully this is a temporary hiccup.

      Like
      • LordRazon
      • LordRazon
      • 5 mths ago
      • 1
      • Reported - view

      Bronstrmontstr thanks, worked perfectly. Xbox now says NAT is open.

      Like 1
    • LordRazon you are most welcome. Glad it worked!

      Like
  • Following. Looks like it’s been a few months now since this problem occurred. Curious about the much needed (and slightly overdue) correction. Port Forwarding is a work around that may suffice but improved UPnP functionality was part of the reason for the update in the first place. 

    Like
  • Yep, still waiting for an official “fix” on this issue. 

    Like
      • SEGApostle
      • SEgapostle
      • 3 mths ago
      • Reported - view

      Bronstrmontstr I'm giving up on the wait.  I ordered an ASUS ZenWiFi AX package with the wireless backhaul.  I'll post some results here once I test them out tomorrow.  eero support has been awful.

      Like
Like3 Follow
  • 3 Likes
  • 3 mths agoLast active
  • 18Replies
  • 459Views
  • 6 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com