1

Eero App Not Loading on iPad updated to IOS 15.2

I’ve seen discussion of this issue on other forums and submitted a customer service request to eero but have not received a reply.  I’m curious if anyone here has a resolution or has experienced the same issue.  

Since updating my iPad Pro to IOS 15.2 last week the eero app freezes on the start up screen.  I’ve deleted the app, hard reset the iPad and reloaded the app three times.  I saw a note on Reddit indicating that some users were able to get the app to load by starting the iPad in portrait rather than landscape mode.  That has not helped in my case.  

I’ve also noticed that the app does not appear in the apps list under Settings on the iPad.  

It seems to work fine on an iPhone and an older iPad running 15.1.  

25 replies

    • Dsccwells
    • 2 yrs ago
    • Reported - view

    Updated to version 16.14.1 today and problem still exists.  

    • VURTDOG
    • 2 yrs ago
    • Reported - view

    I have the same exact issue.

    • mjmaio
    • 2 yrs ago
    • Reported - view

    I have the same problem

      • mjmaio
      • 2 yrs ago
      • Reported - view

      mjmaio works fine on the iphone with IOS 15.2.  I have updated the router and the application on the iPad.  The results are the same.  I see the eero logo but the application does not load.

    • linda
    • 2 yrs ago
    • Reported - view

    I'm seeing the same issue. Eero app won't get past its initial startup screen on the iPad but works on the iPhone. Spoke to support about a week ago and they acknowledged the problem but had no ETA on when it would be fixed. I've seen one Eero app update since but it didn't solve the problem. 

    • JC9091
    • 2 yrs ago
    • Reported - view

    Same problem here. I’m panicking because my iPhone says it’s going to update the Eeros app in the next 24 hours and I’m worried it will stop functioning there as well.

    • Jsammy
    • 2 yrs ago
    • Reported - view

    I have the same issue.  My iPhone works fine, but my ipad will not load the app past the start up screen. I contacted customer service and they had my reset my network settings, but that did not help.  He told me that they were looking into the issue and hopefully a hot fix would be available soon.

    • Marzecms13
    • 2 yrs ago
    • Reported - view

     Me too eero app … works fine on iPhone and 5 years old iPad BUT STOPPED WORKING TODAY ON IPAD PRO 

    • mattekramer
    • 2 yrs ago
    • Reported - view

    exact same issue…fine on phone…no go on Ipad

    • kstr79
    • 2 yrs ago
    • Reported - view

    Hello,

    Here is a temporary work around until they patch this bug.

    1. Close the Eero App.

    2. Take the iPad off of any keyboards, etc.

    3. Put the iPad Screen in Portrait Orientation (Vertical).

    4. Open the Eero App

    Regards, Kstr79

      • JC9091
      • 2 yrs ago
      • Reported - view

      kstr79 that worked for me. Thank you!

      • Dsccwells
      • 2 yrs ago
      • Reported - view

      kstr79 thanks.  Taking the iPad off the keyboard (I also removed the pencil) and opening in portrait worked. Still locks up if left on keyboard or in landscape.  

      • Jsammy
      • 2 yrs ago
      • Reported - view

      kstr79 

      It worked. All I needed to do was take the ipad off the magic keyboard and it worked. I did not need to rotate into portrait orientation.  

      Thanks so much!

      • jmkonline
      • 2 yrs ago
      • Reported - view

      kstr79 Thank you so much.  This worked for me.  One thing I will point out is that as long as I don’t close the App, I am able to reconnect my iPad to the magic keyboard and use the App, use other Apps, then open come back and use Eero.

      • ioleyva
      • 2 yrs ago
      • Reported - view

      kstr79 This worked great. I had tried the portrait mode like others had recommended, however the other posts did not mention removing the keyboard. Once I removed the keyboard and put it in portrait mode, that worked! Thank you very much!

      • Lh2253
      • 2 yrs ago
      • Reported - view

      kstr79 

      This worked for me.

      iPad Pro (12.9-inch) (3rd generation) iPadOS 15.1 eeroOS 6.6.1

      • LouRam
      • 2 yrs ago
      • Reported - view

      kstr79 Thanks for sharing!

    • Marzecms13
    • 2 yrs ago
    • Reported - view

    Thanks !  Worked for me too !  Would have been awhile before i ever tumbled to this :-(

    • linda
    • 2 yrs ago
    • Reported - view

    Yes, worked for me as well! Though I didn't have to rotate to portrait to get it to open properly. Simply removing it from the Apple Magic Keyboard did the trick even in landscape orientation. Once loaded it will start with the keyboard attached though that only last until it gets unloaded from memory I suspect and then the dance will need to happen again

    • Theo
    • 2 yrs ago
    • Reported - view

    I am finding the same problem on iPadOS 15.2. When iPad Pro is connected to the Magic Keyboard, launching the eero app does not get past the splash screen. All other situations work fine, namely:

    • launching when disconnected from the Magic Keyboard
    • Launching disconnected and then connecting to the keyboard after the app has launched
    • results are the same with the iPad in landscape or portrait mode

    I am curious if anyone finds other apps that exhibit this behavior?

    • jssherman62
    • 2 yrs ago
    • Reported - view

    KSTR’s fix in the thread works perfectly.  I have been dealing with this for 4 weeks! 4 contacts with EERO and crickets.  Really appreciate the info! 

    • C_Wood
    • 2 yrs ago
    • Reported - view

    Seriously! I restarted my iPad, reinstalled the Eero app and nothing worked. Then I just undocked it from my Magic Keyboard and it came right up. I didn’t have to be in portrait mode or anything, just take it off the Magic Keyboard. Eero needs to send an update.

    • alcain55
    • 2 yrs ago
    • Reported - view

    Installed iOS 15.3 and it still doesn’t work.

    • C_Wood
    • 2 yrs ago
    • Reported - view

    Is your iPad attached to a Magic Keyboard? Once I undocked my iPad it worked.

    • Dsccwells
    • 2 yrs ago
    • Reported - view

    This issue appears to be fixed in the 6.15.0 update.  

Content aside

  • 1 Likes
  • 2 yrs agoLast active
  • 25Replies
  • 531Views
  • 19 Following