0

Eero not connecting to last mesh point

Hello,

I have a Eero Pro Wifi system setup ( https://www.bestbuy.com/site/eero-pro-mesh-wifi-system-3-eeros-2nd-generation-white/5873518.p?skuId=5873518 ). The router worked fine all along, but the mesh point I tried did not work. It never finds it and then when I put in the serial number it says it is found immediately but then it goes to do a placement test and it continues saying that I need to place the eero somewhere else then after pressing try again it takes me back to No eero found. I've tried connecting wired from the modem to this device and nothing seems to work. Also, when it finds it after manually entering the serial number, it runs the placement test directly next to the router and I've tried in other locations in the house too. The second mesh point worked fine right away. I've tried all the trouble shooting I've found and nothing seems to work. I'm guessing this is an issue with that specific mesh point, but I'm not sure how to fix this. I tried to call customer support, but they were closed, so was hoping someone else has experienced this and can help.

Thanks in advance!

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Sounds like you got a lemon. Quickest solution might be to just return to Best Buy and swap out for a new set. Otherwise, call eero support tomorrow during their support hours, or email them anytime.

    Reply Like 1
Like Follow
  • 13 days agoLast active
  • 1Replies
  • 28Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com