2

Manual IP and IP Reservations

I just set up my new Eero network and am pleased with it.  I chose it for the family controls and it seems to work well.

However, I have two NAS servers with static IP addresses from my old network at 192.168.2.3 and 192.168.2.4.  So, I tried to turn on "Manual IP" to allocate all dynamic (DHCP) address from 192.168.2.20 and up (leaving static addresses below this).  So, I need a network of 192.168.2.0, but the default network is 192.168.0.0 and it cannot be changed.  When I change the "0" to a "2" and press Save, I get a message saying "Reboot required" (no problem) but then it says "we couldn't update your settings.  We ran into an issue updating your settings.  Please check to make sure you entered the right values and try again."

This looks like a limitation in the software preventing non-zero subnets.  Of course, I can change all the network references in .hosts files and all the server references but I would prefer not to change all that.  Any recommendations?

17 replies

null
    • FuzzyG
    • 7 yrs ago
    • Reported - view

    Did you change all 3 values, the subnet IP, the starting IP and the ending IP? 

    • cmarinho
    • 7 yrs ago
    • Reported - view

    Just using the thread as I have the same issue. Yes I did. I need to setup the main eero IP to 192.168.1.1. What should I do? Thanks.

    • cmarinho
    • 7 yrs ago
    • Reported - view

    I need to set a specific lease range, so I must use the manual IP option. I am not seeing where can I edit the gateway Eero IP.

    • eero Community Manager
    • Jeff_C
    • 7 yrs ago
    • Official response
    • Reported - view

    Hi  cmarinho —

    Thanks for reaching out and welcome to the eero community!

    It is not possible to edit the IP of the gateway eero. If you would need to edit the IP of the primary router in your setup, at this time, it would be necessary to use another router as your gateway and put the eeros in bridge mode. We apologize for the inconvenience, however, it is necessary that the primary eero attached to your modem has an IP that ends in .1 for the mesh to work properly.

    If you have any other questions, please contact our support team. We'd be happy to help you through any steps or necessary troubleshooting.

    • FuzzyG
    • 7 yrs ago
    • Reported - view

    Did this change? I am almost certain I had this option awhile back.

    • FuzzyG
    • 7 yrs ago
    • Reported - view

    I didn't want to edit the above reply.

    I just did it now and it worked fine. The router does have to be .1 but my IP has successfully changed, and the server successfully gave me an IP.

    • eero Community Manager
    • Jeff_C
    • 7 yrs ago
    • Official response
    • Reported - view

    Thanks for following up,  FuzzyG .

    Sorry for the confusion—you can change the lease range of the IP, however, what I was saying is you cannot change the primary eero from ending in .1. Also, all the eeros on your network will need to be on the same subnet as the gateway and leaf eeros cannot be on different IPs.

    I hope that helps to clarify things!

    • cmarinho
    • 7 yrs ago
    • Reported - view

    I don't really have any doubts about using Eero in bridge mode, but you guys should have a way to letting customers set the IP address prefix. I understand it is easier for most of customers, but these are the advanced settings, right? 

    I am very happy with the system, so don't take it as a complain, however, I may need to put it in bridge mode and use the ATT router as the gateway just because of the lack of this option.

    • cmarinho
    • 7 yrs ago
    • Reported - view

    I don't really have any doubts about using Eero in bridge mode, but you guys should have a way to letting customers set the IP address prefix. I understand it is easier for most of customers, but these are the advanced settings, right? 

    I am very happy with the system, so don't take it as a complain, however, I may need to put it in bridge mode and use the ATT router as the gateway just because of the lack of this option.

    • FuzzyG
    • 7 yrs ago
    • Note
    • Reported - view

    If you go to Network Settings -> Advanced Settings -> DHCP NAT

    Choose Manual IP and change all of the following to match:

    Subnet IP, Starting IP & Ending IP (if you are only doing a handful of units change the mask to 255.255.255.0) you will be fine. The IP of the router will be the Subnet IP ending in 1. That should do everything you need. Am I misunderstanding what you need?

    • cmarinho
    • 7 yrs ago
    • Reported - view

    it worked!! Thanks!!

    • cmarinho
    • 7 yrs ago
    • Reported - view

    i live in Miami, I am on an event in NYC, and changing the config remotely through  an IOS app. Really cool! Congrats! 

    Keep evolving! 

    • FuzzyG
    • 7 yrs ago
    • Reported - view

    Sweeeeet... Good to hear! 

    • NaNo
    • 2 yrs ago
    • Reported - view

    So I am just wonder what would I put in the Subnet ip, starting ip, and ending ip? Like would I just put one number or a whole ip? I don't think I am fully understadning this.

    • htrottenberg
    • 1 yr ago
    • Reported - view

    FuzzyG , I've entered the manual details as suggested and nothing happens when I hit save and accept the reboot. Any ideas?
     

    Do I need to do a hard reset on the main Eero to get this ip changed? (I'm hoping not)

    • ChrisY3
    • 1 yr ago
    • Reported - view

    I have the same problem. My router is 10.83.1.1 and has several IP address bound to devices. 
    how can I set my eero 6 to match without using bridged (I want to connect it to HomeKit but bridged mode won’t let me) ? 

Content aside

  • 2 Likes
  • 1 yr agoLast active
  • 17Replies
  • 14303Views
  • 8 Following