0

Pixel XL issues

Anyone had issues with Pixel XL? Every device I have including other Android devices is fine. Pixel XL connects and works fine for like 5 mins and then offline to near zero throughput for 1 min.

The Pixel XL is fine on other wifi networks.

12 replies

    • retired and good at it
    • susandennis
    • 7 yrs ago
    • Reported - view

    I have a Pixel (not XL) Phone and I have not seen this or had any problems with it on my Eero network. If there's any test I can do or other things I can check for you, please don't hesitate to ask. That sounds really frustrating!

    • RedRed
    • 7 yrs ago
    • Reported - view

    Thanks. What build you on? I'm on NDE63L.

    Does yours connect on 5 Ghz? It should be in the wifi settings on that connection. Seems like every issue I've had in the past with Android devices I could cure by forcing them back onto 2.4 Ghz. Can't do that with Eero or Pixel XL.

    • rmiller1959
    • 7 yrs ago
    • Reported - view

    I have a Pixel XL and have not had any problems connecting and remaining connected to the network. My build number is NDE63P.

    • RedRed
    • 7 yrs ago
    • Reported - view

    I saw that NDE63P specifically said it fixes wifi issues. But I went to flash it and it's supposedly just the Verizon variant of what I have. 

    I just stuck an Apple Airport Extreme on my network running side by side with Eero, different names, and Pixel is fine with that. So I don't know what the deal is.

    • retired and good at it
    • susandennis
    • 7 yrs ago
    • Reported - view

    I can tell you that my Pixel is using the 5 Ghz band but I can't tell you the build number cause I don't know where to find it :(

    • eero Community Manager
    • Jeff_C
    • 7 yrs ago
    • Reported - view

    Hi  RedRed —

    Welcome to the eero community! I am thrilled to see the quick help you received from  susandennis and  rmiller1959 :) High fives all around!

    If you are still experiencing issues with your Pixel XL and haven't yet contacted support, please reach out. Our team is more than happy to look into this issue with you.

    Feel free to give us a call at 1-877-659-2347 or email us at support@eero.com.

    • RedRed
    • 7 yrs ago
    • Reported - view

    I emailed support. Pixel is fine on every other wifi network I've tried. 2.4 and 5 ghz. All my other devices are fine on the Eero network. So I'm not sure if it's Pixel XL or Eero at this point. 

    • Richard1864
    • 7 yrs ago
    • Reported - view

    It's a known Pixel and Pixel XL wifi card issue (Pixel/Pixel XL internal hardware). It actually has nothing to do with Eero, but may actually be a large batch of defective wifi radios used In the Pixels themselves. Google is working on a patch, but it's not known when it will be released. 

    • RedRed
    • 7 yrs ago
    • Reported - view

    I guess it's possible. It makes sense. But the same Pixel phone works with Apple Airport on the same network. Works on every single other network. The Eero is the only one I can't stay connected to. I guess I'll just leave the Airport in place for a while just for the Pixel.

    • eyeks
    • 7 yrs ago
    • Reported - view

    I have the NDE63V on my Pixel XL eero at 2.0.0 (@susandennis: Settings > About Phone (bottom) > Build number (bottom) ;-)

    No problem connecting to any of my eeros...  

    although Speed test on app after upgrade reports 0.1Mb/10Mbps when it is actually 218Mbps/12Mbps (https://www.dslreports.com/speedtest/6374342)

    • retired and good at it
    • susandennis
    • 7 yrs ago
    • Reported - view

    Thanks, @eyeks - found it! 

    • wonhyuk1
    • 6 yrs ago
    • Reported - view

    Hello, seems that i'm now experiencing issues described here. 

    I have a Pixel XL running Build number; NHG47Q

    I get "Authorization Problem" at home connecting to my eero network wifi. All my other devices have no problem connecting.

    At work, my Pixel has no problem connecting to the office wifi. 

    Anyone else still experiencing this problem? Or anyone find a definitive answer to this issue? 

Content aside

  • 6 yrs agoLast active
  • 12Replies
  • 1338Views
  • 8 Following