12

eero / iOS Random Disconnects Still Occurring

Starting a new thread to re-summarize the situation:

3 eero Pros (not Eero Pro 6), all on eeroOS 6.3.1, in a 1450 sq ft condo
6 Apple devices all on iOS/iPadOS 14.5.1
Private Address off or on does not seem to matter
4 of the devices are mounted on arms and do not move (so they are presumably not moving between APs)
DNS on eero set to 1.1.1.1 / 1.0.0.1

Problem: Devices are randomly disconnected from eero WiFi. When this happens, the device does not automatically reconnect and must be manually reconnected. Other side effects are that the Private Address option may toggle from off to on and that the WiFi password may be forgotten on the device. One older device (iPad 2 running iOS 9.3.5) has NO issues. Other devices (not using iOS/iPadOS) have NO issues as far as I am aware.

At this point I think there are issues in both eeroOS and iOS/iPadOS -- and that means that we really need eero and Apple to talk to each other and work out the source of the problem and get it fixed. I've done all of the troubleshooting I plan to do at this point -- now I am just reconnecting devices as they disconnect and grumbling as I do so.

Please, eero -- get with Apple and figure out what the hell is going on. Surely between the two of you, you can reproduce this issue and figure out the actual cause. If a device knows the SSID and password for the WiFi network, there really is NO excuse for it to become disconnected.

125 replies

    • Ashok
    • 1 yr ago
    • Reported - view

    This is also happening to me exactly as it is with others. Any fixes or updates?

      • Ashok
      • 1 yr ago
      • Reported - view

      clayj Thanks. So I turned off both "client steering" and "thread" in the EERO app and it seems to have resolved my iPhone dropping issue, it's been a day so far, but I'm sure as soon as I post this the problem will return? But for now, it seems to be working.

    • hwrite
    • 1 yr ago
    • Reported - view

    I have an Apple household.   Multiple Appsle Products including iPads and iPhone, and 3 x Apple TV' 4's .  I have run with a Eero mesh for well, since Eero started and started having these issues about a year ago.  Currently I am lucky to be able to watch 30 mins of a program (on lowest video settings) before it drops.  It generally drops out at least 6 time in a 45 min program and sometimes drops every 5 minutes.  My iPhone and iPad similarly drop the connection constantly.  My Mac doesn't seem to have a problem (at least not at the moment).  My problems really began upgrading to Eero Pro  - that was a bad move. I've tried all the fixes here and nothing works so have come to the conclusion that others have here.  Eero is an expensive piece of junk if you have Apple products.   Apple and Amazon seem unable to play in the sandpit nicely so I am going to have to right of $$'s of dollars and bite the bullet and buy new mesh wifi.  Very disappointed in both Apply and Eero that they continue to ignore this issue.  

    • David_G_Kerr
    • 1 yr ago
    • Reported - view

    No doesn't disconnect but I get buffering every so often sometimes two to three times but most likely a engineer who doesn't realize that his actions are interrupting someone's viewing pleasure and should wait till the viewer is having his lunch or has gone out.

    • Riccahet
    • 8 mths ago
    • Reported - view

    I can confirm there is a problem with iPad causing the issue. 
    I have 

    iPhone 12 Pro max

    ipad pro

    3 eero pro 6 mesh network in 3500sq ft home

     

    i constantly have to reenter my WiFi password on my iPhone. Happened when I leave my house and come home. Will not automatically connect. This only happens if my iPad is turned on, sitting in my house. When I turn off my iPad. No problems. Phone connects automatically every time I walk in my house.
    I will keep the iPad off for weeks at a time and there is not one single issue. Once I turn on my iPad. The problem starts again and lasts as long as I have my iPad on. Turn it off. The problem goes away. 
    unless you have an exact fix right now, please don’t ask me to jump through hoops of doing different connections in disconnections and turning on things, and turning off things that apparently isn’t working with everybody else, and I followed the entire thread and done all the suggestions and everybody’s responses without success, so maybe the best answer to give us is “we will talk to our support team and communicate with Apple and figure something out “come on

    sorry just very frustrated. 

    • Sonso
    • 8 mths ago
    • Reported - view

    I have this same problem with devices from multiple manufacturers.  Eero support offered no solution.  In fact, the tech said something about my internet speed, which is completely unrelated to devices falling off the network.  Software time-outs prevent things like Sonos from indexing a NAS drive, my printer being accessible, and my Dropcams from being accessed.  It's unbelievable; using v6.15.2-99 with Eero 6+.  Absolute garbage.

    • KevW64
    • 8 mths ago
    • Reported - view

    I have the same problem but just affects iPhone 12 Pro Max and iPhone X - and only happened for past two months. When I return to the house, I notice my phone is using 5G and not Wifi. I have to turn the phone's Wifi off and on and then it works fine. Latest EERO software version (v6.15.3-12) and latest iPhone SW version (IOS 16.6).  2 EERO 6s in a 4 bed detached house, about 40 feet away from each other (one downstairs, one upstairs)

      • Sonso
      • 8 mths ago
      • Reported - view

       I just ended up going back to my old router, and putting the Eero system in bridge mode, so that it acts only as an extender.  I still have some lag issues, but things are working better with the devices (including being able to add Chromecast and Google Nest cams back into the network).

      • KevW64
      • 8 mths ago
      • Reported - view

       I have no problems with speed or connectivity with any other devices, just the two iPhones - running on a 900Mb internet link, so speed not an issue (getting 240Mb on the phones)

      • David_G_Kerr
      • 8 mths ago
      • Reported - view

      That is strange as I have a iphone 13 Pro Max and I am having no problems at all.

    • Bunless
    • 7 mths ago
    • Reported - view

    Same basic issue just started for me. 2nd eero pro 6e is 35' away from the main eero pro 6e. Internet works on all devices connected to the 2nd eero BUT the family iPhones (12 pro max @ 2, 13 pro max @ 2) which are all updated to the latest iOS 16.6 do not have internet. I reset the eero network, removed and replaced the 2nd eero, reset the network settings on my phone, turned off the wi-fi calling option... with no luck. 

     

    EERO staff, please fix

      • David_G_Kerr
      • 7 mths ago
      • Reported - view

       That is strange as I myself have a iPhone 13 Pro Max and my mobile has internet as well as my iPad and another older iPad so I just don't know what is going on but maybe if the second eero was driven off the first one via a switcher then maybe that might make things work.

    • Homekit_dreamer
    • 7 mths ago
    • Reported - view

    I have the same issue and it happens that my Apple devices forget Wi-Fi’s password, so I have to type it again. It is easy on iPhone but on HomePods it means I have to reset them every time… it is so annoying!
     

    I will have to sell my eeros and buy another mesh!

      • David_G_Kerr
      • 7 mths ago
      • Reported - view

       That is very strange as it doesn't happen to me, as I have a switcher plugged into my eero and other units connect into it the only thing that gets forgotten after an update is my BROTHER HL3150CDW LASER printer.

      • andypbui
      • 6 mths ago
      • Reported - view

       Same issue with you.  Both iPhone 12 Pro Max and iphone 15 Pro Max.  I have to forget/delete the WIFI SSID and reconnect every day.  It's very annoying.

      • David_G_Kerr
      • 6 mths ago
      • Reported - view

      @homekit_dreamerPhone  Have you got the latest firmware on your phone iOS17.0.1 should solve any bugs on your phone and clear problems with your phone but as you say it keeps dropping the connection is it something to do with the WIFI key which should be left at 8 characters other than that I don't know as I am not having any problems with it at all.

      • andypbui
      • 6 mths ago
      • Reported - view

       Yes, I'm on 17.0.2.  I always upgrade/update to the latest whenever it's out.

      • David_G_Kerr
      • 6 mths ago
      • Reported - view

       strange as I don't seem to have this problem maybe I have everything am using connected via a Ethernet connection and only some items like my iPad,iPhone,mums iPad and ROKU connected wirelessly

      • andypbui
      • 6 mths ago
      • Reported - view

       The weird thing is that the iPhone Pro 11 is fine.

      • andypbui
      • 6 mths ago
      • Reported - view

       also, all the iPads are fine.

      • David_G_Kerr
      • 6 mths ago
      • Reported - view

      There must be a difference between your iPhone 11 and current iPhones and iPads that would cause a strange disconnect every so often.

      • andypbui
      • 6 mths ago
      • Reported - view

       

       

      Same problem with two of my iphones 15 pro max.  I have to remove the saved wifi profile then reconnect every day.  There must something wrong with eero pro 6.  I've updated both to the latest firmware version.

    • Homekit_dreamer
    • 6 mths ago
    • Reported - view

    Hello guys it looks like I solved this issue disabling the HomeKit option in eero’s app settings!

    I had no more disconnection since!

      • andypbui
      • 6 mths ago
      • Reported - view

       : I did not have Homekit setup though.

    • Bunless
    • 6 mths ago
    • Reported - view

    Happy to report that my network is up and running. (3) 22' Pro 6E points. After a month I plugged the living eero back in and updated it. Now all devices work and some of the iphones are running ios 17. It's been a week, so far so good. 

      • David_G_Kerr
      • 6 mths ago
      • Reported - view

       thank goodness for that things just falling into place 

Content aside

  • 12 Likes
  • 6 mths agoLast active
  • 125Replies
  • 8609Views
  • 47 Following