0

Alexa / Echo multi-room music grouping

I am using Eeros for the first time.  I have 9 different Alexa Echo devices and when I used my old Apple routers I had them all hooked up via the Alexa app to play on an "Everywhere" multi-room music group. I could listen to music through the whole house.  I hooked up Eeros and got all of my echos on the "one network" but some are connected via 2.4 and some via 5.0 Ghz.  The echos have also connected to different eeros bases.  Does anyone know why multi-room music group can't connect them all?  Is the issue the 2.4 vs 5.0 ghz?  Is it that they are linking to different eeros bases?  All three of my eeros bases are plugged into the router via ethernet cables.  Is that the issue?  I have spent hours trying to fix this.

 

Thanks.

13replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Did you join them to your main network or your guest network?

    Like
  • I didn't create a guest network.  Would that help?

    Like
    • MagnetVox No, if you had connected to them the guest network, then I was going to say that was probably the source of the problem. But since that isn’t the case, I’m not sure. I don’t use Echo devices myself, but I use multiple Sonos speakers in my home without issue. I doubt this problem is directly caused by eero, but I’d recommend reaching out to their support to see if they can help you troubleshoot and figure out what might be causing the issue.

      I’m guessing the issue has something to do with you having all the eeros connected to your router, but eero support should be able to help you narrow that down.

      Like
  • Have the same problem.

     

    https://www.reddit.com/r/amazonecho/comments/hnjaem/multiple_speaker_or_speaker_group_not_working/?utm_source=share&utm_medium=ios_app&utm_name=iossmf
     

    a few weeks ago, I started to have trouble with multi room speaker group w Echo speakers. I thought it was just a glitch and didn’t think much of it. And it never worked since then.

     

     Today, I was tinkering around, and found that there was something strange when you create a new Multi speaker group in Alexa app. I could only select the Echos that are connected to the same Eero station.

     

    i am guessing this has to do something with audio sync issue. But effectively, Eero’s mesh router and Echo/Alexa app broke Multiple room speaker feature!
     

    Like
  • I'm having the same issue. Set up my two eeros last night and speaker groups are broken. Can't even re-pair my two Echos and Echo Sub that were set up in a stereo pair.

    Like
  • I am having the same issue. All 3 of my Eeros are updated. I have 4 Echos (two dots and 2 shows, all are 3rd gen). I have 2 Echo devices connecting to the same eero, while the other 2 are each one connected to a different eero. All of them are connected to 5Ghz. The “all house” or “different floors” option on Alexa App won’t work. I would love to know if this is something that Eero is planning to fix. 

    Like
  • Has anyone figured this out yet?  Same problem . . . 

    Like
      • Js_pace
      • Js_pace
      • 2 mths ago
      • Reported - view

      Js_pace Putting the eeros in bridge mode fixed this issue.  Settings -> Advanced ->DHCP & NAT

      Like
      • jimjimmer
      • jimjimmer
      • 2 mths ago
      • Reported - view

      Js_pace yeah be careful with this, tried it, eero went to reboot and bricked. Had to hard reset and re link everything. Wouldn't recommend 

      Like
      • Js_pace
      • Js_pace
      • 2 mths ago
      • Reported - view

      jimjimmer Good to know.  Mine rebooted ok and everything is working (multi-room music included).  I don't like that I am losing the eero functionality though.  

      Like
      • Js_pace
      • Js_pace
      • 3 wk ago
      • Reported - view

      Js_pace Circling back on this. I have ended up taking the eeros off of bridge mode and rebooting the system. It has been mostly working. It seems that Amazon music works most consistently. Radio.com works some of the time. I rarely get Spotify to stream multi-room consistently. It seems to be getting progressively better across all of the platforms. I'm not sure if the various apps are updating, the eeros are updating to help, or some combination of the two. Regardless, most of the time, I can get one of the services to stream multi-room.

      Like
  • All of my echo devices work fine on the everywhere group. In fact it works better on eero than my old router and extender setup. 
     

    IIRC I had a issues switching them over to the new eero network and ended up factory resetting each echo. It’s worked flawlessly since then. 

    Like
  • This worked for me.  I power-cycled all my echo devices, then rebooted the eero (did not put in bridge mode). 

    Everything worked as it should after that. 

    As always, YMMV

    Like
Like Follow
  • 3 wk agoLast active
  • 13Replies
  • 269Views
  • 11 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com