A year of stability but now I'm really struggling with Eero

Hi all

I'm pretty much lost for ideas now, maybe someone can help.

My router is a Draytek 2860, and I have 6 Eero Pros (Gen 2) in my house, with the network set to Bridged mode so that my router does the DHCP, which is what I want.

About a month ago I noticed an occasional issue where my laptop wouldn't get an IP address. It would connect to the Eero network but wouldn't get an IP address. I restarted the Eero network, and the laptop etc. and normally the problem would go away for a while.

The last few days, the problem has become huge, affecting many more devices, from Harmony Hubs to iOS to MacBooks. The symptoms seem to be the same - connection to the network but unable to get an IP address.

On my MacBook, when it's in this state, I can go into the network settings and TCP/IP and click on "Renew Lease". This instantly gives me my laptop its correct assigned IP address from the router. However, this only lasts a few seconds, before it seems to lose this IP address. I can click again to get it back, but a few moments later it has gone.

In the same location right now, my other MacBook doesn't have the issue, yet it's right next to it. Yesterday both had the issue, so it's random.

Harmony Hubs switch from red to green to red to green occasionally during the day, indicating the same problem.

My Sonos controllers started disappearing, and I reset all of them, now I can't get any of them to join my Eero network.

I've deleted and recreated my Eero network, doing a factory reset on each one. I've restarted the network countless times. I've restarted my router a few times, both through the admin page, and via a power reset. Powered off/on network switches (I just have unmanaged ones).

Thing is, this was working really well for a year. But now it's completely stopped working.

My house is wired for Ethernet, so the Eeros are connected via a wired connection. So typically in a room I have an ethernet outlet going into an unmanaged switch which then feeds various devices (Apple TVs, desktop PCs for example), and also the Eero for that location. All wired devices are functioning perfectly. None of them lose their IP addresses in this way, they are rock solid. But it seems that all wireless devices that get their IP address via the Eero in bridge mode are now malfunctioning.

I've replaced my gateway Eero with a new one that I hadn't used, it made no difference.

All I can think of is one of the Eero updates might have broken something? Nothing else has changed on my router, I've not touched the firmware for a year.


40replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • The other thing that I'm finding really odd is right now is that I just found that if I change the IP address assigned to my laptop, in my Draytek router, and then reboot the Draytek router, the laptop is *still* being assigned the old IP address.

    Is there some kind of caching going on by the Eero network?

  • So a little update; last night I swapped out all my Eeros for a set of DrayTek's own wireless access points (WAP902, centrally managed from my DrayTek router), and this seems to have solved my problem. There is now no longer any issue with devices keeping their IP addresses. I changed no settings in my DrayTek router.

    It's only been a day , so I'm not 100% sure yet, but it would appear that the issue must be with the Eero system?

    I'd appreciate if someone close to the Eero tech/dev team could comment on the possibility that one of the recent updates might have caused this issue in bridge mode?

    I'm really disappointed, as I had a perfectly stable network.

  • I'm in the same boat.  As of a few days ago it appears the eero's have stopped forwarding DHCP requests correctly.  I've had to unplug my 5 eero network running bridged and gone back to Asus access points.  I may look at Asus new mesh software since I already have the access points.  I use a Netscreen firewall as my firewall/DHCP server/NAT box.  I opened a ticket with eero, no reply yet, but it's only been 18 hours or so since I opened the ticket.

  • So it seems like they must have changed something in a recent update?

    Pretty poor really. I’ve lost all trust in them now.


    i really dislike companies who enforce updates like this. I experienced something similar with a Harmony Hub earlier in the year; they screwed with something that had been working fine and a bunch of folk suddenly couldn’t control their TVs with it any more hehe.

  • Yes, it's my theory that they pushed an update within the last week.  I've not noticed if there is anyplace that tells me the date of their releases.  But my system has been working fine for 1.5 years at least.  Then I got a new device and it couldn't get an IP address via DHCP.  I checked everything else first since eero has been so reliable, but in the end wired connections were working fine.  So I unplugged the eeros, installed APs and everything is working again.  I only have a single eero connected via ethernet.  The rest were wireless mesh.  The single connected to ethernet may work, I haven't confirmed that.  But the 4 that were pure wireless sure didn't.

    I had my DHCP set to expire leases in 3 days, so there is a window in there where an update could have occurred but since no one needed a new IP address I didn't notice.

  • Well I had six and all were wired, so if we are talking about the same problem then wired or wireless maybe isn’t a factor.

    i found it was quite a random problem where some devices seemed relatively unaffected others more so. It almost felt like there was only a limited IP pool to give out (I even double checked my router in case I’d done something stupid). Eg I could click on Renew Lease for my MacBook and it would get an IP address then lose it a few seconds later - as if another device had pushed me off.

  • Interesting.  I'll plug some back in perhaps tomorrow and put a sniffer on the DHCP server and see what kind of traffic if any I'm getting.  I'll also try the wired one to see if we're having the same issue.  

  • Hi, oviano – thanks so much for taking the time to share your experience with us. I'm sorry to hear you've been having such a hard time of it with your network, but I definitely appreciate your detailed overview here. Based on everything you've said, this is definitely something that shouldn't be happening, and we'd like to look into things with you. If you could kindly send us an email to support@eero.com , we'll do what we can to get to the bottom of this. Include "Community" and my name somewhere in the subject line, and I'll make sure it finds its way to our senior specialists!

    William Misko I see that you've already emailed us about this as well, I'll make sure that we have someone reach back out to you ASAP to gather more information so we can work with you and get to the bottom of this.

    Thanks both of you for sharing your experiences, and welcome to our Community Forums!

    Drew, eero Community Team

  • Ok. I will plug one back in over the weekend, reset it with a different SSID and once I've reproduced it again I will get in touch with support.

    Given the stability I seem to now have with DrayTek's product I'm unlikely to revert to Eero, but I'm willing to help get to the bottom of the problem for the benefit of others.

  • Same issue for me.  I use a Netgear router.  If I reserve an IP address for the MAC id of the device, then it will always get an IP, for what it is worth.

    Hopefully now that Eero has 2 reports of this on their support email system, they will be able to fix it.  It clearly is a regression in a recent firmware.



    Like 1
  • Yes well, here I am 46 hours after sending a network down message to support and I've still had no contact other than the one above from someone saying they would have someone contact me ASAP.  I was a huge eero supporter, backing them since kickstarter I believe, but this is leaving me with a sour taste in my mouth.  If I had not had some old APs laying around I'd really be livid.

    Like 1
  • I'm not sure what your root cause is, but I've found my Gateway Eero device requires a reboot every morning.  I've got a business FIOS drop, one public IP on the Eero and one for work, connected to my Sonciwall firewall.  The Sonicwall shows no outages over the same time period that I've needed to reboot the Eero.  The good news is that after a reboot internet stays up on the wireless system until the next day when it happens all over again.  

  • Regretfully I’ve not had the time to set up the eero network again, and contact support, what with a busy family, kids etc.

    Hopefully the detailed information i have provided in this thread is useful to the developers.

    i do have another Eero network at a holiday home which I will visit in December so I trust if it is a widespread issue that it will have been solved by then.

    I’ve had zero problems since swapping out my Eeros for the DrayTek ones so I’m afraid the Eeros here are likely to go into eBay.

    It’s a shame as it was great for a year but I work from home a lot so having to spend days trying to solve an issue like this I’m afraid I simply do not have time for.

  • I plugged mine back in and eero rolled me back to the previous release.  All I was told is engineering is looking into the regression on my issue.

  • I do not have the exact same problem but I too have had issues since the newest update. I had a stable eero setup for 2 years. Last week, speed issues being throttled to 50Mbps (down from 800+). I spend a long time on the phone with eero support and they were not able to solve the problem. I have since deleted the eero network and rebuilt it with same results. As posted elsewhere, I have taken other variables out of equation. I bought new switches and cat6a cables which did not fix the problem. If I disable the eero and connect directly to the AT&T modem, I'm back to full speed on gigabit.

    Like 1
      • kmont1234
      • kmont1234
      • 2 yrs ago
      • Reported - view

      t2clej This is exactly what happened to me. Since last Saturday, November 10th, my Eero app has been showing me around 45 down, 300 up on AT&T Gigabit fiber. Speed tests from my devices have shown me the same results, even hard wiring into the main Eero. I just factory reset my AT&T 5268AC gateway hoping that would solve it, but still a problem. Another problem I'm noticing is with AT&T WiFi calling on iPhones and iPads connected to my network. If I get a call, the other person only hears me for the first few seconds and then it goes out. 

      Hardwiring to my AT&T Gateway gives me my full speeds (around 800 down/up). I don't know what happened, but will be contacting Eero Sunday. 

  • I have had my 5 eero gen 2 system for 2 weeks now. I am experiencing the same problems that you guys are having. This thread doesn't give me a lot of reassurance. I might have to return all of mine back to Best Buy. I really don't know what else to go to. This system would be so great if it didn't keep having to be reset. I will not continue to have to reset my eero routers over and over again to get an IP address.

  • Open a support ticket.  They got me some test software which fixed my DHCP regression issue.

    Like 1
  • I'm having the same issues.  My eero setup has been perfect for almost 2 years.  

    Now, there is some software change and BOOM, it can't hold a connection.

    I can see from the WAN router logs (on the AT&T device) that the eero is basically dropping/bringing up the connection every 4 minutes.  There is a delay everytime that happens.

    I've opened a support case (and reset everything), no luck.

    • Thanks for reaching out catmandad and sorry to hear you're having some trouble! I was able to find your ticket, and I'll be following up with you to gather a little more information!

      Drew, eero Community Team

  • OK, so this looks like it might have been caused by a firmware update to the AT&T Fiber PACE router.  A lot of complaints about the 11.x update in the past week (about the DMZ+ support).

    I've temporarily moved eero to just a standard Double-NAT scenario (not ideal, but I need the wireless coverage, and I don't want bridge mode).

    I've requested a different router from AT&T and we will see if that resolves this issue.

  • Having very similar issues.

    I have a SonicWALL router that also serves as DHCP server. A 24 port switch connected to the SonicWALL connects all local network devices (some to devices directly, others to smaller switches which in turn connect to multiple devices). Multiple Eeros (all connected via Ethernet to that switch, except for one Beacon which is obviously connected wirelessly) in Bridge mode. Devices connected by Ethernet all work fine getting their IP addresses (in the 192.168.0.x range) from the SonicWALL. Devices on WiFi sometimes can connect and sometimes can't, many try to get IP addresses but never do. And this happens with all sorts of devices, Android phones, iOS devices, Windows machines, so not tied to a specific client type.

    To try figure out what is happening I did a packet capture session on the SonicWALL. When wireless devices fail to obtain an IP address I am seeing the DHCP DISCOVER packet from the device, and SonicWALL responds with a DHCP OFFER packet containing a valid available IP address. But I never see the responding DHCP REQUEST packet come back from the client which then keeps trying to DISCOVER and then eventually times out with an error. What I can't tell is exactly where in the process it is failing. As I can't packet trace on Eero I can't determine if the DHCP OFFER is never being passed by Eero on to the client, or if it is indeed being passed and accepted and it is the response DHCP REQUEST that is never being sent back to the SonicWALL. Regardless, this is definitely why some devices don't get their IP addresses, the situation is consistently reproducible, and only on when requested via Eero. Plug a failing device into an Ethernet connection straight to the SonicWALL and it immidiatley works. So this is not a SonicWALL issue, it is definitely an Eero one.

    Eero support asked me to turn off Bridge Mode, which I have done. Now all devices are getting IP addresses (from Eero in the 192.168.7.x range, not the SonicWALL). So a bit better.

    But, I am in a Double NAT configuration which is creating difficulties getting to some devices. To address this I moved some of them from connecting to the SonicWALL to connecting via the Eero's Ethernet port so that they'd be on the same network (192.168.7.x instead of 192.168.0.x). But, nope, while devices connected to Eero via wireless all seem to be connecting properly and getting Eero assigned IP addresses, those connecting via Ethernet are often getting no IP addresses at all.

    I have replaced cables and switches just to be sure (although I know they are not the issue as they worked until I turned off Bridge mode).

    I have had Eeros for a long time, but I close to tossing them out. Especially as Eero support has been rather useless, 5+ days response times and no real direction or suggestions.

    --- Ben

      • BenForta
      • BenForta
      • 2 yrs ago
      • Reported - view

      One detail to add. With the Eeros no longer in bridge mode as noted previously, the Eero seems to not even detect wired devices. I have a Sonos Bridge plugged into an Eero Ethernet port. When I look in the Eero app for devices connected to this Eero it doesn't even report the Sonos Bridge as there, even though Ethernet port lights on the Sonos show activity. Wireless connected devices are all listed, wired not.

  • Ben

    They should be able to simply revert the firmware to the version before they broke it.

    They offered to do this at the location I was having the issue but it was too late as I’d already got rid of the system.

    At a second location which was offline at the time they rolled out the broken update they were able to prevent it upgrading when I arrived and turned it on and I’ve not had the issue at that location.

    What a way to ruin a perfectly good product though!

  • Hi everyone,

    I believe, since last update, the Eero has a poor performance. I have to reboot every once or twice per day. Almost 1 year without any problem. Last month or so, the experience is horrible.

    Network is working, but no internet or a fast connection. Correct the bugs, update fast or my next gadget will be Google Wifi.


    • Hi, filipembarreto – Thanks for taking the time to reach out, and I'm sorry to hear about your recent instability and frustration with eero. If you can provide some more specifics about what you're seeing, then myself and the rest of the Community would be more than happy to offer some guidance and advise you on the next steps to take.

      For the most thorough and effective resolution to your issue, however, I definitely encourage you to send a detailed email account of the issues you've been seeing to support@eero.com or to give us a call at 877-659-2347 between 7am-5pm Pacific so that one of our agents can help go through things with you directly. We definitely don't want your eeros to be a source of frustration, and we look forward to hearing from you further to get this taken care of!

      Drew, eero Community Team

  • did this get solved?

  • II have no ide if this was solved or not. All I heard was they’d stopped my holiday home network from being upgraded and that worked fine when I was there last month.

    i have no idea if I plugged back in my Eeros at my main residence whether it would work or not as I haven’t been informed.

  • Try plugging some back in perhaps tomorrow and putting a sniffer on the DHCP server then see what kind of traffic you are getting.

    run 3

Like3 Follow
  • 1 mth agoLast active
  • 40Replies
  • 4943Views
  • 22 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support