I am having issues with ssh (or scp) between OSX devices, only on my eero network

I have three macbook pro devices.  2008 model on 10.11.6, 2015 on 10.13.6, and new 2019 on 10.14.6.

While trying to setup the newest device I wanted to scp files from the 2015 to the 2019.  But I couldn't get scp or ssh to work on my home eero network not mater what I tried.

So I tried at work and they connect just fine.

More testing on home network finds that this seems to be an eero issue.  I have a second network at home (independent network with it's own external WAN IP).  It's on a zyxel router and connecting to that device works fine.  I can ssh between any of these devices.

Once I return them to the eero network they start failing again.

I also find they can't ping each other.

Each Mac can see the rest of my network.  I have several Raspberry Pi devices.  Each can be seen, each can be pinged and I can ssh to any of them from any of my OSX macbooks.  I can even ssh from one mac to the other if I go through any of the pi devices.   SSH to PI and then SSH any of the other macs.   No problem.  I can also ping the macbooks from any of the pi devices.

So for some reason my eero network is causing issues for peer to peer connections between OSX devices specifically. 

I can ssh from any pi to any other pi as well.  So it is a OSX specific issue.  

Actually it seems to be an apple specific issue.  Because I have a terminal app on my iphone which lets me ssh.  I can ssh into any pi, but once again I can NOT ssh into my macbooks from my iphone.

I have heard about issues with Apple devices on eero network but they mostly involve issues with connecting to a closer (stronger signal) eero or loss of connection when you roam.  I have this issue as well with my iphones, macbooks and ipads.   But a simple wifi off/wifi on fixes this issue.  I can't find a solution to fix my ability to ssh (or more specifically scp) from one macbook to another on an eero network.

Has anyone else experienced this issue?

Is there a solution?

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • That’s a pretty strange issue. I just checked and I have no issue with pinging or SSH between macOS and/or iOS devices on my eero network.

    Like 1
      • ron_g
      • ron_g
      • 6 mths ago
      • Reported - view

      cMoo92 Isn't it strange.  I have contacted support.  No response yet.  I also reached out to folks over on reddit r/eero and an eero dev there helped me debug a bit.  She acknowledges that there is a layer in the system keeping track of what devices can communicate with the network in order to provide the profile support they have.  She suggested perhaps there is a bug at that layer or something similar.  So not as strange as it initially seems.

      I had a moment where the ssh started working again yesterday.  No changes made it just started working.  Then hours later I tried again and the problem is back.  I can join several other non-eero networks I have access to and the problem goes away so I am pretty sure the issue isn't with the machines themselves.

      • ron_g
      • ron_g
      • 6 mths ago
      • Reported - view

      cMoo92 Forgot to say thanks for testing that for me.  I was wondering if it worked for anyone else.  Good to know it can work.  Do you have Gen 1 or Gen 2 eero?  I have the older Gen1 system so wondering if that is a factor.

    • ron_g my gateway eero is a gen 2, but I also have one beacon and two gen 1 units. One “disclaimer” is that I am part of the beta program, so I’m running a different eero OS version than you would be (unless you’re also in the beta). So it’s technically possibly the issue you’re experiencing isn’t present in the current beta.

  • Hi there, did you solve your problem. Same issue here.

      • ron_g
      • ron_g
      • 4 wk ago
      • Reported - view

      miwi unfortunately no never solved. It was a short term need for me so I just double natted and old router and connected the two macs to that network while I transferred files between them. Eero support was not able to solve or understand what was happening. On reddit an eero developer explained that it could be a bug in the software that is there to provide the profile features they have on eero network. She mentioned that layer has code that determines what devices are allowed to talk to each other. I don’t use profiles but you can’t turn them off so even when not using them the code is still processing. I would suggest you contact support so they get more reports about this issue. Here is the thread on the topic of you want to read through it. https://www.reddit.com/r/eero/comments/cob4aj/i_cant_ssh_from_one_macbook_to_another_but_can/

  • Hi ron. Thanks for the quick reply. I’ll contact to see if they have a solution now. Just activated my old airport and I immediately got my macs connected. 

Like Follow
  • 4 wk agoLast active
  • 7Replies
  • 76Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support