EERO not accepting connections...

Is anyone else experiencing devices being dropped and can no longer connect? The ethernet port works fine to access the internet, but wifi isn't at all. I've tried a variety of Apple devices, Microsoft PC, Alexa and a HP printer. Nothing will connect anymore.

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I created an account just to reply to this thread. I had this happen to me 3 days ago.  My devices connected via wireless started dropping one by one until none of them can connect. I have IOS, macOS, Linux, and Switch devices in my network. Ethernet is fine.

    I called Eero Support and spent an hour troubleshooting. We exhausted all troubleshooting steps and none worked. They escalated my case and have yet to get back to me.

    While waiting, I've been testing my devices and have been able to connect inconsistently/randomly. Some devices take a few attempts before they can connect, while others take up to an hour of trying. Also, when a device sleeps for a long period of time (i.e. overnight), it gets disconnected and I have to go through repeated attempts to connect again.

    1. My initial thought was the IOS Private Address setting might be confusing the Eero causing it to drop connections, but I have several IOS devices on different IOS versions (therefore some not having private address settings) and all of them are having the same issue.

    2. Next, I looked at the Eero Labs features as there might have been updates that had bugs. I use Band Steering and WPA3, so I disabled both but the issue persisted. Support also tried turning on Local DNS Caching, to no avail.

    3. Some people have suggested that Eero might have issues with assigning IP addresses (DHCP) and that might be the culprit. According to the person I spoke with, this happened years ago and was supposed to be fixed. I haven't tried manually assigning IP addresses yet as I need some of my devices to be online because of work and I can't risk getting disconnected and not being able to connect again. If someone can test this, please share your findings.

    4. Another weird thing was Support told me they see a Smart Light that might be causing the issue, but I don't own any IOT or smart home devices and I've never seen an unknown device connect to my network. This is a bit worrying to be honest. Someone suggested I might have assigned a device as a light in the device profile, but I meticulously review my list regularly and ensure all my devices are assigned the correct type.

  • Hello,

    I wanted to check in with you to see if you were still having issues with your devices connecting to your eero network. Some tests you can perform are to forget the eero network and then try and rejoin the network, restart your eero network, and check for updates on your devices for their WiFi card.

    Thank you,


    eero Support

      • ham
      • ham
      • 3 mths ago
      • Reported - view

      Hi James . Unfortunately none of those steps work. I've also gone through them as part of the troubleshooting I did with Eero Support on the phone. As of today, I am somewhat able to connect my devices inconsistently, but it takes a lot of attempts to get through. This is still unacceptable as once a device disconnects temporarily (sleep, hibernate, restart, etc.), it takes a while again to be able to re-connect to my network over wifi.

Like1 Follow
  • 3 mths agoLast active
  • 3Replies
  • 30Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support