2

Eero not working with Nintendo Switch

My Nintendo Switch will not work online with my new Eero.

When I connect to the network, all is good, but the test connection always fails even though it says it's connected.

I have tried all the troubleshooting (restart console, restart eero, turn off 5Ghz, reserve IP) what else can i try? Please help!

28 replies

    • Mikmo1111
    • 3 yrs ago
    • Reported - view

    I’ve been having this same issue for months and nothing worked. This morning I put my switch on the blocked list and then took it off hoping that might trick the system or whatever. Next time I turned on my switch it connected after a few minutes for the first time since maybe November. Hope this works for everyone else

      • txgunlover
      • 3 yrs ago
      • Reported - view

      dandesilest Nothing special.   IPV6 on... Spectrum's 950/40 service.

    • Team0
    • 2 yrs ago
    • Reported - view

    I was experiencing an issue where I could connect to the internet and the Nintendo store, but I couldn't do certain in-game activities that require an internet connection. The error code I would get is: 2618-0583 and the message was "Unable to connect to the other console(s). NAT traversal process has failed." At the time, my EeroOS was version 6.2.0. To resolve the issue, I did the following:

    1. Turn off Band Steering and WPA3 from Eero Labs (Eero app > Discover tab).

    2. Clear registered network on the Nintendo Switch (Home > System Settings > Internet > Internet Settings > [Your Registered Network] > Clear Settings).

    3. Re-register your network. It should be listed at the bottom of the list under Networks Found.

    Once I did this, everything was working again. Also, turning off WPA3 resolved other issues I was having with other devices where they could not connect to the internet at all. Such devices included an older '15 Vizio TV and a 2nd generation Apple TV. I spent months researching for a fix, but I couldn't find anything. Hopefully, this info helps someone else!

    • baharris18
    • 2 mths ago
    • Reported - view

    Was having this issue today and figured out the solution. On the switch I was getting an error that was complaining about a possible DNS error, but connecting games via online worked just fine. To fix this, I went into the eero settings>Newtork settings> DNS and set to "Custom DNS" and copied in the DNS setting for Google's public DNS:

    IPv4 Primary: 8.8.8.8

    IPv4 Secondary: 8.8.4.4

    IPv6 Primary: 2001:4860:4860:0:0:0:0:8888

    IPv6 Secondary: 2001:4860:4860:0:0:0:0:8844

    https://developers.google.com/speed/public-dns/docs/using

Content aside

  • 2 Likes
  • 2 mths agoLast active
  • 28Replies
  • 2503Views
  • 14 Following