2

Eero not working with Nintendo Switch

My Nintendo Switch will not work online with my new Eero.

When I connect to the network, all is good, but the test connection always fails even though it says it's connected.

I have tried all the troubleshooting (restart console, restart eero, turn off 5Ghz, reserve IP) what else can i try? Please help!

28 replies

    • Indianajns
    • 3 yrs ago
    • Reported - view

    Exact same issue I am having but with Xbox One.  Worked fine prior to update last week. Nothing I do solves the problem.  Going to ask a similar question on the board. 

    • rich4647
    • 3 yrs ago
    • Reported - view

    Also same problem.

    My Nintendo Switch connects and can do some online things.  (i.e Purchase a game) but can't update or download things.  some in game functionality doesn't work either.

     

    like dandesilest  said, it seems to connect okay, but a connection test on the Switch always fails.

     

    I am also having the same problem with my wife's e-reader.  She can purchase a new book through it, but cannot download it.  All other devices in the house seem to work fine.

    If I create a hotspot from my iPhone and connect these devices they work just fine (like they did with my old router last month).

    Indianajns  dandesilest   Did either of you find a solution?  

    • Indianajns
    • 3 yrs ago
    • Reported - view

    Ugh. Sorry you are having problems. My issue was resolved with the Nov 17th update. Check your update history to se if you have the most up to date system. Cheers. 

    • dandesilest
    • 3 yrs ago
    • Reported - view

    I still continue to have issue.  

    • rich4647
    • 3 yrs ago
    • Reported - view

    I have the update and issue remains as well...

     

    Indianajns would you mind doing dandesilest  and I a favor and tell us about your eero config.  If we are having the exact same problem, then maybe we are just a config setting away from having it resolved. 
    Are you doing any reservations or port forwarding for your switch?  Is UPNP enabled or disabled?  Did you override the default DNS?

    • smorin
    • 3 yrs ago
    • Reported - view

    Hey, I am having the same issue (Switch connecting like all is fine, but no or partial downloads and updates, and eShop working from time to time). Obviously, all of the Internet's wisdom in troubleshooting this kindly failed.

    I spent an hour on the phone with eero CS, to conclude that all was fine on the eero's side. I then spent an hour on the phone with Nintendo, to conclude that all was fine with the console, since it works just fine with my old router. 

    I am a bit in a dead end here and it is driving me nuts. Anyone has a hint on where the issue could be?

    • rich4647
    • 3 yrs ago
    • Reported - view

    Hey smorin

    Yeah, super frustrating.  I had to download a 4 GB update for a game over my phone hotspot last week.

    Here is what I know.  It's not only the Nintendo Switch.  My eReader has the exact same issue.

    I spent 2 hours on the phone Friday with eero support and we tried EVERYTHING and still couldn't get it to work.  

    The best I can figure is that something on the Eero is blocking this traffic, but no one seems to know what is causing it.

     

    That being said, after more than 10 hours total working on this I have given up.  I have asked to return the Eero and have already purchased an alternate router.

     

    I'm sad, because I was really enjoying everything the eero has to offer, but I need everything in my home to work.

      • Aly
      • 3 yrs ago
      • Reported - view

      Has there been a solution ? I just bought a eero set up and I have 4 Nintendo switches in my house not able to update or go in eshop :-/ 

      • rich4647
      • 3 yrs ago
      • Reported - view

      Aly No solution.  I am stuck in the same boat as smorin waiting for a label to return the items.  I have been waiting three weeks at this point and have pointed this out many times to eero support.  I was going to call today again to ask what could possibly justify someone waiting three weeks for an e-mail with a return label to print off.

      • Aly
      • 3 yrs ago
      • Reported - view

      rich4647  I ordered off Amazon. It is something with EERO for sure as I can set up my other router ( dlink ) with switch no problems.  I see some had this prob before months but it’s fixed I am sad. I just received them yesterday and love the performance but I need my switch’s to work :-/. And suggestions on a different mesh system ? 

      • rich4647
      • 3 yrs ago
      • Reported - view

      Aly I ordered through Eero and the return process is still crazy.
      I got the Linksys Velop mesh system as a replacement. 

      Their interface isn't as nice as Eero, but all my devices worked perfectly with the out-of-the-box configuration.

      • Aly
      • 3 yrs ago
      • Reported - view

      rich4647 thanx for the info. I ship mine back tomorrow !  Amazon return is easy thank goodness !   I was on the phone for a good hr with a guy named Eric he was awesome however this issue had him stumped ! I told them I was not the only one with the issue so hopefully in the further it’s better for other people!  He would have submitted a ticket but it could be a 3 week wait because they are behind..   He was a honest and nice guy to talk to !!  Sadly a return is happening for me..  hope this info will Help Others ! 

    • dandesilest
    • 3 yrs ago
    • Reported - view

    I got one reply from Eero and have screen shots of every error and no one has responded. I’m really disappointed that I cannot resolve this. 

    • smorin
    • 3 yrs ago
    • Reported - view

    Update: I spent a long time on the phone multiple times with support, I have reached the point where I just want to return it for reimbursement, but I am stuck, waiting for the return process to kick off with an email from the corresponding department, which is apparently very busy following black Friday. I hope this thread will help speeding things up for all of us, as we are at least a few with the same issue. Hang on in there!

    • R&D Manager
    • theflamingonion.1
    • 3 yrs ago
    • Reported - view

    Do you all have use the Secure + service?  I had to disable the features for my son's switch to work.

    • SausagePatty
    • 3 yrs ago
    • Reported - view

    I have had the same DNS error issue with my son’s new switch. Found the following YouTube video and followed DNS directions and it worked! https://youtu.be/8g24hfadWn4

    • dandesilest
    • 3 yrs ago
    • Reported - view

    i tried every suggestion in this video.  Nothing woks with my switch since using this eero router

    • rich4647
    • 3 yrs ago
    • Reported - view

    Yes, I tried multiple DNS services on the Switch and at the Router level.  None successful.
    Eero support also had me try a few changes around DNS that didn't work as well.

    • dandesilest
    • 3 yrs ago
    • Reported - view

    same here.  Eero suggested DNS changes for the router and nothing worked.

    • Hillman23
    • 3 yrs ago
    • Reported - view

    I have this exact same problem. I’m outside the return window to return my eero and I really don’t want to because it works great for everything else. But I’m having to run my switch on my phone hotspot which is frustrating. 

    • Lbjay
    • 3 yrs ago
    • Reported - view

    Also me. Hey, Eero! Wtf!

    I have a second random issue besides the switch: the Amazon prime video roku channel now no longer works. 
     

    has anyone tried setting the eero to bridge network mode? I read that solution somewhere but when I tried it suddenly none of my mesh nodes would talk to each other. 

    • smorin
    • 3 yrs ago
    • Reported - view

    Just hung up with eero for a second time today. This is seriously unacceptable; (very) long story short, they refuse to either refund or replace the unit because I am past the 30 days period (when the defect appeared after 2 months, following an update) and tell me that I have to deal with Amazon for a refund, since I bought from them. I did try the Amazon customer support, and they refused to proceed as well.

    Fun Fact: eero is an Amazon company. Good team work, guys.

    I am done spending energy on this issue, I am frustrated and very disappointed. I will give the reviews they deserve, every occasion I will have.

    Good luck, guys.

    • Mikmo1111
    • 3 yrs ago
    • Reported - view

    I’ve been having this same issue for months and nothing worked. This morning I put my switch on the blocked list and then took it off hoping that might trick the system or whatever. Next time I turned on my switch it connected after a few minutes for the first time since maybe November. Hope this works for everyone else

      • txgunlover
      • 3 yrs ago
      • Reported - view

      Mikmo1111 Both our Switches are working great.

      • dandesilest
      • 3 yrs ago
      • Reported - view

      txgunlover do you have specific settings for the router you could share to help us all out?

Content aside

  • 2 Likes
  • 5 mths agoLast active
  • 28Replies
  • 2788Views
  • 14 Following