eero Pro 6 upgrade - several devices not connecting

Hi – I just upgraded my network from a Linksys WRT1900 AC router plus an Engenius EAP600 to the eero Pro 6 3 pack.  The Linksys/Engenius core ran 2.4 and 5GHZ wireless fine and was reasonably fast but I upgraded for better security and speed. The transition was very smooth as I reused the same SSID and password.  I mapped my home using an Android app, Wi-Fi Strength Meter, and I appear to have solid coverage throughout.   My eero’s are running v6.0.2-11.  My network currently has about 40 – 50 devices online and active at any one time.  It also hosts a SmartThings Hub which connects about 50 – 75 sensors/devices via Zwave and Zigbee.

Right now, everything appears to be stable, but I have several devices that simply will not connect to the eero network.  I have tried band steering both on and off and have DNS Caching on.  I turned off the 5GHZ band and have enabled legacy mode to no avail.  I will keep playing with this but if anyone has any advice, it would be appreciated.

I have the eero app installed on both my Samsung Galaxy S9 and my iPad Air 2.  I like it on the iPad best as it just seems easier to use.  At one point, I removed the network password to try and connect my devices to an unsecured network – that worked.  When I went to re-enter the password via the Android app, the app would crash repeatedly, but I was able to re-enter the network password via the iPad app.  Finally, while doing this troubleshooting/re-booting/re-configuration I noticed both apps were showing my laptop and desktop as off-line when both were active on the network and accessing the internet.  Not sure why some devices are shown offline when they are in fact online and active.

Right now I’m having mixed feelings on whether I made a good choice in upgrading.  I plan to stick with this for a little while longer to see if I can connect/upgrade/replace those devices that won’t connect.  I also need focus closer on the eero apps as flaky or inaccurate information would be a show stopper.

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have had the same concern. Many of my devices are online, but are being shown as “offline” on the app.  

  • One of the devices that won't connect is a Garmin Index Scale, a legacy 2.4GHz device.  I can turn off the 5 Ghz band and it will connect, but that is NOT a long term solution.  Any suggestions would be appreciated. 

      • Ergolad
      • Ergolad
      • 2 mths ago
      • Reported - view

      KY_Tom I know that this is a little older post, but I have had an issue with my Garmin FR630 watch connecting over wifi since my Eero Pro system upgraded to 6.0. After months of communicating with Eero Support with no solution, the Reddit community helped me identify that Secure+, specifically Advanced Security, was preventing the Garmin from connecting. I have notified Eero of the issue. For the time being disabling Advanced Security allows my Garmin to connect. Don't know if that might help you?

Like Follow
  • 2 mths agoLast active
  • 3Replies
  • 283Views
  • 4 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support