4

No "internet" on guest network only?

I have a strange issue that does not allow internet on my guest network only.  It allows the device to connect, but the wireless status on the device says "no internet".  This is happening on many IOS devices, but I did not test on a Windows device.  Any device connected to my primary network works perfectly fine.  Any suggestions?

70replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi  johnt519

    Sorry to hear you are experiencing an issue with your Guest Network. If you haven't yet, please contact eero support so we can take a look. This isn't a known issue, so we definitely want to take a look and help get to the bottom of what is potentially going on.

    Feel free to give us a call at 1-877-659-2347 or email us at support@eero.com .

    Like
  • I've send in a message to support (under another email). Curious how you say it isn't a known issue - the 26 replies in this one post seems to indicate otherwise...

     

    Thanks.

    Like
  • johnt519 totally can see how that is a bit confusing :) Something that is a known issue would be a problem without any solution. To my knowledge, we have been able to resolve it through troubleshooting with support.

    With that said, if anyone here is still having this issue, please also contact support so that we can take a look and pass along any feedback and observations.

    Like
  • As is shown here, "resolving" by constantly resetting the router is not a solution.

    Like
  • johnt519 That wouldn't be considered a solution. That is just a troubleshooting step (resetting it once). If it doesn't resolve the issue, we would do further troubleshooting and then determine next steps and status of the reported issue.

    Like
  • Well I haven't reset my router yet, so as soon as someone from support gets my message, hopefully looking at the network will shed some light.

    Like
  • I've also run into no internet and DHCP periordic issues on the main network ever since the v2.3 firmware, I don't use a guest network. I've a number of times done the full power cycle and the soft reset and it works but then the problem always comes back up again. I'm hoping the new v3.0 firmware that just came out will be more stable.

    Like
  • I am having the exact same issue. Just realized it this morning as I was troubleshooting my robotic vacuum that I have using the guest wifi (don't want my IoT devices on my main network if I can help it). Tried my laptop and iPhone on the guest network, and they get an IP address but can't get to the internet. 

    Like
      • Jeff C.
      • eero Community Manager
      • Jeff_C
      • 4 yrs ago
      • Reported - view

      erikjoha  —

      If you haven't yet, could you please contact eero support so we can take a look?

      Feel free to give us a call at 1-877-659-2347 or email us at support@eero.com .

      Like
      • erikjoha
      • erikjoha
      • 4 yrs ago
      • Reported - view

      Jeff C. I opened a ticket over email right after I posted here. Hopefully we can figure out what’s going on quickly. 

       

      Thanks!

      Like
      • erikjoha
      • erikjoha
      • 4 yrs ago
      • Reported - view

      Is anyone else experiencing this problem regularly? I restarted the gateway eero the first time based on what support told me - then it happened again 5 days later, I again restarted the gateway to fix it, but I shouldn't have to restart the gateway regularly to keep the guest network running?

      Like
  • I’ve been having a REALLY odd issue that’s similar in nature to this, but on my main network. YouTube seems slow two load, and then doesn’t buffer properly. If I switch over to my guest network, it works just fine. I’m lost at how to fix this.

    Like 1
  • Jeff C. I have the exact same issue: Guest internet used to work then stopped, on all of my 4 eero's. This is for our AirBnB and I simply can't not have wifi for our guests. I had to go buy another router just for guest wifi! You have been directing everybody above to contact support for 1 year now. I contacted support too, spent an hour troubleshooting, with no help.  They said they escalated to tier-2. Still no documented answer?  Between this and the lack of PPPoE support (separate thread) I'm really regretting this purchase x4. FWIW, I'm using my eeros in bridge mode (per the non-supported PPPoE needed by century link fiber) but the problem remains in full-router mode too, across phones, tablets and laptops)  I also reset the gateway eero before returning to bridge mode

    Like
      • Jeff C.
      • eero Community Manager
      • Jeff_C
      • 4 yrs ago
      • Reported - view

      Denash97227 —

      Thanks for taking the time to reach out and I'm sorry to hear you're experiencing an issue with your guest network. This isn't something we often see, and hopefully, our tech support team will be able to identify what is going on and get this resolved for you in a timely manner.

      Not every issue reported above have been similar in terms of cause, so we don't have a documented set of steps to take besides for the troubleshooting steps our team has had you go through, including:

      • Disabling and re-enabling the Guest Network
      • Power cycling your eero network
      • Power cycling your upstream network modem and/or router

      Working with tier-2 support, as well as our engineering team, our team will work to identify the issue you've reported and provide any necessary next steps.

      Thanks for your patience and understanding.

      Like
  • This happened to me on day 1 with a brand new Eero. Is there any way to fix the issue? Why is it even happening?

    Like
      • Jeff C.
      • eero Community Manager
      • Jeff_C
      • 4 yrs ago
      • Reported - view

      bigsimpfan  —

      Sorry to hear the issue you're experiencing. If you could please shoot us an email to support@eero.com or call 877-659-2347, we'll be happy to help.

      Like
  • This is STILL a problem, over one year later!!! The “solution” to just soft reset the entire network in my house on a regular basis is absolutely ridiculous. Why can’t you just fix this, eero? Do you realize how bad this is from a marketing standpoint?!? Guests on my network complain the network isn’t working, and I have to say “sorry, this eero system I paid a bunch for just randomly stops working for guests, and I need to reboot the router”. I doubt anybody who experiences this at my house is running out to spend $300 on one of your routers.

    Like 1
      • Dnash97227
      • Denash97227
      • 3 yrs ago
      • Reported - view

      jonbirge  FWIW, one of my 4 eeros got sick and I was unable, even with support trying to help, to root cause the failure so I took that unit offline and bought a used one on ebay. the replacement has been working since (incl guest network). Unsatisfying that I neither found out nor corrected what caused this problem. Several of my eeros are mounted on high ceilings and thus difficult to access & power cycle.  For a cloud--connected system, seems to me that our units should be all rebootable / resettable remotely. 

      Like
  • Was facing same issue 

    Like
  • Was this issue ever resolved?  After numerous complaints about not being to connect to the network, I have traced the problem to this same issue ... guests are able to connect to the guest network, but are not able to connect to the internet!  A reset fixes the problem for awhile, then same problem happens again.  It's very unreliable, it will seem to fix itself and then will quit working ... super frustrating for kids who have a limited time to finish a test online!

    Like 1
      • TechGuru
      • Techguru
      • 1 yr ago
      • Reported - view

      It’s resolved for me.

      Like
  • One of my customers has this problem since Day 1 with his Eero system.  He does have a Static IP address from his internet provider.  A soft reset usually fixes it.  We sometimes have to do a couple of soft resets.  I have had 2 eero systems at home with no problems at all but I don't have a static ip.  Could the static IP cause the issue?  Is there anything I can do to isolate the issue / find which Eero might be having a problem?  Thanks!  

    Like
  • Possibly a bug in the latest firmware

    Like
  • Frustrating that 4+ yrs later this is still an issue with eero. We have had constant problems all this last year. Many troubleshooting events and connectivity is always a question. Guest network went off in the latest loss of WiFi after a power outage rebooted the whole

    system. Everyone can log on successfully but there is no WiFi. Just continual. All the problems mentioned in this thread have not been resolved. Even with buying the upgraded pro 6 as suggested. 

    Like
  • I’m having exactly the same issue.  I have six eeros (3 pro 6 and 3 pro).  Various devices connect to the main network but have no internet access.  They can connect via the guest network.  The strange thing is that when they connect to the main network they are being assigned the wrong IP address. The address is not from the subnet assigned to the main network.   It looks like they are being assigned an address from the guest pool starting 192.168.10.  Obviously there will not be a route to the internet with the wrong address on that interface.  
     

    Like
  • Manually assigning an IP address to my iPad’s MAC address and then reconnecting to the main network seems to resolve the issue.  At least so far….

    Like 1
    • Hello carl ,

      Thank you for reaching out to us and welcome to the Community! The eeros should not be assigning any addresses outside of the subnet range that is set in the eero app. Have you reached out to our support so we can take a look at this and help you identify the cause? If not and you would like to reach out you can use the link below to find the best number for you to call to reach out tech support.

      https://support.eero.com/hc/en-us/articles/207376426-How-do-I-contact-eero-support-

      Also, if you would rather troubleshoot over email you can follow the directions I will be sending to you over direct message shortly.

      Like
    • James 

      The eeros should not be assigning any addresses outside of the subnet range that is set in the eero app. 

      To clarify, is it expected for the main network and guest network to use the same address range? (This has been the case on previous, non-eero routers I've owned.)

      When I see this problem, all affected devices on the guest network are getting IP addresses from a different range.

      Like
    • HolisticDeveloper The Guest Network and the Main Network use different subnets, so they will assign different IP Addresses. 

      Like
  • The Eero's aren't compatible with iOS 15 or 15.1(beta).  See my thread below.

    Like
  • I have also had the issue.   It’s a DNS issue within the guest network.  If you go into your iOS device and manually add the DNS to 8.8.8.8 that should correct the issue. Soft reset only corrects the issue until it doesn’t work again.  If you’re like me and don’t want to continuously reset things this is a better fix until Eero creates a permanent software fix/update.   Hope this is helpful 

    Like 2
      • packerman8
      • packerman8
      • 7 mths ago
      • 1
      • Reported - view

      FawcettP - Thank you.  This fixed the issue.  I created documentation for my customer with how to do it on Android, Windows, and IOS devices.  Let's hope Eero can finally fix it now that they know what the problem is.

      Like 1
      • mc714
      • mc714
      • 7 mths ago
      • 2
      • Reported - view

      FawcettP Created an account to note that this was very much appreciated and was the answer (Band-Aid) to the issue I too am having. The problem is that every device (i.e., every guest) then has to be talked through how to switch DNS from Automatic to Manual, and then enter 8.8.8.8. My aunts, uncles, grandparents, and young nieces and nephews surely don't know how to do that themselves. So hopefully is on the radar of engineers to actually FIX (and not have to do the work-around noted above). 

      Like 2
      • jbmia
      • jbmia
      • 2 mths ago
      • Reported - view

      FawcettP  I've had this issue since day 1.  Like several years now... and the dhcp address override does work... but as pointed out.. who the hell wants to walk every user through that process.. completely defeats the purpose.  This issue completely, and I mean completely mars what would would otherwise be an awesome solution.  I'll likely be moving off this platform when it's time for an upgrade because of this.. this is a 3 year old thread... sheesh eero.. get it together.

      Like
  • Let’s hope with the latest update this gets resolved.  We typically do shared password with guests but kids started using primary to share. Not a fan of having guest on primary network.  

    Like
      • mc714
      • mc714
      • 6 mths ago
      • Reported - view

      FawcettP do we have any idea if Eero is working on this issue / a known ETA? 

      Like
      • FawcettP
      • FawcettP
      • 6 mths ago
      • Reported - view

      mc714 

      Like
      • FawcettP
      • FawcettP
      • 6 mths ago
      • Reported - view

      mc714 no idea I would hope so.  You can contact erro they make you cycle down and restart.  Which temporarily fixes issue.  Other than that I’d see if it fixes after latest updates.  You can check for updates and latest update on the app. 

      Like
  • I recently installed a new cable modem Arris SB6183. I contacted Xfinity to activate it and then I reboot eeros and I thought all were working. A couple days later I tried to connect the guest SSID then the iOS shows no internet connection then routed to a page for me to download Xfinity app for activation. I am not sure if there is something missing that needed to be set in the modem or it just eero's issue.
    I accessed the modem via 192.168.100.1 but didn't see anything for me to set.
    I soft reset eero, unplugged the modem and also tried to add DNS 8.8.8.8. None of them work. The main SSID is working great but the guest SSID just not working. Any idea? Thank you.

    Like
      • iAMme
      • iAMme
      • 6 mths ago
      • 2
      • Reported - view

      I was testing it on an iPhone 8 Plus. After I turned off private WiFi address with manual dns 8.8.8.8 then it was working. After that I turned the private WiFi address on again then it was still working. 
       

      I tried the dns 8.8.8.8 and 8.8.4.4 on my iPhone 11 and it was working also. 

      hopefully eero can fix the dns issue soon. 

      Like 2
  • Had this issue from day 1 so several months now. Was holding out for a patch to fix it as yes having guests on my main network is not ideal. I will try the 8 point plan to see if I can fix it and go via support I'd not. 

    Like
      • mburford
      • mburford
      • 1 mth ago
      • Reported - view

      mburford I should add that other than the guest network. Zero complaints for rock solid connectivity. 

      Like
Like4 Follow
  • Status Acknowledged
  • 4 Likes
  • 1 mth agoLast active
  • 70Replies
  • 6986Views
  • 39 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com