No "internet" on guest network only?

I have a strange issue that does not allow internet on my guest network only.  It allows the device to connect, but the wireless status on the device says "no internet".  This is happening on many IOS devices, but I did not test on a Windows device.  Any device connected to my primary network works perfectly fine.  Any suggestions?

64replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi everyone —

    If you are experiencing a similar issue, you may want to take the suggested step of performing a soft reset of your gateway eero. To perform a soft reset, hold the reset button until its LED flashes yellow (7 seconds), then release it.

    We also encourage you to contact support. We're more than happy to take a look into what is going on, and making sure we get this all sorted out and resolved for your guest network. Feel free to give us a call at 1-877-659-2347 or email us at support@eero.com .

  • Hi  imajonzin

    Thanks for reaching out and sorry to hear the issue you are experiencing.

    For us to best help troubleshoot this matter, I would suggest giving us a call at (877) 659-2347 or sending an email to support@eero.com . We are going to need some information about your account, which isn't in your best interested being shared in a public space.

    We can always circle back here with the solution that helped resolve this matter for you.

    Thanks again, we look forward to hearing from you and getting this resolved.

  • Same issue here. Appears to work intermittently.  Not just limited to apple devices.   Any simple solution?

    Like 1
  • same issue here - get this "no internet" issue mostly from my guest network, although also happens on main network - happens on iOS devices for me, and for a few guests. just started about two weeks ago. have to either restart device or forget network and rejoin to fix - getting annoying

    Like 1
  • Same issue here. It appears to happen whenever the device on the guest network switches from one eero device to another. From the point of view of the eero app the device is shown as connected to the new device fine and with the original IP but from the point of view of the phone/computer its seems to lose its IP/netmask/dns and assigns itself a default IP from a different subnet. I got it to happen on both IOS and a dell laptop. And for me it only happens on the guest network. 

    Like 1
  • I'm getting the same thing. Main network is fine but nothing can connect to guest network. I'm getting the same "no internet" error as well when I try to select the guest network name. 

  • Same problem for me. I left an email for support@eero.com - haven't heard back yet. Odd that the regular network is not working but the guest is not.

  • I realize eero wants everyone to contact support, which I understand.  I did hear back from support and they game me instructions on how to potentially correct this issue.  I have not tried it yet, so I am not sure if this is a fix, but I will share the basics:


    1)  Disable your guest network in the app

    2) remove all eero guest wifi settings from all devices trying to access guest wifi

    3) do your primary eero last (the one connected to your router) and shut all eeros down by unplugging power and ethernet cables

    4) power cycle your modem

    5) bring modem completely up and then power up the eero connected to the modem and bring that one completely up

    6) bring any other eero devices up one at a time

    7) re-enable guest wireless network

    8) attempt to have devices connect to guest wireless

  • Hi  imajonzin

    Thanks for contacting support. That is one way to do it, however, the first suggestion we would have is performing a soft reset.

    From our help center article:

    A soft reset will clear all network configurations from the eero, but preserve its sessions. This keeps the eero on your network and saves its logs and advanced settings such as IP reservations and port forwarding configurations.

    To soft reset your eero, hold the reset button until its LED flashes yellow (7 seconds), then release it.

    If this does not resolve the issue, you will then want to attempt the other process posted above.

    Please let us know if you have any additional questions.

  • Same problem here.  I performed a soft reset of the primary eero.  Internet connectivity was restored on the guest network.  An hour later, connectivity is lost.  This is the same behavior as when the cable modem is rebooted. 

  • All, 

    The eight step process I described above worked to correct my guest wireless issue.

  • Mine is working now as well, thanks!

  • I was told (by eero support) to swap two of the eero devices.  I did this, and my guest network was restored.  I didn't have to perform a soft reset or do anything else.  


  • While I appreciate the info shared here, it seems like a significant number of users are experiencing this same problem -- numbers sufficient to warrant a software fix, pushed over the interwebs, saving us the trouble of jumping through these hoops.  Is such a fix in the works?  Thank you.

  • This is interesting, I had this issue most likely around the same time as people are reporting and what I did was just unplug my eero that was wireless and then let it reboot.  Once that was completed and the wireless eero synced with the wired one the problem went away and has never returned.

  • Hi  John Cutter

    Thanks for reaching out and welcome to the eero community.

    We are continuing to investigate the issue reported here. If you have had this problem and haven't contact eero support, please do so we can record the instance.

    While it has affected a handful of users, it isn't something we are seeing across all networks. If this appears to be an issue that requires a fix, I will absolutely be updating the status of this thread. Please let us know if it persists after taking the steps above.

  • One other thought in this thread -- the recommendation is to "soft reset the primary eero".  I have a situation where all of the eero's have a hardline backhaul.  Under that case, there doesn't appear to be any way for an end user to know which one is the primary one.  Support was able to tell me which one was primary for my install, but there was no way for me to figure that out on my own, nor does it make sense to me why that particular one is primary -- it's not the first one I set up on the network.  

  • I'm also seeing this issue (unable to obtain an IP address via DHCP on the guest network).  It happens often on the guest network but has now started happening on the main network. 

    This issue started happening after upgrading to eero OS 2.3.0-91

  • Hi  Sal C

    Thanks for chiming in. I'm sorry to hear you are encountering this situation with your guest network. I took a look and I saw you already have submitted a ticket with our team. Thank you for doing that.

    A member of our team should be getting back to you shortly. In the meantime, if you'd like to try the steps provided above, you can see if that helps to resolve the issue.

    Thanks again!

  • Jeff C. 

    Thanks, Jeff.  It's five days later, and I just got around to applying the suggested fixes.  ...Except the problem fixed itself.  Guest network "internet access" is normal.  Let's hope it stays that way.  

    Thanks for the quick and helpful reply.

    John Cutter

    Like 1
  • I've done the same and reset everything, it worked finally and then stopped working once again :(

  • Experiencing the same issue as everyone else here.

  • Hi erik450 and trevorsheridan

    If you haven't yet, could you please contact our support team so they take a look into your network and pass along any findings to the necessary teams? Your outreach will be greatly appreciated.


  • Just encountered the issue for the first time on multiple devices -- if it helps w/ debugging on the eero end, I had just changed the guest password before the problem started. 

  • Just want to add a "me too" to this issue. Have done the "soft reset" and that seems to clear it up... for a time. Then it just comes back. I hope an update is forthcoming with fixes soon.

Like4 Follow
  • Status Acknowledged
  • 1 mth agoLast active
  • 64Replies
  • 6820Views
  • 37 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support