4

No "internet" on guest network only?

I have a strange issue that does not allow internet on my guest network only.  It allows the device to connect, but the wireless status on the device says "no internet".  This is happening on many IOS devices, but I did not test on a Windows device.  Any device connected to my primary network works perfectly fine.  Any suggestions?

73 replies

    • Stephanie_Sy
    • 3 yrs ago
    • Reported - view

    Possibly a bug in the latest firmware

    • Cjwojo
    • 2 yrs ago
    • Reported - view

    Frustrating that 4+ yrs later this is still an issue with eero. We have had constant problems all this last year. Many troubleshooting events and connectivity is always a question. Guest network went off in the latest loss of WiFi after a power outage rebooted the whole

    system. Everyone can log on successfully but there is no WiFi. Just continual. All the problems mentioned in this thread have not been resolved. Even with buying the upgraded pro 6 as suggested. 

    • carl
    • 2 yrs ago
    • Reported - view

    I’m having exactly the same issue.  I have six eeros (3 pro 6 and 3 pro).  Various devices connect to the main network but have no internet access.  They can connect via the guest network.  The strange thing is that when they connect to the main network they are being assigned the wrong IP address. The address is not from the subnet assigned to the main network.   It looks like they are being assigned an address from the guest pool starting 192.168.10.  Obviously there will not be a route to the internet with the wrong address on that interface.  
     

    • carl
    • 2 yrs ago
    • Reported - view

    Manually assigning an IP address to my iPad’s MAC address and then reconnecting to the main network seems to resolve the issue.  At least so far….

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello carl ,

      Thank you for reaching out to us and welcome to the Community! The eeros should not be assigning any addresses outside of the subnet range that is set in the eero app. Have you reached out to our support so we can take a look at this and help you identify the cause? If not and you would like to reach out you can use the link below to find the best number for you to call to reach out tech support.

      https://support.eero.com/hc/en-us/articles/207376426-How-do-I-contact-eero-support-

      Also, if you would rather troubleshoot over email you can follow the directions I will be sending to you over direct message shortly.

      • HolisticDeveloper
      • 2 yrs ago
      • Reported - view

      James 

      The eeros should not be assigning any addresses outside of the subnet range that is set in the eero app. 

      To clarify, is it expected for the main network and guest network to use the same address range? (This has been the case on previous, non-eero routers I've owned.)

      When I see this problem, all affected devices on the guest network are getting IP addresses from a different range.

      • Evan_eero_support
      • 2 yrs ago
      • Reported - view

      HolisticDeveloper The Guest Network and the Main Network use different subnets, so they will assign different IP Addresses. 

    • aaronuae
    • 2 yrs ago
    • Reported - view

    The Eero's aren't compatible with iOS 15 or 15.1(beta).  See my thread below.

    • FawcettP
    • 2 yrs ago
    • Reported - view

    I have also had the issue.   It’s a DNS issue within the guest network.  If you go into your iOS device and manually add the DNS to 8.8.8.8 that should correct the issue. Soft reset only corrects the issue until it doesn’t work again.  If you’re like me and don’t want to continuously reset things this is a better fix until Eero creates a permanent software fix/update.   Hope this is helpful 

      • packerman8
      • 2 yrs ago
      • Reported - view

      FawcettP - Thank you.  This fixed the issue.  I created documentation for my customer with how to do it on Android, Windows, and IOS devices.  Let's hope Eero can finally fix it now that they know what the problem is.

      • mc714
      • 2 yrs ago
      • Reported - view

      FawcettP Created an account to note that this was very much appreciated and was the answer (Band-Aid) to the issue I too am having. The problem is that every device (i.e., every guest) then has to be talked through how to switch DNS from Automatic to Manual, and then enter 8.8.8.8. My aunts, uncles, grandparents, and young nieces and nephews surely don't know how to do that themselves. So hopefully is on the radar of engineers to actually FIX (and not have to do the work-around noted above). 

      • jbmia
      • 1 yr ago
      • Reported - view

      FawcettP  I've had this issue since day 1.  Like several years now... and the dhcp address override does work... but as pointed out.. who the hell wants to walk every user through that process.. completely defeats the purpose.  This issue completely, and I mean completely mars what would would otherwise be an awesome solution.  I'll likely be moving off this platform when it's time for an upgrade because of this.. this is a 3 year old thread... sheesh eero.. get it together.

    • FawcettP
    • 2 yrs ago
    • Reported - view

    Let’s hope with the latest update this gets resolved.  We typically do shared password with guests but kids started using primary to share. Not a fan of having guest on primary network.  

      • mc714
      • 2 yrs ago
      • Reported - view

      FawcettP do we have any idea if Eero is working on this issue / a known ETA? 

      • FawcettP
      • 2 yrs ago
      • Reported - view

      mc714 

      • FawcettP
      • 2 yrs ago
      • Reported - view

      mc714 no idea I would hope so.  You can contact erro they make you cycle down and restart.  Which temporarily fixes issue.  Other than that I’d see if it fixes after latest updates.  You can check for updates and latest update on the app. 

    • iAMme
    • 2 yrs ago
    • Reported - view

    I recently installed a new cable modem Arris SB6183. I contacted Xfinity to activate it and then I reboot eeros and I thought all were working. A couple days later I tried to connect the guest SSID then the iOS shows no internet connection then routed to a page for me to download Xfinity app for activation. I am not sure if there is something missing that needed to be set in the modem or it just eero's issue.
    I accessed the modem via 192.168.100.1 but didn't see anything for me to set.
    I soft reset eero, unplugged the modem and also tried to add DNS 8.8.8.8. None of them work. The main SSID is working great but the guest SSID just not working. Any idea? Thank you.

      • iAMme
      • 2 yrs ago
      • Reported - view

      I was testing it on an iPhone 8 Plus. After I turned off private WiFi address with manual dns 8.8.8.8 then it was working. After that I turned the private WiFi address on again then it was still working. 
       

      I tried the dns 8.8.8.8 and 8.8.4.4 on my iPhone 11 and it was working also. 

      hopefully eero can fix the dns issue soon. 

    • mburford
    • 1 yr ago
    • Reported - view

    Had this issue from day 1 so several months now. Was holding out for a patch to fix it as yes having guests on my main network is not ideal. I will try the 8 point plan to see if I can fix it and go via support I'd not. 

      • mburford
      • 1 yr ago
      • Reported - view

      mburford I should add that other than the guest network. Zero complaints for rock solid connectivity. 

    • jrfred
    • 1 yr ago
    • Reported - view

    eero been great for a year or but just noticed this guest network problem today, neither my or my son's iPhone will open pages (they connect just fine).  However my MacBook Pro is working just fine on this guest network blazing speed.  Everything has been retooted and restarted, forget the network and rejoin, etc.  Main eero network works just fine.  I'm about to try the orange reset button that but is not a fix especially remotely.

    • thefoodjunky
    • 11 mths ago
    • Reported - view

    Having the exact same problem. Guest Wifi has never worked for me. Any user who connected to the Guest wifi gets an Xfinity page instructing me to Download the Xfinity app to activate the internet. A lot of users in this thread seem to be able to get their guest Wifi to temporarily work with a soft reset or through other rest procedures. None of which have worked for me. I have been on with support now for over a month trouble shooting and most recently they are directing me to Xfinity as the problem for eero guest wifi not working. Hey don't get me wrong love to hate on Xfinity but this is squarely not an Xfinity issue. Can we get this listed as a bug and get an actual software update to fix it. It's been 6 years from the first report with no resolution!

    • Faustian
    • 11 mths ago
    • Reported - view

    I'm having this exact issue. I have several Eero Pro 6's in a small office environment... I basically have to provide guests with iOS devices access to the non-guest network as their connection will drop on the guest network. Anything other than iOS devices work fine on the guest network.

    I've done everything - soft resets/factory resets... last software updates... nothing has worked. 

Content aside

  • Status Acknowledged
  • 4 Likes
  • 11 mths agoLast active
  • 73Replies
  • 8524Views
  • 43 Following