7

eero with Gigabit (AT&T Fiber)

So I just upgraded from the cable companies internet with a 100/5mb plan over to AT&T U-Verse and their Gigabit 1000mb symmetric plan. Installation was pretty easy as I just set my main eero in DMZ mode on the AT&T gateway (Pace 5268AC) by following these instructions: http://www.dslreports.com/faq/17804

I use a 2 eero setup that are hardwired with a gigabit switch in between. My eero's set themselves up with no issues and I have blazing fast internet on my hardwired iMac getting 900mb+ up and down.

But my WiFi is the issue. From my iPhone, connected to my primary eero and about 8ft from it I'm only getting upper 100's down. I never expected to be getting my full 1000mb via WiFi but I was hoping to be getting at least half of that. With my cable connection at 100mb down, I would consistantly get speed tests showing me with a download speed of 120-130mb.  And now with a full gigabit pouring through my eero I'm only seeing marginal WiFi improvements up to 170-180mb.

So my question is how can I get better WiFi speeds? Is it even possible for my eero to give me more speed via the WiFi? And my setup is fine, I did a completely new network setup with the gigabit. Completely erased my eero network and started over from scratch. I understand about coverage distance and interference, but even with my iPhone 6 inches away I am barely getting 200mb.

So anything I can do to get more WiFi speed out of my eero's?

37 replies

    • M_tt
    • 6 yrs ago
    • Reported - view

    This is my issue as well. Installed eero pro 3 pack. All Ethernet gig wired direct to uverse fiber gw. Had a bunch of throughput issue, it was like the 3 ports in the gw (set to auto) negotiated down to 100 full and stayed that way. Removed the direct connections and ran to a gig non managed switch, then switch to gw port. Still haven't throughput, connection issues. Haven't changed anything on att gw. IPv6 is off though. Do not have router behind router setup either. Here is the weird thing, these issues come and go. Roaming between eeros is an issue too, mainly on all our iPhone 7's on 5g. Ugh, so lame. Will be calling support today. That DNS reference on this thread is where I am going to start before calling in a bit. Thoughts?

      • Consumer IT Consultant
      • jayman16
      • 6 yrs ago
      • Reported - view

      M@tt Each eero should NOT be plugged in the gateway. They need to be daisy chained to each other. Only one can be plugged into the gateway and that becomes the "master" unit.

      For the last two months I've been testing the Netgear Orbi mesh system. Range and speed were better than eero but I hated dealing with the UI and settings. I just reinstalled my eero's last night and added a third. My WiFi has been awesome. I'm getting about 400/400 everywhere in the house now. I believe there was one maybe two updates since I used the eero's last, so maybe that helped.  They are all 1st gen eeros.

    • Consumer IT Consultant
    • jayman16
    • 6 yrs ago
    • Reported - view

    Here's the speedtest on my iPhone 7 and eero's last reported internal speedtest.

    • M_tt
    • 6 yrs ago
    • Reported - view

    jayman16 this morning before calling support I plugged the 3 eero's into an 8 port non managed gigabit switch, then the switch to the uverse gw. that didn't resolve it either, to your point. So I lobbed a call into eero support and they mentioned the same thing. That setup was crushing my network with all sorts of ip conflicts. so support had me put the system in bridge mode ( of course disabling all PRO features, no issue since i only offer wifi at home for web surfing) and everything seems to be a lot better for now. They said there are issues with uverse gateways and that bridge mode seems to be the best configuration for a cohesive wifi experience. I will update on Monday to see if my issues have totally been resolved...

      • Consumer IT Consultant
      • jayman16
      • 6 yrs ago
      • Reported - view

      M@tt Here's what you need to do. I'd factory reset the gateway and all eero's. To reset gateway go to: Setting>Diagnostic>Resets then select reset to factory default state. (eero is easiest to reset via the app. "Delete network) Then log into the gateway (hardwired from a computer not through an eero) any way you might need to, disable the WiFi, change any settings you wish. Then power it off and hardwire one eero into it. Power them both up and wait 1-2 mins. 

      Log back into the gateway and head to: Settings>Firewall>Applications, Pinholes, and DMZ. Where you see "1) Select a computer" right under that should be your eero. Click it and select the very last radio button "Allow all applications (DMZplus mode)... Click save.

      Then power cycle them both again. After they both come online, head to http://www.dslreports.com/faq/17804 and start at step #9 I just walked you through 1-8.

      After all that, go ahead and setup the eero with your phone. So now you should be good to go. With your gateway turned into a dumb modem and eero doing all the routing and heavy lifting on the network.

      Run some tests with just the one eero installed to make sure everything is working as expected. If your good at that point and you're ready to add more eero's go ahead and power down your gateway and first eero. Then setup your switch and second eero. The connections MUST go this way: Gateway>eero #1>switch>eero #2>eero #3 I'm not sure if eero #3 has to been connected to eero #2 or the switch. Maybe Jeff C.  can help. At any start with just the Switch and eero #2 ready to go and power everything on. After your network is back up setup eero #2. If that works and you're all good setup eero #3, no need to power cycle the system.

      I know it took my first eero setup a few power cycles to get working with the switch. I'm not using one this time, so only my #1 and #2 eero are wired, my #3 is wireless.

      • r/eero Moderator
      • JTswift
      • 6 yrs ago
      • Reported - view

      M@tt I'm with jayman16...

       

      You want to have the first eero going directly to your ATT router. That will leave one ethernet port open on that eero. Then, use the second Ethernet port to connect your Ethernet switch.

       

      The remaining eeros can connect to that switch.

       

      I have ATT uverse and my eeros are not bridge mode, and it's working fine.

    • catmandad
    • 6 yrs ago
    • Reported - view

    I upgraded to AT&T Fiber yesterday.  

     

    I followed the instructions listed by jayman16 and everything worked great.

    I didn't even have to reset my eero's from my old ISP (I had configured it to use OpenDNS and reserved some IP addresses for printers and NAS and I wanted to keep that configuration).

    This "download" speed occurred while my wife was streaming an HD movie at the same time.

    My neighbors have also had AT&T installed, but are complaining about poor Wifi coverage!  They need to get an eero!  (I live in a large condo building with concrete floors separating our first and second floors inside our residence).

    eero really shines in this scenario.  Fast ISP connection, Fast WiFi !

      • catmandad
      • 6 yrs ago
      • Reported - view

      One thing to note....

      eero's speed test (in the iPhone App) reports my speed as 598 down / 515 up. The numbers are more impressive using a website like speedtest.net (using a Mac with a wired connection to the eero).

      • saust
      • 5 yrs ago
      • Reported - view

      catmandad the speed looks good. It just to confirm that was wired correct? What do you see via wireless? I can’t get over 300 but have 1000mbps service. 

      • catmandad
      • 5 yrs ago
      • Reported - view

      saust Yes, my speedtest above is a WIRED connection.  Wireless is slower (WiFi can't achieve gigabit speeds yet).  I have the original eero.  On wireless, I get about 350-425 down, and about 200-225 upload speeds.  This is very dependent on how far away I am from the eero when I run the test.

      My wired home computer will get 930 down, 930 up consistently.

    • grgcombs
    • 6 yrs ago
    • Reported - view

    ditto --- google Fiber here

    • emmawatsun
    • 5 yrs ago
    • Reported - view

    You have written a great post. This is really very helpful to me.

    If you need any technical assistance over routers then contact to Belkin Support Number.

    Visit- https://www.belkinroutersupportnumber.com/

Content aside

  • 7 Likes
  • 4 yrs agoLast active
  • 37Replies
  • 20251Views
  • 16 Following