eero with Gigabit (AT&T Fiber)

So I just upgraded from the cable companies internet with a 100/5mb plan over to AT&T U-Verse and their Gigabit 1000mb symmetric plan. Installation was pretty easy as I just set my main eero in DMZ mode on the AT&T gateway (Pace 5268AC) by following these instructions: http://www.dslreports.com/faq/17804

I use a 2 eero setup that are hardwired with a gigabit switch in between. My eero's set themselves up with no issues and I have blazing fast internet on my hardwired iMac getting 900mb+ up and down.

But my WiFi is the issue. From my iPhone, connected to my primary eero and about 8ft from it I'm only getting upper 100's down. I never expected to be getting my full 1000mb via WiFi but I was hoping to be getting at least half of that. With my cable connection at 100mb down, I would consistantly get speed tests showing me with a download speed of 120-130mb.  And now with a full gigabit pouring through my eero I'm only seeing marginal WiFi improvements up to 170-180mb.

So my question is how can I get better WiFi speeds? Is it even possible for my eero to give me more speed via the WiFi? And my setup is fine, I did a completely new network setup with the gigabit. Completely erased my eero network and started over from scratch. I understand about coverage distance and interference, but even with my iPhone 6 inches away I am barely getting 200mb.

So anything I can do to get more WiFi speed out of my eero's?

29replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi  jayman16

    Thanks for reaching out and sorry to hear the trouble. Let's see if we can help here before escalating to tech support.

    Would you mind sharing a few pieces of information with me?

    • Where is the eero placed? As in, what kind of surface is it on and is covered or encased in anything?
    • Have you tested a wireless speed test from your laptop (if possible since you can do it from the same spot) or the iMac?
    • Have you tried swapping the primary eero with your other eero? To do this, just simply unplug and swap them. No need to go through setup or anything.

    Thanks!

    Reply Like
  • So picture #1 and #2 are my main eero. It's in my office sitting on wood. I live in a small 1600sq ft ranch home that is constructed of brick, cinder block, and plaster walls. While great at being fireproof, not the best for WiFi.  I've sketched up and adding a 5th picture showing our basement setup, where both eero's live. For what it's worth the basement is all new construction, wood and drywall.

    So the main eero is in my office sitting about 4' off the ground on the wood and eero #2 is shown in picture #3 and #4. It is located in our storage room. It sits on top of some metal shelves we have it there, but as you can see I have it pretty well elevated on top of my Drobo box. (Side note: I wish the eero units came with support to mount them on a wall either with holes in the underside of the eero or you could sell a bracket for them to sit in) if I could easily mount my eero I'd have it attached vertically in my joist.

    I have ran tests from all of my devices. My laptop gets the best WiFi results, at about 300-400mb when at the same distance as my iMac. For reference I'm running a 2015 MacBook. However, as I sit here typing this reply I am on my couch upstairs, which places me about 8 feet from eero #2, going only through the couch, hardwood floor, and floor joist. And my speed test result shows me at 110/110mb

    I have not tried swapping the eero's position. I can certainly try that. Out of curiosity, what would that do?

     

    I really appreciate the help. In case it matters, I am an eero beta tester. So I am running the beta app on my iPhone and both my eero's are on software version 2.1.0.

    Reply Like
  • Thanks for following up and for all the details,  jayman16 .

    I think it would be best to have our tech support team take a look so that they can make some suggestions to help improve your wireless speeds.

    Please feel free to give us a call at 1-877-659-2347 or email us at support@eero.com.

    Our team is aware of this topic, so to avoid having to repeat everything when reaching out, please direct them to this community thread. If you decide to call in (typically very little to no wait times), feel free to have whoever you are speaking to reach out to me and I'll be sure they have the right topic here for reference.

    Thanks for your patience and understanding. We look forward to getting this resolved.

    Reply Like
  • Will do, thanks for your help

    Reply Like
  • Went through tons of troubleshooting with support. I must say I'm always very impressed when I have to call eero support. After spending about an hour on the phone I got my WiFi network speeds up to the 400's up and down on 99% of my devices. 

    Part of what fixed it, I believe, is switching to Google DNS, away from my ISP DNS settings.  Either way, I'm considering the matter closed and I thank eero for all there help.

    Reply Like 1
  • Woo-hoo! Awesome to hear  jayman16 🙌

    Glad we were able to get that resolved for you.

    Thanks again for your patience and understanding!

    Reply Like 1
  • Make sure you turn off IPv6 on the Uverse Gateway.  It's caused me many many problems.

    Reply Like
  • imurray2000 Thanks I'll try that see if anything changes. 

    Reply Like
  • imurray2000 You're just talking about the IPv6 LAN enable/disable correct? I just disabled it.

    Reply Like
  • jayman16 that is correct.  A couple of years ago, it stopped all streaming video from working (Vimeo, Facebook, YouTube).  Recently, it would cause the GW to just choke...throughput dropped to like .3dn/.1up.  I still have problems where my network chokes like that.  I have to reboot the Eero or the U-verse GW to fix it...or just wait it out.  This only started when I got the Eero.  However, I did move my U-verse service from across town at the same time so I can't say definitively that it is the Eero.

    Reply Like
  • Jeff C.  Could you please post the instructions?  I am having the same sort of issues.  I am at best getting 90 Mbps up and down although I'm only 10 feet away from the EERO.  I appreciate your help ahead of time!

    Reply Like
  • Hi iamravi

    Thanks for checking in. Are you still experiencing these issues? If so, I would suggest starting out by contacting our support team. They'd be happy to get this resolved for you.

    Feel free to give us a call at 1-877-659-2347 or email us at support@eero.com .

    Reply Like
  • Jeff C. I need to fix this also, I have AT&T Gigabit (gigapower) and my speeds are not what they should be. I have the new three pack 2nd gen eero. I called support and I did not get any solutions to my issue. This is a solved problem, I just need the solution please.

    Reply Like
      • jayman16
      • Consumer IT Consultant
      • 1 mth ago
      • Reported - view

      sjenkins What speeds are you getting? Are your eero’s wired or wireless?

      Reply Like
    • jayman16 one is wired to the att router/modem. I checked with att and it was out of sync with their servers. Hard wired to my Mac I am now getting 550 Mbps down. On the eero with wifi it is 220 Mbps 

      Reply Like
    • sjenkins  Is everything resolved now? Or do you still need help on our end?  Also, have you taken a look at this article: 

      https://support.eero.com/hc/en-us/articles/207988076-Setting-up-eero-with-AT-T-U-verse

      Reply Like
    • Jeff C. the ip pass through instructions are not applicable to my router/modem  I have the 5268AC and I do not know how to enable IP pass through 

      Reply Like
    • sjenkins  —

      Ah, thanks for clarifying. Have you tried the steps that  jayman16 provided to resolve his issue here?

      Part of what fixed it, I believe, is switching to Google DNS, away from my ISP DNS settings.  Either way, I'm considering the matter closed and I thank eero for all their help.

      To change your eero network's DNS, please take the following steps:

      1. Open the eero app
      2. Tap the menu button
      3. Tap Network Settings
      4. Tap Advanced settings
      5. Tap DNS
      6. Select Custom DNS and put in the following
      • Primary: 8.8.8.8
      • Secondary: 8.8.4.4

      After changing it, tap Save in the upper right corner. Your network will reboot, so give it a few minutes to come back online.

      Other things to consider:

      Checking with AT&T

      Make sure your AT&T modem/router combo is in bridge mode. If you haven't yet called AT&T, you may want to do so. For more, here is a discussion from the AT&T forums. However, I'm not sure if that is the most helpful, but it is a place to check.

      Checking back with us

      You can also continue to work with our team. It looks like you received a response from Kaneko yesterday. We'd be happy to continue to help with this so we can work towards a resolution.

      Thanks again!

      Reply Like
      • jayman16
      • Consumer IT Consultant
      • 1 mth ago
      • Reported - view

      sjenkins Make sure you also do this: http://www.dslreports.com/faq/17804

      Reply Like
      • jayman16
      • Consumer IT Consultant
      • 1 mth ago
      • Reported - view

      Jeff C. I know it’s off topic but what is the Max throughput of the eero 2nd gen?

      Reply Like
    • Jeff C. Yes, I have enabled all of your suggestions. I am now getting 250 mbps over the eero mesh network. Thanks for all of the advice and support. 

      Reply Like
    • jayman16 Maximum throughput is the same as 1st-gen. Theoretical maximums are 867 Mbps over 5 GHz and 300 Mbps over 2.4 GHz.

      Reply Like
    • sjenkins  Awesome! Thanks for your patience. I'm happy we were able to get that resolved for you.

      Reply Like
  • This is my issue as well. Installed eero pro 3 pack. All Ethernet gig wired direct to uverse fiber gw. Had a bunch of throughput issue, it was like the 3 ports in the gw (set to auto) negotiated down to 100 full and stayed that way. Removed the direct connections and ran to a gig non managed switch, then switch to gw port. Still haven't throughput, connection issues. Haven't changed anything on att gw. IPv6 is off though. Do not have router behind router setup either. Here is the weird thing, these issues come and go. Roaming between eeros is an issue too, mainly on all our iPhone 7's on 5g. Ugh, so lame. Will be calling support today. That DNS reference on this thread is where I am going to start before calling in a bit. Thoughts?

    Reply Like
      • jayman16
      • Consumer IT Consultant
      • 12 days ago
      • Reported - view

      M@tt Each eero should NOT be plugged in the gateway. They need to be daisy chained to each other. Only one can be plugged into the gateway and that becomes the "master" unit.

      For the last two months I've been testing the Netgear Orbi mesh system. Range and speed were better than eero but I hated dealing with the UI and settings. I just reinstalled my eero's last night and added a third. My WiFi has been awesome. I'm getting about 400/400 everywhere in the house now. I believe there was one maybe two updates since I used the eero's last, so maybe that helped.  They are all 1st gen eeros.

      Reply Like
  • Here's the speedtest on my iPhone 7 and eero's last reported internal speedtest.

    Reply Like
  • jayman16 this morning before calling support I plugged the 3 eero's into an 8 port non managed gigabit switch, then the switch to the uverse gw. that didn't resolve it either, to your point. So I lobbed a call into eero support and they mentioned the same thing. That setup was crushing my network with all sorts of ip conflicts. so support had me put the system in bridge mode ( of course disabling all PRO features, no issue since i only offer wifi at home for web surfing) and everything seems to be a lot better for now. They said there are issues with uverse gateways and that bridge mode seems to be the best configuration for a cohesive wifi experience. I will update on Monday to see if my issues have totally been resolved...

    Reply Like
      • jayman16
      • Consumer IT Consultant
      • 12 days ago
      • Reported - view

      M@tt Here's what you need to do. I'd factory reset the gateway and all eero's. To reset gateway go to: Setting>Diagnostic>Resets then select reset to factory default state. (eero is easiest to reset via the app. "Delete network) Then log into the gateway (hardwired from a computer not through an eero) any way you might need to, disable the WiFi, change any settings you wish. Then power it off and hardwire one eero into it. Power them both up and wait 1-2 mins. 

      Log back into the gateway and head to: Settings>Firewall>Applications, Pinholes, and DMZ. Where you see "1) Select a computer" right under that should be your eero. Click it and select the very last radio button "Allow all applications (DMZplus mode)... Click save.

      Then power cycle them both again. After they both come online, head to http://www.dslreports.com/faq/17804 and start at step #9 I just walked you through 1-8.

      After all that, go ahead and setup the eero with your phone. So now you should be good to go. With your gateway turned into a dumb modem and eero doing all the routing and heavy lifting on the network.

      Run some tests with just the one eero installed to make sure everything is working as expected. If your good at that point and you're ready to add more eero's go ahead and power down your gateway and first eero. Then setup your switch and second eero. The connections MUST go this way: Gateway>eero #1>switch>eero #2>eero #3 I'm not sure if eero #3 has to been connected to eero #2 or the switch. Maybe Jeff C.  can help. At any start with just the Switch and eero #2 ready to go and power everything on. After your network is back up setup eero #2. If that works and you're all good setup eero #3, no need to power cycle the system.

      I know it took my first eero setup a few power cycles to get working with the switch. I'm not using one this time, so only my #1 and #2 eero are wired, my #3 is wireless.

      Reply Like
      • JTswiftheero
      • Just a guy who likes the eero
      • 11 days ago
      • 1
      • Reported - view

      M@tt I'm with jayman16...

       

      You want to have the first eero going directly to your ATT router. That will leave one ethernet port open on that eero. Then, use the second Ethernet port to connect your Ethernet switch.

       

      The remaining eeros can connect to that switch.

       

      I have ATT uverse and my eeros are not bridge mode, and it's working fine.

      Reply Like 1
login to reply
Like Follow
  • 11 days agoLast active
  • 29Replies
  • 1967Views
  • 7 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com


Latest from the eero blog

eero, plus peace of mind

Learn more about eero Plus and how our security suite helps to keep both your devices and everyone in your home safe while online.


Meet a few members of our team