0

Unable to connect Printer to Network

Hello! 

 

I have a Canon MX922 that I'm trying to setup on the new Eero Network I created. When I go through the setup of it on the printer, instead of asking for the network password, it's asking to choose the MAC address to connect to. 

I confirmed the MAC address is the gateway device about 10 feet away from my printer. When I hit connect, the printer will fail to connect it. 

Is there something I need to do in the app to allow this or would I need to reach out to Canon for support? 

 

Thanks in advance! 

12 replies

    • eero_support
    • 3 yrs ago
    • Reported - view

    Hello,

    This could be an issue with the printer trying to connect to the computer via WiFi instead of trying to connect to the WiFi network. When you are going through the steps to connect your printer up to your eero network and you select it, is it then asking for the mac id? I have found Canon's guide on how to connect your printer through the WLAN option. I have shared the link below.

    https://support.usa.canon.com/kb/index?page=content&id=ART139014

    Thank you,

    James

    eero Support

    • tceero
    • 3 yrs ago
    • Reported - view

    I just resolved an issue where my Canon printer would not connect suddenly, and trying to reconnect I wasn't getting asked for the network password. After an hour with Canon tech support the culprit turned out to be having WPA3 enabled. Disabling WPA3 prior to connecting the printer allowed the wifi connection to proceed. Once connected WPA3 can be re-enabled. Hope that helps.

    I would like to request that Older security protocols be supported even with WPA3 enabled.

    • ChrisDesAZ
    • 2 yrs ago
    • Reported - view

    Thanks for your assistance. Turning off the WPA3 feature temporarily thus enabled me to connect my canon PIXMA 922 printer, which I really love, to my eero Network. as we stated,as soon as it was connected, I was able to re-enable the WPA3 feature once again. Nice job guys.

    • GerryG
    • 1 yr ago
    • Reported - view

    Thank you all  but can anyone tell me how to disable/reenable the WPA3?  Or where to find how to do this?

    Thank you

    Gerry

    • RocketMan1
    • 1 yr ago
    • Reported - view

    I'm having the same problem connecting my Epson WF-2760. 

    I also have the same question that Gerry has about how to temporarily disable WPA-3. 

      • GerryG
      • 1 yr ago
      • Reported - view

      RocketMan1 

      I finally did find out on my own.  On the eero app go to Settings, Troubleshooting, "My device won't connect"   and you can turn off wifi 5 and 6.  Still hasn't helped me connect my printer or my thermostat though. 

      • RocketMan1
      • 1 yr ago
      • Reported - view

      GerryG  Thanks. I read somewhere, I think possibly on an eero site, that eero won't connect to devices that have an outdated, more vulnerable, security system. I think that's my issue since my printer is at least 5 or 6 years old. I've had no problem connecting to anything else, including my Honeywell thermostats. For most things, I'm connecting at 5 GHz to most things, but I can't seem to solve the printer problem. I've thought about buying a new printer that has the proper security. My current printer is an Epson WF-2860 and it's really noisy when printing, so hopefully they've quietened them down a bit over the years. 

    • Stephanie_Sy
    • 1 yr ago
    • Reported - view

    Make sure to create proper zone, vlan or assign different physical port.

    • GerryG
    • 1 yr ago
    • Reported - view

    So this seemed to have finally worked for me.  On the eero app, I ticked "Discover" and on the bottom ticked "eero Labs" and turned off WPA3.  I then connected as Canon suggests and finally was asked for my password and connected the printer to the eero. Turned WPA3 back on and all seems well.  Hope this helps.

    • Martin
    • 11 mths ago
    • Reported - view

    With me, strangely, the exact opposite worked: I could not connect my brand new Pixma TS6350a, whatever I tried.

    I then ENABLED WPA3. That did the trick.

    Strange world. Canon Support was absolutely useless.

    • wfewster
    • 10 mths ago
    • Reported - view

    To finally get my HP printer to connect with eero, I had to create a new network name for eero, as my devices were apparently still connecting to my old router. I went into Account Settings on the eero app, Wifi name & password, then had to edit my old Wifi network name (you can keep the same password; in my case I changed the network name from Barn House to Barn House 2), then hit save. I then went into my computer's wifi connection setting and connected it to the new Barn House 2 network, and went in to my printer's wifi settings (where you enter the info on the printer itself) to also connect it to the Barn House 2 network, and lo and behold, after hours of messing around with this over the last couple weeks, everything finally works! And it's staying online - I don't have to keep rebooting or reconnecting each time I want to print, at least so far! An eero customer support agent actually coached me through this process.

    • hazydave
    • 6 mths ago
    • Reported - view

    I know this is a bit older, but it still seems to be a problem... and  maybe getting worse. I used to have an MX922 and several other Canon printers, and they worked just dandy on my Google mesh network. 

    I've been setting up a new house, and I put in the eero6+ routers, mostly because my ISP offered a freebie, and I added more nodes (one died, that's another issue, gotta get that back to eero after I do a bit more validation). So far, so good... that's cameras, IPTV, computers, phones, tablets, light switches, plugs, thermostat, the usual stuff. This has been working pretty well since September, other than the one flaked out node. 

    I recently added a Canon TR4720 printer, replacing an aged-out HP that worked just dandy. My PC or phone connected to the Canon, set things up, but the Canon couldn't see the network. What I did: 
    * Tried automatic setup. No dice. 
    * Tried manual setup, picking the specific MAC address of the gateway router in my office, very close to the printer. No dice. 
    * Tried both of these things with 2.4GHz only set. No dice. 
    * Finally tried 2.4GHz mode with the other two routers unplugged. That worked... printer's on the network. I let the network come back to life... seemed good. I sent the printer box on to the recyclers. 

    Whoops... too soon. After the printer powers down (why does it it do that?), next time I power it up, it's lost again. If I take down the network as before, it'll automatically connect. 

    The one annoyance I have with eero specifically is that this would be a 5 minute fix in the old days of regular ordinary routers. With my old Asus I'd make a new SSID at 2.4GHz only, hand that to the printer, and everything would be sunshine and lollipops. But apparently, as we get more sophisticated with all this mostly automatic setup, etc. the actual power of network control is lost. That's sad. I think the Asus router is in a box up in the attic back in Delaware or I'd be busting that one out... yeah, there's a hardware fix for this stuff, but there's always a hardware fix (I'm a hardware engineer, so of course there is). Annoying when a simple software fix should be available.... fewer power dongles, fewer cables, etc. 

Content aside

  • 6 mths agoLast active
  • 12Replies
  • 2518Views
  • 10 Following