0

Unable to connect Printer to Network

Hello! 

 

I have a Canon MX922 that I'm trying to setup on the new Eero Network I created. When I go through the setup of it on the printer, instead of asking for the network password, it's asking to choose the MAC address to connect to. 

I confirmed the MAC address is the gateway device about 10 feet away from my printer. When I hit connect, the printer will fail to connect it. 

Is there something I need to do in the app to allow this or would I need to reach out to Canon for support? 

 

Thanks in advance! 

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello,

    This could be an issue with the printer trying to connect to the computer via WiFi instead of trying to connect to the WiFi network. When you are going through the steps to connect your printer up to your eero network and you select it, is it then asking for the mac id? I have found Canon's guide on how to connect your printer through the WLAN option. I have shared the link below.

    https://support.usa.canon.com/kb/index?page=content&id=ART139014

    Thank you,

    James

    eero Support

    Like
  • I just resolved an issue where my Canon printer would not connect suddenly, and trying to reconnect I wasn't getting asked for the network password. After an hour with Canon tech support the culprit turned out to be having WPA3 enabled. Disabling WPA3 prior to connecting the printer allowed the wifi connection to proceed. Once connected WPA3 can be re-enabled. Hope that helps.

    I would like to request that Older security protocols be supported even with WPA3 enabled.

    Like 2
  • Thanks for your assistance. Turning off the WPA3 feature temporarily thus enabled me to connect my canon PIXMA 922 printer, which I really love, to my eero Network. as we stated,as soon as it was connected, I was able to re-enable the WPA3 feature once again. Nice job guys.

    Like 1
  • Thank you all  but can anyone tell me how to disable/reenable the WPA3?  Or where to find how to do this?

    Thank you

    Gerry

    Like
  • I'm having the same problem connecting my Epson WF-2760. 

    I also have the same question that Gerry has about how to temporarily disable WPA-3. 

    Like
      • GerryG
      • GerryG
      • 1 mth ago
      • Reported - view

      RocketMan1 

      I finally did find out on my own.  On the eero app go to Settings, Troubleshooting, "My device won't connect"   and you can turn off wifi 5 and 6.  Still hasn't helped me connect my printer or my thermostat though. 

      Like
    • GerryG  Thanks. I read somewhere, I think possibly on an eero site, that eero won't connect to devices that have an outdated, more vulnerable, security system. I think that's my issue since my printer is at least 5 or 6 years old. I've had no problem connecting to anything else, including my Honeywell thermostats. For most things, I'm connecting at 5 GHz to most things, but I can't seem to solve the printer problem. I've thought about buying a new printer that has the proper security. My current printer is an Epson WF-2860 and it's really noisy when printing, so hopefully they've quietened them down a bit over the years. 

      Like
  • Make sure to create proper zone, vlan or assign different physical port.

    Like
  • So this seemed to have finally worked for me.  On the eero app, I ticked "Discover" and on the bottom ticked "eero Labs" and turned off WPA3.  I then connected as Canon suggests and finally was asked for my password and connected the printer to the eero. Turned WPA3 back on and all seems well.  Hope this helps.

    Like
Like Follow
  • 1 mth agoLast active
  • 9Replies
  • 340Views
  • 7 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com