1

An alternative to transparent bridging for folks with PPPoE

My internet connection is DSL by Centurylink - when I installed my eero pro 6 three pack, it was repeatedly suggested I configure my combo modem/router (Zytel PK5001Z) to use transparent bridging. Eero doesn’t support PPPoE and the more I read, the riskier this seemed. I’ve chosen an alternate approach that is far simpler and works for me. I just disabled the Wi-Fi radio for the combo box. 

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • While disabling your WiFi radio on the combo box prevents WiFi conflict - it does nothing to provide you the advanced / remote features that Eero has.

    I've called into Support to get either PPPoE to work (which they never told me it wasn't supported) and only received call your internet service provider (CEnturylink).  Wasted hours + days of time trying to take advantage of the advanced security features (why I spent 600.00 dollars) but couldn't do to DSL router. I then found an article setting your DSL router to use a DMZ Hosting - and BOOM, it worked great. I am blown away that Eero support was not helpful at all or even suggesting this.

    Like
  • So I did what Prouty did, too. To avoid putting my eero into bridge mode, I have turned off the wireless radios on my CenturyLink combo modem/router. It still handles DHCP because I have it connected to a switch. I have my eero connected to the switch and let my wireless devices connect to it. The eero has an external IP address of 192.168.1.5 (which it gets from the router). The gateway eero IP address is 192.168.4.1 (with all wireless devices taking an address from this pool... 192.168.4.x on subnet 255.255.252.0). The devices connected to my switch all are in the 192.168.1.x pool on subnet 255.255.255.0.

    Unfortunately, now computers connected wirelessly do not see my NAS on the switch. How do I fix this? Port forwarding? Reservation? Where do I fix this? At the router? the switch? or the eero? DMZ hosting didn't seem to do anything for me that wasn't already working. I seem to have all the advanced features, too. So confused.

    Like
      • cmarinas
      • cmarinas
      • 10 days ago
      • Reported - view

      ImpendingDoon You can connect the eero directly to the router and use the other ethernet port on the eero to connect the switch (so the switch won't be connected to the router directly). Your NAS (and whatver else is on the switch) now gets the IP address now from eero rather than the router.

      Like
Like1 Follow
  • 1 Likes
  • 10 days agoLast active
  • 3Replies
  • 107Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com