2

Slow upload speeds with Eero Pro 6E connected through an AT&T Fiber Gateway

My fiber connection is operating at full symmetrical gigabit speed according to the AT&T gateway, and my Eero Pro 6E gateway is connected by ethernet to the AT&T gateway. The Eero app reports full download speeds of ~950Mbps, but upload speeds hover around 40Mbps (sometimes 22Mbps, sometimes 60Mbps). I have tried all manner of configurations on the AT&T gateway including turning off the firewall, having the Eero use the AT&T gateway's IP address, toggling IPv6, etc., but nothing I do to the AT&T gateway fixes the issue with the Eero's upload speeds. And other devices operate at full bidirectional speed when connected directly to the AT&T gateway by ethernet. Only the Eero gateway is upload bandwidth-limited, and all of my devices connected to the Eero system are affected. I need a mesh system and cannot simply rely on the AT&T gateway. And I'm not sure my issue has anything to do with the AT&T gateway, it might just be a problem with the Eero.

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have the Pro 6 model and also ATT Fiver I get about 950 down and 100 up when I do a test from the Eero gui. BGW210 is in pass through mode. Until recently I was getting 950 up and down. I think is just a display issue as my wireless devices get around 600 up and down, wired is hired. 

    Like
  • Same issue here.   Just upgraded from Eero Pro to Eero 6E.  Speedtest on the Eero app show 900/20.   Speeds on the Eero Pro were always 900/900.    Speed test from wired devices on the network are 900/900 and wireless iPad is 275/250.   All expected - except the 20 up showing from the Eero speedtest app.   I suspect everything is working fine, but the incorrect upload speed is bothering me.  The Eero 6E is connected to an AT&T Pace 1GB router.

    Like
    • Jimstalder To clarify, my speedtests were done with those devices connected to the Eero6E (and not directly to the ATT router).  All devices connected to the Eero 6E show the expected speeds.   Only the Eero app on my phone is showing the slow upload of 20.

      Like
  • Following this thread.

    I just installed my newly purchase eero Pro 6E over the weekend and I am also seeing the same download/upload stats reported from the eero app.  This is really strange and weird.

    Like
  • yep.... still happening to me. 952 down and 73 up via the Eero app on my iPhone. However, 900/900 on any connected device when I go to speedtest.net or most any other common speedtest website. So, I think I'm getting full speed, and feel that Eero must have a bug in the Eero app using the integrated speedtest on the function 6E.

    Like
  • Count me in.  Having the exact same issue everyone else is describing.  Upgraded to the 6E and upload speeds, per the Eero app speed test,  dropped to less than 100 Mbps.  Tests through other GUIs show everything looks good 900-1000 down and up.  

    Like
Like2 Follow
  • 2 Likes
  • 8 hrs agoLast active
  • 6Replies
  • 194Views
  • 5 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com