0

EERO Ethernet throughput drop

I wanted to start out this conversation again because it was so hard to find an answer from any websites.

Quick background: I've had my EERO for about 2 years, and it was working fine on my Xfinity network. I'm signed up for 800Mbps plan, and I used to get such throughput via Ethernet connection to the router.

And then one day, Xfinity updates their network and then my EERO goes from 800 down to 200 overnight. I've tried replacing the cable modem with same brand, same model just new unit, tried upgrading to brand new EERO Pro as main router and nothing had worked. But whenever I reboot my EERO router it would recover the speed for a while (4-6 hours) and then degrade down to 300Mbps again without exception, very consistently.

So, at this point, I returned all of the cable modem and EERO pro and instead changed my main router from EERO to Netgear WAX204 and then went through the hassle of setting up my network again.

As a result, I've noticed the following:

1. It actually resolved the issue, where I continue to received 800Mbps+ for the past 2 days without any issues. (Same EERO behind Netgear router, same cable modem, I've had for the past 2 years)

2. EERO router or EERO pro does not like working as a bridge. My Mesh network becomes extremely unstable when I setup EERO as a bridge, I would get no internet connection throughout the house, only the main room where EERO is connected to the router directly.

What is wrong with EERO ethernet port that is causing this? Why isn't anyone having this problem except for me? Please save me the following basic debugging comments. (1. check your cable, 2) switches in the network etc.) All I did was, keep rest of the LAN the same and  simply switch the cable routing because they are all sitting in the same room. Basically, I unplugged LAN cable from EERO from the cable modem to my Netgear router. And I simply unplug my cable from Netgear and plugged directly into my cable modem. No other changes were made and now my network is working as expected, with minor inconveniences of course because I have two sub nets in my LAN.

So, I would like to get some light on what could be the root cause, is it really EERO router's compatibility issue with my ISP? Or a setting that I'm missing? Why don't I see the same problem with Netgear router, but with EERO?

Thank you for your help!

Reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
Like Follow
  • 4 mths agoLast active
  • 32Views
  • 1 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com