Eero 6 - not connecting ethernet connection (it accepts wifi only)


I bought Eero 6 (triple pack router) few weeks ago. Initially, setup was easy, after installing the gateway, i set up the other 2 routers using the ethernet cables in each room not to lose speed. It was working perfectly until yesterday. Few days ago, the routers updated the latest software. After that, it changed the gateway from one room to another (for no reason). That was still ok and manageable for me, however, somehow i lost the wired connection on the other 2 routers (AP). It is now only connecting through wifi, these 2 routers are just not accepting the ethernet cable at all and i am losing more than 90% of my internet speed because of the forced wi-fi. I tried a looooot of things. I hard reset all the routers, i reset the network, i tried to switch all the cables and the routers and tried to install from scratch. When I re-do the installation of the network, i first connect the first router as gateway, the wired connection is OK in this. When i try to connect the second router, (if i have cable plugged in), the router doesnt get detected so i cannot connect, and i cannot even complete the setup. The moment i remove the ethernet cable from the second router, the installation goes smoothly via wi-fi. That is the same case for my third router too. Because of this, i used to get 750mbps/800mbps internet speeds in all the rooms, now i barely get 30-40mbps. Will you please help to get the issue fixed? I need to use the ethernet cable function for all the 3 routers and that is the reason i bought the eero or else i could have just got few basic repeater.  Will you please help me with a solution? Software version is : V6.12.1.-54. Model number is N010011. 

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Any solution on that? Appearantly some other people are suffering from the same.

  • Hi burak. a

    I would recommend calling into eero support for this issue, sounds like those ports might have gone bad or had an issue with the firmware update: https://support.eero.com/hc/en-us/articles/207376426-How-do-I-contact-eero-support-

    One thing you will want to check on is the topology, we have an article about it here: https://support.eero.com/hc/en-us/articles/360000830546-Examples-of-common-network-topologies

    Make sure you are going modem/router->gateway eero->switch->other eero instead of modem/router->multiple eero

  • The ports are all OK. When i restart the entire network, and when i change to the second or third router as the gateway (with ethernet), there is no issue. That means ethernet ports are working in all 3 routers. I feel like it is the software issue. Is there anyway to install the previous software? Or is there any alternative to that? 

    • burak. a We do not have a way to permanently put on previous firmware versions.  If the ethernet ports are working, we know it isn't a firmware issue anyways.

      This sounds more like topology.  What kind of switch are you using?  Is it an unmanaged switch and does it have QoS?  (QoS doesn't work well with eero to eero communication).


      If anything call into support.

  • I have the same issue, lost my ethernet ports/backhi; overnight/post update, everything has been working fine until now.  4 eeros, no ethernet functionality on all after a minute or two after restarting network.

  • Nothing.  One of my eeros started going offline, I removed it then the network stabilized again.  Factory reset the removed eero and tried to add it again and got the same results.  Even running it just wireless it seems that this one device is distrupting the whole network.  I've a call into eero but bithing useful back as yet.

Like1 Follow
  • 2 mths agoLast active
  • 6Replies
  • 67Views
  • 4 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support