Denon Receiver Connectivity Issues

I have a Denon X-3400H unit that that I cannot get connected to the "main" wireless network. And I'm not alone as someone else reported something similar with a Denon receiver on AVSForum.

If I attempt to manually enter the password on the receiver and join the wifi network, the receiver fails to connect and reports the password is incorrect. Obviously, I typed the password correctly. In terms of the password, I've tried 12 characters (all lower-case), 8 characters, and even 88888888 and 12345678. In the majority* of cases, wifi setup fails with "Password is incorrect".

If I attempt to join using Airplay, iOS reports an unexpected error occurred and the receiver reports the connection failed.

The odd thing is, that it will connect to the eero guest wifi network. Yes, even with the same password as the main wifi.

And of course, I can connect successfully with a hardwire.

==Tests Performed==

I started fresh with a fw reset of the receiver and a reboot of the Eero network. After each test, I performed a network reset on the receiver.

Since I assumed that the issue was the password (being 12 characters all lower-case), I started tests with that assumption:

1. FAIL: The receiver cannot connect to main network by manually entering the password. Receiver reports "Password is incorrect."

2. FAIL: The receiver cannot connect to the main network by using Airplay.

3. SUCCESS: I configured my guest network to use a 11 character password (different password from main). The receiver connected via Airplay.

4. SUCCESS: I configured my guest network to use a 12 character password (added one letter; different password from main). The receiver connected via Airplay.

5. SUCCESS: I configured my guest network to use the same 12 character password as my main network. The receiver connected via Airplay.

6. FAIL: retest of #1 and #2. The receiver can’t connect to the main network.

7. FAIL: I configured my main network to use a 8 character password (trimmed off the last 4 characters). The receiver can’t connect to the main network using Airplay. Likewise, manual password entering encounters the “Password is incorrect.” Error.

*8. PARTIAL SUCCESS: I configured my main network to use a password of 88888888 (eero requires a minimum of eight digits/characters). The receiver connected via Airplay. However, I could not get this to consistently work (e.g, if I removed the network and attempted to re-add it, it would fail).

One other thing – when I do a manual scan of the wireless networks, Denon reports multiple instances of my wifi networks (between 4-6 instances). I’m not sure why that is.

I don't believe the receiver has a defective wireless component. Given that the receiver can connect flawlessly to the guest network, there must be some difference between the configuration of the main network vs. guest network, but given the limited app settings, I can't figure it out.

I have a support case open with Denon as well, but they just want me to do firmware resets and ship the unit it in for repair (I don't believe this is a defective wireless chip in the receiver; I firmly believe this is a software issue either with Denon or Eero or both). 

Has anyone else run into this?

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • 1. Is the name/SSID of your main network just one word, or does it have spaces or any special characters?

    2. The reason your receiver is seeing multiple instances of your network when you do a WiFi scan is because each eero is broadcasting the SSID. The receiver is reporting each of the radios broadcasting the SSID even if though it’s the same name.

  • SSID has spaces. The difference in the SSID between the guest and main is one character (added a "g" at the end of the guest SSID. No special characters.

    Ha, regarding #2, I should have realized that. It's a Monday. :P

    • smithre4 could you try taking out the spaces and see if that fixes the issue?

      • smithre4
      • smithre4
      • 2 yrs ago
      • Reported - view

      cMoo92 I'll give that a try. I originally discounted that as a potential problem given that the receiver connected to the guest network 

      • smithre4
      • smithre4
      • 2 yrs ago
      • Reported - view

      OK, so that is odd. Removing the spaces worked. I can't explain why that made a difference when the receiver could connect to the guest network with spaces, unless the g at the end made a difference? Not sure I want to try that out since I have a connection now...

      main: "FBI Van 22" -> "FBIVan22"

      guest "FBI Van 22g"

    • smithre4 it is certainly odd that the guest SSID works with spaces in it. I admit I don’t understand deeply enough the technical reasons for why spaces and special characters can be hard for certain clients to use, but in my experience removing spaces usually resolves these types of issues (as you now know).

      Glad I was able to help you resolve your issue!

      • smithre4
      • smithre4
      • 2 yrs ago
      • Reported - view

      cMoo92 yeah, definitely odd. Thanks for the help!

  • I have a x-4400h and as of today:

    Denon does not accept WEP security setting. Eero

    use WPA2 PSK AES security. Set your connection MANUAL. Enter Network Name. Set SECURITY to WPA2 PSK AES. Enter your password. Select CONNECT. Works like a champ.

  • I have the exact same issue.  My Denon X-3500h is only 2 months old, but this is the first time I have tried to connect it to our WiFi.  

Like Follow
  • 10 days agoLast active
  • 9Replies
  • 2664Views
  • 4 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support