Can't Access QNAP NAS through EERO

I just switched over from an Asus RTAC66U router to a 2nd gen EERO mesh network.  Everything has gone exceptionally well with one glaring exception.  When I connected my QNAP nas via hardwire,  I can see the QNAP on all of my computers,  but I cannot connect to it.  It seems odd that my computers can see the NAS as a device, but when I go to connect, I get a message saying the NAS is unavailable or not connected.  I have scoured the internet and have only found very complicated threads that talk about creating DNS servers or changing IP addresses on the NAS.  I am not an advanced network guy by any stretch.  Any help would be greatly appreciated!

11replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • as an additional note....it looks like my eero assigns an IP address to my QNAP that is different from the IP address of the QNAP itself of that makes any sense...


    IP address of QNAP when logged into QNAP 192.168.1.x

    IP address of QNAP as seen from eero app 192.168.7.x

  • This type of issue has come up about other NAS products (primarily Synology), and it’s usually related to the IP address settings on your NAS. I’m not familiar with QNAP products, but check to make sure your QNAP is set to DHCP instead of a static IP, and also check the DNS servers it’s listing. You want to make sure it’s getting the DNS server info from the DHCP  server (which is your eero gateway).

    • cMoo92 Thanks for the tip.  Let me see if I can tinker around based on your suggestions and try to get some results!

  • So I have tried configuring 6 ways since Sunday:

    1. Initially created a reservation exception on eero and tried to plug in the IP address of my QNAP NAS.  When I did this, I got an error that the IP address was outside the range of my subnet mask,  whatever that means.

    2. I configured DHCP and DNS on my QNAP to automatically obtain IP address.....still nothing


    When I connect my computer and my NAS to my original router,  all is well and I can both see and access the NAS from my computer wirelessly.


    When I hard wire the NAS to my eero and then try to access the NAS (which my computer can see) through the eero network,  I get an error saying it cannot connect.  

    • mstephens77 when you did Step 2 (of configuring DHCP), did you reboot your NAS? It might need a reboot in order for it actually request an IP address from the eero.

    • cMoo92 I did not restart the system.  I just gave it a try and it looks like I can now connect from my computer.  Thanks for the help!  I really appreciate it :)

  • Back to square one.  After a few days and not changing any settings, The QNAP NAS is visible on my iMac finder,  but cannot be connected to and Qfinder Pro cannot locate the server on the network.  I did not change any settings since the steps that were described above in this post....

  • For what it's worth, although I don't have a QNAP, I do have a Synology NAS and had similar issues with accessing it from my Mac computers (Windows PC's were OK).  In my case it had to do with the SMB implementation Apple uses, it's non-standard/proprietary, so rather than using the standard libraries everyone else does, they rolled their own...  While people are always saying AFP (Apple's own legacy networking protocol) is "on its way out", I've found it still the most reliable way of connecting to a NAS with a Mac computer.  

    When I setup my eero, I found the 'advanced' setting to configure the DHCP range to start with, which is what my static-IP-configured NAS was expecting and consistent with how I am used to accessing my home network.  And in my network I have all DHCP assignments starting at, reserving everything below .100 for static assignments, for things like my printer (which definitely prefers a static assignment) and my NAS.  That has also helped.

    Regarding Apple computers networking issues, in the realm of 'tweaking-techie' things might be to change the version of SMB that your NAS device uses -- SMB 3.0 is the latest standard but people have reported better compatibility with Apple products by lowering the SMB level used in the NAS to SMB 2.0 or even 1.  You might also look into configuring your NAS to be the 'master browser' on your network (you'll have to google this one) to resolve DNS issues.

    Net/net, I think it might be worthwhile to look into setting up a static IP address for your NAS, and always hitting it from your computers using the IP address rather than by NAS 'name'.  So something like afp:// (for Apple) might give you more success, avoiding local DNS issues altogether.

    Also, if you want to use server names instead of IP addresses, try afp://yourNAS.local/your_share.  The ".local" part is apparently important for Mac. 

    One last suggestion is that once you set your NAS up to use a static IP address consistent with your DHCP configuration (the same first 3 numbers in the IP address scheme), you could edit your local HOSTS file on your PC to add an entry for the NAS.  Your machine will always consult a local HOSTS file first before attempting to use a DNS entry to resolve a server name to an IP address. 

    Again, this is techie stuff but unfortunately important to know because unfortunately networking is almost never a plug-and-play affair anymore...

  • I have several QNAPS that I use with Mac computers, and this clearly sounds like an IP or DNS issue.  If your QNAP says it has an IP address of 192.168.1.x, there's your issue, since Eeros default to 192.168.7.x, and for any device to be usable it must match the Eero's gateway and IP range.  Seems it's retaining some IP config assignments in use from your old router.  Try doing a basic reset on your QNAP, which will reset all of your settings to DHCP (hold in reset button about 3 seconds or till it beeps once).  I didn't see you state which model of QNAP you have?  Most QNAPS have a small recessed reset button in back you access with a paperclip.  Alternatively, if that doesn't work, you can set your QNAP to a static IP with your old router with a 192.168.7.x, just make sure the address you choose isn't in use.  It of course won't be visible with the old router once you make this change.

    I'd also make sure you set your DNS server to obtain DNS automatically.  If you manually assign it, use your Eero's gateway ( and you can also add a Google DNS like  Then save that config, and then hook up your Eero.

    Both the IP and DNS config options are on the same page - go to Control Panel--->Network.

    I'd try the soft reset first and only go to the second method if it doesn't work for some reason.  The soft reset should set both your IP to DHCP and your DNS to obtain its server automatically.  Do the soft reset while it's connected to your Eero network.  If you soft reset it while connected to your old router, power down your QNAP completely before connecting it to your Eero network, and then power it back on to ensure it can obtain proper IP and DNS settings.

  • Hi, I just wanted to leave this here for other people who search for 'EERO SAMBA' and related problems. I installed my Eeros (amazing product! entire network up and running in minutes!) and I couldn't see my Linux Samba fileserver. It turned out I had hard coded IP addresses in my /etc/samba/smb.conf. The line was 'hosts allow 192.168.1. ' and my Eero network had changed to using 192.168.4.x I simply changed the line to the new IP addresses 'hosts allow 192.168.4.' , then 'systemctl restart smb' and it worked. Most NAS are running Linux and Samba under the hood and may have that setting somewhere in their config interfaces.

  • Was struggling with not seeing my server for a while. Finally found the solution! :) 

    In the eero app: Settings > Network settings > DHCP & NAT > Bridge

Like Follow
  • 1 yr agoLast active
  • 11Replies
  • 1662Views
  • 6 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support