1

EERO v6.0.4 dropping internet connection

Since my EERO 3-node mesh system was upgraded to v6.0.4, it is dropping offline for 30-120 seconds or more every 2-10 minutes. I am running Network Logger Pro on my Mac which does a Ping or HTTP header request every 20 seconds, so I can see the internet connection going down. I have have detailed error logs showing the dropped connection. This is not an ISP problem, since I can connect the Mac directly to the ISP and Network Logger Pro will show no dropped connection.

Thus far, I have unplugged the 3 EEROS and plugged them back in with no effect.

I disconnected one of the EEROs, still no effect.

It looks like I may have to go back to my old Netgear router to get reliable internet access.

HHHHEEELLLLPPPP!!!!!

24replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi,

    I had the same problem. Do this might solve it. 
    1) Un-plug your eero’s for about 2 minutes. 
    2) plug them back starting with the gateway. 
    3) once they are all up, press the hard reset button on the gateway eero. Keep pressing it until you see the light yellow. Make sure not to over press it as it will reset all the settings if the light went red. 
    4) as soon as the light becomes yellow release and wait for the network to come back on. This might take few minutes. 
     

    this might solve the issue. 

    good luck

    Like 1
      • Brad K
      • Brad_K
      • 11 mths ago
      • Reported - view

      Debbeh Debbeh I followed your steps and did the soft reset, but the problem still exists.

      Like
      • Debbeh
      • Debbeh
      • 11 mths ago
      • Reported - view

      Brad K if you still having issues, the best thing is to call them as they can diagnose your system online and find out if there is anything else is causing this. 

      hopefully it will be solved. 

      Like
  • Seems to be a common problem Eero can't fix.  I have given up trying to deal with support and just live with the constant disconnects.

    Like 2
  • I am experiencing issues with drops and reconnects on my network. I just replaced some of my eero pro's on the network with the new eero pro 6. I was thinking that the issues were with the new eero pro 6 but now I am wondering if it is 6.0.4 software release. I happened to take that update at the same time that I installed these new eero pro 6. I hope that the support team takes a look at this as my kids are complaining to me multiple times a day about the network glitching and them having to reconnect. This needs to get resolved and our community needs your sustaining team's help to fix this. I am happy to work with anyone to figure out where the issues happen. 

    Like 1
    • Chris G We're sorry to hear that you've been experiencing some instability on your network since the latest update. We'd definitely like to work with you and help figure out what's going on here. When you're able to, please email us at support@eero.com with the subject "Community Followup." We look forward to hearing from you!
       

      Kindly,

      Kora | eero Community Team

      Like
  • I'm crossing my fingers that the problem of internet connection failures is solved. Tyler Barrett from EERO suggested swapping my gateway EERO with one of the others, and after the system is running again doing a soft reset on the previous gateway EERO. Well, it seems to have worked so far. I've been running the Network Logger Pro, which alternates pings and sends http header requests every 20 seconds. No connection outages in over one hour. I'm going to let it run overnight before claiming success. However, I'm still puzzled as the cause of the problem.

    Like
      • Debbeh
      • Debbeh
      • 11 mths ago
      • Reported - view

      That’s is good. Hope your problem is solved. 

      Like
  • Ran the network logger for over 24 hours without internet connection being dropped. I consider my problem is solved.

    Like
  • Briefly, I have had problems with internet stability since 6.0.4. I keep having to unplug my modem and gateway to reset back to normal. This fix works for a day or two and then it returns. This problem never existed prior to 6.0.4. I'm suspicious...

    Like 1
  • Same story for me. I upgraded to the PRO 6 hoping it would stop the "dropouts" - and they are still here. I have a 1500 sq foot house with the pro6 as the main, a PRO as a beacon, and a second beacon. The EERO support team's suggestion...move the additional beacons further away. I can't...it's a 1500 sq foot house.  Piss poor support for an expensive router, with ZERO real solutions, when clearly it's a common problem with their device. 

    Like 1
  • This was my first experience with a mesh system. Netgear Nighthawk with an extender was my previous set up. The Eero Pro 6 was super easy to set up. This was 2 weeks ago. During those 2 weeks, I noticed it drop and quickly reconnect a few times, but thought no big deal. Yesterday though, it went offline and despite 2 hours on the phone with customer support, couldn't get even 1 of the 3 nodes to reboot/reconnect. Tech support decided it was my ISP, despite the fact that I could hardwire a PC to the modem and have internet, and reconnected my old Netgear router with no issues.

    Submitted for a return of the Eero system today. :(

    Is this common? I liked the speed and coverage the Eero system provided compared to the Netgear plus extender. Should I try buying it again, or switch to something else?

    The old Netgear was having stability issues and connectivity was "lagging" for the kids playing online, to the point they were getting reported and kicked from the game. The modem and router are set up in the home office in the basement, with the extender in one of the kid's bedrooms (about 2500 sq ft). The Netgear setup provides ok coverage through the house and on the back porch. The Eero system provided a much better speed throughout the house, and coverage extended to the pool area and the pole barn ~75 feet from the house. We were happy happy, until it failed.

    Advice on next steps? Try another Eero system? Something different? Thanks!

    Like
  • Ever since the last eero firmware update, various devices like Nest Protects, Wemo light switches and plugs, etc. are dropped off the network. The only way to get them back on is to reset the network. Never had this issue before the last firmware update. How can I go back to the previous one? Anyone else seeing this? I am on v 6.5.0. 

    Like
    • yld2rob Thanks for posting! We typically do not roll back firmware, except in extreme cases. That said, you are always welcome to give us a call or send in an email so we can investigate this further and see what options we have for resolving this behavior.

      Like
  • Ever since the last eero firmware update, various devices like Nest Protects, Wemo light switches, and plugs, etc. are dropped off the network. The only way to get them back on is to reset the network. Never had this issue before the last firmware update. How can I go back to the previous one? Anyone else seeing this? PC Drivers

    Like
  • Honestly as of this point I feel that eero should do the responsible thing and roll back the update - very irresponsible decision on your part. While all the responses here and in blogs through out the web are pleading for this to be resolved all eero can respond with is to call. So then we call and wait, and wait, and wait - unbelievable. I, along with many, desperately need this resolved considering work remotely and am constantly having to use my cell phone to connect for meetings. Further more we are having to deal with connection issues preventing us from being able to do our jobs efficiently. 

    At this point I think I am going to leverage my skills, as a targeted campaign guru, to position eero in such a way that they will have to either fix the problem promptly or refund me for my investment in them. I believe this is where the beauty of the internet and social media can represent those of us that are being subjected to their poor decision making.

    Like
  • I just purchased a two pack eero pro6 (6.5.1) and I'm having the same issue. I live in a long narrow 1,500sqft apartment. 
    I've tried moving both access points to different locations but it hasn't helped. 
    I get random connection drops and extreme slowdowns constantly. 

    It's not my ISP because this wasn't happening with my old wifi router that I just replaced. 

    If this issue persists, I'll be sending it back in the next few days. 

    Like
      • adf4st
      • adf4st
      • 4 days ago
      • Reported - view

      adf4st 

      I posted two weeks ago about having the same issue. I couldn’t figure it out so I bought an Orbi RBK752 instead and put the router and satellite in the same positions. Speeds are now even faster than with the eero and I’m not experiencing connection drops. 

      Like
  • Same issue here that seems to have started before I upgraded to 6.5.1 (though I see 6.6.0 has been recently "pushed" to me: no release notes so assuming early release from Eero for troubleshooting purposes?).  I feel like the issue is about 3 weeks old though could have been longer and I only pinpointed once I started trying to track the occasional "your Internet connection is unstable" notices from my web conference tools.

    I tracked by running continuous ping (2 second interval) from multiple systems in my home and all experienced timeout at the same moment. Also at that moment, all Internet traffic was disrupted. I've swapped the Gateway Eero with others in the house so that each of the three has now been the Gateway at some point.

    I've tried blocking all but the most essential devices from connecting (note that I've not added anything new so everything on my network has been on my network for over a year).

    I've replaced the Eero with my 10 year old 802.11n router and the problem goes away.

    I've connected directly to my cable modem with one computer and ran the same ping test and the problem goes away (tested for 16 hours straight).

    I've dropped to a single active Eero and the problem persists.

    I've connected to Ethernet on the single active Eero and the problem persists (though other items were still connected via wi-fi).

    Here's what I see (RELIABLE_DESTINATION=whatever you want to ping that you expect reliably responds all the time):

    548 fails Sun Nov 21 07:02:07 EST 2021 64 bytes from RELIABLE_DESTINATION: icmp_seq=25169 ttl=53 time=191.986 ms
    548 fails Sun Nov 21 07:02:09 EST 2021 64 bytes from RELIABLE_DESTINATION: icmp_seq=25170 ttl=53 time=241.700 ms
    548 fails Sun Nov 21 07:02:13 EST 2021 Request timeout for icmp_seq 25171
    549 fails Sun Nov 21 07:02:15 EST 2021 Request timeout for icmp_seq 25172
    550 fails Sun Nov 21 07:02:17 EST 2021 Request timeout for icmp_seq 25173
    551 fails Sun Nov 21 07:02:17 EST 2021 64 bytes from RELIABLE_DESTINATION: icmp_seq=25174 ttl=53 time=51.782 ms
    551 fails Sun Nov 21 07:02:19 EST 2021 64 bytes from RELIABLE_DESTINATION: icmp_seq=25175 ttl=53 time=125.526 ms

    I'm tracking above using this bash command:

    i=0; ping -i 2 -A RELIABLE_DESTINATION | while read pong; do echo "$i fails $(date) $pong"; [[ "$pong" == *"timeout"* ]] && let "i++"; done;

    …so I'm counting both timeouts (551) and total attempts (25175 @ 2 second intervals). Above is after I rebooted all Eeros because it had progressed to 10-15 seconds down every 2-3 minutes. You see from above counts that's about 13 hrs and usual drop is about 3-5 timeouts so 551 ÷ 3(5) = 110-183 drop "sessions" over 13 hrs is about 1 "session" every 3-4 minutes.

    I am told to expect replacement units. I think they are only wanting to replace two of the three so we'll see what, if anything, changes.

    Like
  • I started having issues with signal dropping a couple weeks but only on my laptop computer. Fire Stick, android phone, and Samsung tablet had no issues. I thought it might be anti virus and VPN settings. Switched anti virus and VPN software. Still had issue with signal dropping.

    Figured out an apparent solution today. It appears the signal drop is browser specific and I'm not sure why. If I reboot my laptop and open Firefox the signal will keep dropping. If use Chrome the signal is stable. If I open Chrome and then Firefox, the Firefox browser wifi signal is stable. Not sure why there is an issue with Firefox????

    Like
  • I have Spectrum Internet. I started having random drops from the  system after it was running steady no problems for over a year. Phone calls to both Spectrum and Eero resulted in it getting reconnected and then hours later it disconnects again. I had Spectrum tech out today to check every single thing. They replaced the modem, splitters, cords etc. everything on there end is solid so I can’t think it is anything but the Eero. I will call them tomorrow but here is what I suspect. The Eero wants to update to the new software but when it tries an error occurs and the whole thing disconnects. I have invested a lot of money in the Eero mesh system. I have a large 2 story house with a stone wall in the center. The original set up was done by a technician from Best Buy. I have 4 eero pros and three beacons. Is anyone else having issues with trying to update to 6.6 OS???

    Like
      • mikaworks
      • mikaworks
      • 3 days ago
      • Reported - view

      mikaworks Update: I switched my Gateway Eero that was still stuck on old OS 6.4 with another one of my Eero pros. Wifi was able to connect but I couldn't update that one Eero to 6.6, I called Eero and they were able to update it from their side. I really thought that was the solution and I would have solid Wifi but no such luck it worked for about 3 hours and then all went down. Now Im wondering if that Eero that wouldn't update is bad and causing the system to drop?... We have had the Eero system since 2018 with no issues like this. All started on November 25th with the drops. Still hopeful, more calls to Eero and Spectrum today I suppose.

      Like
  • I ended up buying Google Nest and everything is working now - so it was my eero mesh. I will be requesting Eero refund my devices. Seems like the only answer considering Eero has no interest in customer service.

    Like
      • jeliker
      • jeliker
      • 4 days ago
      • Reported - view

      bsavage Ha! I bought these Eero devices to replace my Google system. We could have traded! 😉 

      On a positive note, either the three replacement Eero devices or the 6.6.0 update seems to have resolved my issue. I’ve been running my same continuous ping all day and have only 4 timeouts for the day so far. 

      Like
Like1 Follow
  • 1 Likes
  • 3 days agoLast active
  • 24Replies
  • 3121Views
  • 19 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com