Setting up Synology NAS on new Eero 6 network

Hello folks,

I am struggling to set up my Synology NAS on my new Eero 6 network. Can y'all help me pretty please?

Currently, the hardware is T-Mobile Modem → Eero 6 Gateway (the one with 2 ports) → network switch → NAS

A few days ago, I used find.synology.com to search my network for the NAS, and it found it at Eventually, that stopped working. Then I tried to go into the Eero Network settings > Reservations & Port Forwarding > reserve an IP address ( for the Synology device. Then I tried find.synology.com, and no beans. After some googling, I read somewhere that Eero only gives out 192.168.7.XXX IP addresses, so I changed the reservation in the Eero settings to ( and it still doesn't work.

I'm stumped. Any help? Can someone outline what exactly I should do to get my NAS setup stably on my network? Please & thank you!

7 replies

    • Pdobb
    • 1 yr ago
    • Reported - view

    I've got an eero and Synology at home, plus my parents have the same in their home. I've not used nor ever really needed to use find.synology.com, I just connect to the Synology by its internal IP address. Just now, I tried find.synology.com and it reports being unable to find my Synology, as well. But it doesn't matter, I don't think. I'm betting that if you wanted that service to work you'd need to open a port to your Synology for it to be findable from the internet.

    So, IMO, just set an IP reservation (as you've done) and connect to that. Also, It shouldn't have to be 192.168.7.X. My reserved IP is 192.168.1.X. So, e.g. I connect to to log in to DSM.

    • InfamousJohnnyB
    • 1 yr ago
    • Reported - view

    Dang, I just ordered a DS220+ And now I‘m reading all these issues with the Eero systems. Hope this works!

      • Pdobb
      • 1 yr ago
      • Reported - view

      InfamousJohnnyB It will be fine 👍

    • Homeuser66.1
    • 1 yr ago
    • Reported - view

    Hi. Did you ever get this solved? I have same issue, but I'm coming from a Motorola mb-8611 modem into the eero and then from the eero to a Netgear switch but I've also tried plugging it directly into the eero and it still won't configure router in the Synology NAS DSM

    • Homeuser66.1
    • 11 mths ago
    • Reported - view

    I'd like to know if this got resolved? I have a similar set up with similar issue. When I go into synology settings, it finds my router but then I have to manually add it, but it's not on the list. Is there another name for an eero pro 6? I have port forwarding on for 1194, that's the specific port for OPENVPN. 

    • Chickenman69
    • 10 mths ago
    • Reported - view

    Anyone find a solution to this? When I try to use the DSM router setup it says it’s compatible but fails when I try to open the VPN ports. It says make sure UPnP is enabled (which it is). Anyway, I bailed on that and I tried opening the ports manually via Eero app but DSM still says “failed” when testing the VPN ports even though they are open and assigned to the NAS ip via the app. Why isn’t Eero supported yet and how do I get VPN working on my synology NAS. 

    • unmeshm
    • 7 mths ago
    • Reported - view

    1. On your Eero app under "Home" click on your Eero Router (named Gateway Eero 6)

    2. Click on "Connected Devices"

    3. Scroll through the list to find your "Synology device" - by default it will show up as SynologyNAS

    4. Click on it - note the ip address e.g.

    5. Open a browser and type

    6. You should be able to launch the setup

    7. In order reserve the above IP and give it a friendly name click on "Settings" at the bottom right in your app

    8. Click on Network Settings

    9. Click on "Reservations and port forwarding"

    10. You should see "SynologyNAS" - click on it

    11. Change the Nickname to something like mydrive.local

    12. Click on Save

    You should now be able to access your NAS by simply entering http://mydrive.local in your browser

Content aside

  • 7 mths agoLast active
  • 7Replies
  • 2023Views
  • 9 Following