Setting up Synology NAS on new Eero 6 network

Hello folks,

I am struggling to set up my Synology NAS on my new Eero 6 network. Can y'all help me pretty please?

Currently, the hardware is T-Mobile Modem → Eero 6 Gateway (the one with 2 ports) → network switch → NAS

A few days ago, I used find.synology.com to search my network for the NAS, and it found it at Eventually, that stopped working. Then I tried to go into the Eero Network settings > Reservations & Port Forwarding > reserve an IP address ( for the Synology device. Then I tried find.synology.com, and no beans. After some googling, I read somewhere that Eero only gives out 192.168.7.XXX IP addresses, so I changed the reservation in the Eero settings to ( and it still doesn't work.

I'm stumped. Any help? Can someone outline what exactly I should do to get my NAS setup stably on my network? Please & thank you!

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I've got an eero and Synology at home, plus my parents have the same in their home. I've not used nor ever really needed to use find.synology.com, I just connect to the Synology by its internal IP address. Just now, I tried find.synology.com and it reports being unable to find my Synology, as well. But it doesn't matter, I don't think. I'm betting that if you wanted that service to work you'd need to open a port to your Synology for it to be findable from the internet.

    So, IMO, just set an IP reservation (as you've done) and connect to that. Also, It shouldn't have to be 192.168.7.X. My reserved IP is 192.168.1.X. So, e.g. I connect to to log in to DSM.

  • Dang, I just ordered a DS220+ And now I‘m reading all these issues with the Eero systems. Hope this works!

      • Pdobb
      • Pdobb
      • 2 mths ago
      • Reported - view

      InfamousJohnnyB It will be fine 👍

  • Hi. Did you ever get this solved? I have same issue, but I'm coming from a Motorola mb-8611 modem into the eero and then from the eero to a Netgear switch but I've also tried plugging it directly into the eero and it still won't configure router in the Synology NAS DSM

  • Be that as it may, it doesn't make any difference, I don't think. That's what i'm wagering assuming you believed that that help should work you'd have to open a port to your Synology for it to be findable from the web.


    website development company in Dubai

Like1 Follow
  • 13 days agoLast active
  • 5Replies
  • 286Views
  • 6 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support