1

Chromecast won’t setup with Eero network problem solved

I struggled for months to get my Chromecast devices working. Factory resets. Router reboots. The whole song and dance. No matter what I tried, the Google Home app would not see the device. Never had time to see it through until today. And I solved it!

Someone said to turn off band steering. So I did. No luck. Then I unplugged all Eero extenders. That did the trick! Chromecast setup is done and the device is working! I wanted to memorialize my success here in case anyone else is having the same trouble. I’ve not turned band steering back on, fwiw, because so I don’t know for sure if it was or wasn’t part of the problem. 

Reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
Like1 Follow
  • 1 Likes
  • 13 days agoLast active
  • 12Views
  • 1 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com